Results 1 to 5 of 5

Thread: Lilliput 8" ribbon cables?

  1. #1
    Variable Bitrate therussman2002's Avatar
    Join Date
    Mar 2004
    Location
    Milwaukee, WI
    Posts
    391

    Lilliput 8" ribbon cables?

    I am having some serious issues with my 8" lilli

    sequence of events:
    1)bios update killed video output on epia m10000
    2)ripped open lilli thinking the controller board ribbon cable was at fault (again)
    3)reseated it at an awkward angle too many times, tore some of the connectors off one end of the cable
    4)cut off that end of cable and tried stripping another connector out of the remaining cable (failed)
    5)ordered the 40pin lilli ribbon cable off digitalww
    6)read on the forums that digitalww takes forever
    7)ordered same cable off digikey
    8)both cables came in 2 days, both are wrong size, the cable in my lilli is lots smaller
    9)guess on part number for 30pin ribbon from digikey
    10)receive 30pin ribbon in 3 days, it is too small
    11)finally count the number of pins on original cable... 32?
    12)try to make 30pin cable work, at certain positions i can only get an upside down & reversed image
    13)tried to cut one of the 40pins down to 32 (failed using a util knife)
    14)tried to cut the other 40pin cable down to 32, succeeded using a paper cutter, but i still only get a white screen when using that one

    anyone ever have any issues with their 8"lilli and replacing/reseating the ribbon cable? i cannot find a 32pin ribbon cable anywhere, and i cannot seem to get this darned display to do anything useful, even after cleaning each cable attempt with alcohol

    gosh pretty soon im gonna find a better use for that alcohol...

  2. #2
    Variable Bitrate therussman2002's Avatar
    Join Date
    Mar 2004
    Location
    Milwaukee, WI
    Posts
    391
    15) broke the flat connector off the back board where aforementiond ribbon cable plugs in

  3. #3
    Constant Bitrate
    Join Date
    Apr 2003
    Posts
    189
    Can you post some pics of the broken connector to show how bad the damage is ?

    I had a 7" Lilli that had a broken connector (the part the slides and locks the cable down). I got the white screen effect - the connector couldn't hold the cable firm enough to get good contact. Fixed that by putting 2 layers of thin Scotch tape on the back of the cable to thicken it. Now it fits into the connector snugly and stays in place quite well even with the bad connector. Someone else mentioned a toothpick trick here - search and see if that works as well.

  4. #4
    Variable Bitrate therussman2002's Avatar
    Join Date
    Mar 2004
    Location
    Milwaukee, WI
    Posts
    391
    the entire part thats soldered onto the board that accepts the ribbon cable is broken off

    i quit the carpc venture

  5. #5
    Maximum Bitrate
    Join Date
    May 2004
    Location
    NJ
    Posts
    558
    Problem is, you went from 1 to 2 straight, you should have tested the Lill on another computer first, you assumed the worst and end up with a bad display - basically, you broke it.

    I know these are not comforting words but reality is, people keep reading that the Lill is POS and it is the user that is at fault.

Similar Threads

  1. Replies: 118
    Last Post: 10-22-2010, 04:05 PM
  2. Lilliput and ribbon cable problems
    By Udonboy in forum LCD/Display
    Replies: 21
    Last Post: 11-08-2004, 08:24 PM
  3. Replies: 3
    Last Post: 09-03-2004, 08:07 PM
  4. Replies: 10
    Last Post: 08-12-2004, 05:45 PM
  5. Lilliput Ribbon Cables
    By Pokey in forum LCD/Display
    Replies: 2
    Last Post: 07-01-2004, 08:22 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •