Page 1 of 4 1234 LastLast
Results 1 to 10 of 31

Thread: HELP! I Screwed up!

  1. #1
    Maximum Bitrate
    Join Date
    Oct 2003
    Posts
    664

    HELP! I Screwed up!

    OK guys, I'm an idiot. I reversed the polarity on my xenarc screen, and now it won't power up. Any ideas on what kind of damage I caused, and what can be done to fix it? Is it just a small peice, or did I fry the whole damned thing? Any way I can fix it myself? PLEASE HELP!

    THANKS,
    Dan

  2. #2
    _
    Join Date
    Mar 2004
    Location
    Little Elm, Texas
    Posts
    13,500
    bump - since I would like to know what others have to say on this as well....

    thinking a diode might be messed up????
    Jan Bennett
    FS: VW MKIV Bezel for 8" Lilliput - 95% Finished

    Please post on the forums! Chances are, someone else has or will have the same questions as you!

  3. #3
    And then I was mod. Tidder's Avatar
    Join Date
    Sep 2003
    Location
    New Mexico, USA
    Posts
    4,207
    I wish I had the answer, but I don't. I just wanted to say, it's been my experience every time I've done this that it just didn't ever work right after...
    Tidder

    Try RevFE
    The best resurrected frontend I've ever used, period.

  4. #4
    Maximum Bitrate Altimat's Avatar
    Join Date
    Oct 2003
    Location
    WI
    Posts
    764
    I'm sure there is a fuse. Call Xenarc their support is great.
    Fabricator

  5. #5
    Variable Bitrate choyak's Avatar
    Join Date
    Jun 2004
    Location
    Buena Park, CA
    Posts
    326
    If it is designed properly, there would be a sacrificial diode after the fuse and the diode will fry and the fuse will blow. Replacing the fuse and the diode will fix it.
    Carputer currently 'ghettoed' into car!!!

    EPIA MII-12000
    Ampie Case with rigged extra USB
    Hitachi 60GB
    Holux GPS mouse with iGuidance 2.0
    Lilliput 7" touchscreen
    Netgear WG121 USB WiFi
    Carnetix P1260

  6. #6
    FLA gospeed.racer's Avatar
    Join Date
    Dec 2003
    Location
    Portland, OR
    Posts
    1,303
    Cross your fingers and open it up...youll see something im sure.

    Once you let the smoke out, its hard to put it back in! You did save it, right?
    2005 Ford Focus ST

  7. #7
    _
    Join Date
    Mar 2004
    Location
    Little Elm, Texas
    Posts
    13,500
    it's already open - there was no front part to the case....

    I also don't remember seeing an internal fuse in there, at least not a fuse in the traditional sense.....??

    there is no plug on the power lead being that it was cut off to hard wire it into the car the first time...

    I know this because I sold him the screen.....there was a note on the plug wire to tell him which lead was positive and which lead was negative
    Jan Bennett
    FS: VW MKIV Bezel for 8" Lilliput - 95% Finished

    Please post on the forums! Chances are, someone else has or will have the same questions as you!

  8. #8
    Registered User mpattonm's Avatar
    Join Date
    May 2003
    Location
    Czech rep.
    Posts
    655
    Fuse can be of SMD type. Its hard to recognize, but it should look transparent and "small sized" )

  9. #9
    _
    Join Date
    Mar 2004
    Location
    Little Elm, Texas
    Posts
    13,500
    right on - right after I posted that I rememberd something about that size/type of fuse.....

    does anyone know where it would be located? or where abouts? like close to where power would enter the board?
    Jan Bennett
    FS: VW MKIV Bezel for 8" Lilliput - 95% Finished

    Please post on the forums! Chances are, someone else has or will have the same questions as you!

  10. #10
    Maximum Bitrate
    Join Date
    Oct 2003
    Posts
    664
    Thanks for the help, guys....I'm looking, but I don't see anything burnt out or anything that resembles a fuse. I will try a magnifying glass and see if that helps. I hope you guys are right about the fuse - there was no smoke or pops or anything whatsoever when I plugged it in wrong....

    Dan

Page 1 of 4 1234 LastLast

Similar Threads

  1. Opinions/Ideas: Possible screwed Lilliput
    By Magma in forum LCD/Display
    Replies: 34
    Last Post: 10-30-2006, 10:59 PM
  2. I think I'm being screwed. Help
    By Rob in forum Off Topic
    Replies: 12
    Last Post: 06-25-2002, 11:30 PM
  3. 4 x 20 LCD screwed up.
    By knix in forum LCD/Display
    Replies: 1
    Last Post: 06-04-2002, 04:56 PM
  4. Screwed up sound
    By Dartman111 in forum General Hardware Discussion
    Replies: 9
    Last Post: 05-11-2001, 03:56 PM
  5. Hard Drive screwed in cold weather!?!!?
    By grandamp3 in forum General Hardware Discussion
    Replies: 8
    Last Post: 11-23-2000, 11:41 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •