Results 1 to 7 of 7

Thread: Audigy NX 2 review

  1. #1
    Low Bitrate
    Join Date
    Nov 2004
    Location
    Northern VA
    Posts
    87

    Thumbs up Audigy NX 2 review

    Well today I grabbed a Sound Blaster Audigy NX 2.

    I hooked it up to my Epia 10k (to replace the onboard sound). Installation was a breeze. I immediately noticed a huge sound quality difference. The music was clearer, could go louder and there was MUCH more bass.

    I didn't experience any of the other issues mentioned here (strange noises coming from the NX, poping, or lots of CPU usage). The only small issue I've run in to, is Frodo's XM app won't mute the line-in upon exit. I think this has something to do with the Audigy's dual mic/line in port. I'll have to investigate further.

    Because I wanted to put the NX behind my LCD, where I had already run a USB cable and installed a USB hub, I spliced a USB cable with the barrel plug connector end of the Audigies power cord. I connected the +5v line on the USB cable to the positive wire, and the Ground line to the negative wire. I was a bit worried that the Audigy would want to pull more current than the USB rail would provide, but this doesn't seem to be an issue.

    The audigy comes with some software of varying degrees of usefulness. One nice thing, is the equalizer software. Some of the other features, like bass boost, seem to be realatively useless, as even at very low levels of "bass boost", you can hear distortion. I think this distortion is pre-speaker - that is, it's is somewhere in the amp/soundcard (I suspect sound card).

    All in all, I'm VERY pleased so far with my purchase, it has made a big improvement in the overall sound quality in my car.

  2. #2
    Newbie
    Join Date
    Mar 2005
    Location
    Tynda, Russia
    Posts
    13
    Don't connect Sound Blaster Audigy NX 2 directly to USB cable power. Use separate power source: for example from PSU, or additional DC-DC converter. And noises will low down.
    Check for the last drivers too.

  3. #3
    Low Bitrate
    Join Date
    Nov 2004
    Location
    Northern VA
    Posts
    87
    Quote Originally Posted by SergeykoR
    Don't connect Sound Blaster Audigy NX 2 directly to USB cable power. Use separate power source: for example from PSU, or additional DC-DC converter. And noises will low down.
    Check for the last drivers too.

    Thanks for the info, but I did not experience noises.

  4. #4
    Newbie
    Join Date
    Jan 2004
    Location
    Bay Area (North)
    Posts
    20
    Glad to hear that you are not running into any issues... when I had one installed in my car, I had some noise issues (occasional clicking noise), but the killer for me was the cpu usage, which was around 20-30% or so, even in stereo mode, which made .wmv and DVD playing problematic on the 10K.

  5. #5
    Newbie
    Join Date
    Mar 2005
    Location
    Tynda, Russia
    Posts
    13
    to eleventh: first time i made connections like you did, and at very high volume (listening rock) in pauses noises was heard.......

  6. #6
    Low Bitrate
    Join Date
    Nov 2004
    Location
    Northern VA
    Posts
    87
    Quote Originally Posted by SergeykoR
    to eleventh: first time i made connections like you did, and at very high volume (listening rock) in pauses noises was heard.......
    Interesting, I'm pretty sure I tested that, but I will double check..

  7. #7
    Variable Bitrate
    Join Date
    Apr 2004
    Posts
    343
    mine runs fine.... ive tested it with an oscilliscope.... no clipping at any volume (no EQ or Boosts on) crystal clear sound always... Check gains on amps.... youre probably clipping the signal...
    Carputer HIFI car stereo project!
    [XXXXXXXXXXXXXXXXXXXXX-]
    95% COMPLETE! FINALIZING SOFTWARE PLATFORM!

    [XXXXXX--------------]
    30% COMPLETE! CAPUTER Version 2.0! Hardware FAILING! CARPUTER BLEW UP! AND NOW MONITOR TOO! WTF?!

Similar Threads

  1. Replies: 7
    Last Post: 02-21-2008, 12:49 PM
  2. Audigy NX sounds like crap
    By Phythorian in forum General Hardware Discussion
    Replies: 6
    Last Post: 03-03-2005, 01:39 PM
  3. Audigy 2 NX left channel only issue? help needed...
    By jedi7001 in forum General Hardware Discussion
    Replies: 2
    Last Post: 02-28-2005, 08:38 PM
  4. Audigy 2 NX full volume after resume
    By STI_FFY in forum Car Audio
    Replies: 4
    Last Post: 11-22-2004, 10:38 AM
  5. Audigy 2 NX and Sub
    By nick9871 in forum General Hardware Discussion
    Replies: 14
    Last Post: 08-18-2004, 10:41 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •