Results 1 to 4 of 4

Thread: Wiring XM Direct internally to motherboard COM port... Having problems

  1. #1
    Maximum Bitrate
    Join Date
    Mar 2005
    Location
    Pomona, CA
    Posts
    456

    Wiring XM Direct internally to motherboard COM port... Having problems

    I have my XM direct unit mounted internally in my case, and have it wired up from the mini-din cable directly to the on board com port with its little plug.

    I have read through all the posts regarding V1 and V2 versions of the pinout, and am still unable to get it to work either way.

    Currently, the XM direct goes to the com port on the motherboards as follows.

    8 pin mini-diin to db9
    pin 1 = pin 2 Data Receive
    pin 2 = pin 3 Data Transmit
    pin 3 = pin 5 ground

    I tried connecting it as a v1 and a v2 style but neither seem to work (refering to the left most picture of the serial port header on the mobo). Do I have the send and recieve pins backwards?





    Also, is there a test program I can use to see if it works without using satradiox? I can no longer find frodos test app.

    Lastly, since this is all internal, where do I ground the shileding?

    Any help is appreciated.

  2. #2
    Maximum Bitrate
    Join Date
    Mar 2005
    Location
    Pomona, CA
    Posts
    456
    I swapped the send and recive pins and upon restart it said "new hardware found" and detected a serial mouse. Not sure what that means. It still did not work in satradiox.

    I am also still not sure where to ground the shielding, if anywhere? The XMdirect unit shares the same ground as the PC case chassis, if that helps any.

    I am clueless here, any help is appreciated.

  3. #3
    Maximum Bitrate
    Join Date
    Mar 2005
    Location
    Pomona, CA
    Posts
    456
    I disabled the serial mouse, and with the pins swapped as:

    8 pin mini-diin to db9
    pin 1 = pin 3 Data Receive
    pin 2 = pin 2 Data Transmit
    pin 3 = pin 5 ground

    no connection of the shielding to anything

    (using the first style serial port header pinout)

    With the above changes, the XM direct unit turns on and I can see the signal indicator, but cannot see track names or artists. I do get the channel names etc, which I did not get before.

    Should I try swapping the pins back?

  4. #4
    Maximum Bitrate
    Join Date
    Mar 2005
    Location
    Pomona, CA
    Posts
    456
    I ended up getting it to work. I should note that it is working just fine with the mini-din shielding not connected to anything.

Similar Threads

  1. XM Problems
    By maestro7879 in forum Road Runner
    Replies: 11
    Last Post: 06-01-2008, 10:58 PM
  2. XM on Carputer THE GUIDE
    By Prindle19 in forum Hardware Development
    Replies: 240
    Last Post: 10-25-2007, 06:02 AM
  3. Replies: 2
    Last Post: 04-27-2005, 02:07 PM
  4. REplacing motherboard...problems?
    By Skipjacks in forum General Hardware Discussion
    Replies: 4
    Last Post: 01-08-2005, 02:27 PM
  5. motherboard port "hack" is EASY!!!!
    By ShinkunoNamida in forum General Hardware Discussion
    Replies: 6
    Last Post: 07-22-2002, 11:37 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •