Results 1 to 7 of 7

Thread: 300 watt power inverter problems

  1. #1
    Newbie
    Join Date
    Feb 2000
    Posts
    12

    Question 300 watt power inverter problems

    I have a walmart brand prestone 300 watt dc to ac power inverter. I am building a mp3 player in my 1996 chevy blazer. I put the power inverter in the back and ran the ground wire straight to the frame. I ran the power wire up to the front to a switch that has a build in led and from the switch to the power wire on the cigarette lighter plug.

    When I flip the switch to power up the system the led comes on but the inverter will not come on. I can take the inverter and plug it into the cigarette lighter plug up front and it will work fine whats the problem???

  2. #2
    FLAC Gutter's Avatar
    Join Date
    Dec 1999
    Location
    Casina, Italy
    Posts
    901

    Post

    Two questions:
    1. What gauge wire are you using and how long is it?

    2. If you have a 300W inverter, you probably have a 30A fuse on it. Is your switch rated at 12VDC@30A?

    Gutter
    http://impee3.hypermart.net
    The Impee3 Car Player

  3. #3
    Variable Bitrate spud42's Avatar
    Join Date
    Oct 1999
    Location
    brisbane,qld,australia
    Posts
    241

    Post

    sounds like your "ground" isnt ground......try running asecond wire up front
    Volvo V40 Phase 2 2002. T4 turbo upgrade.... currently no mp3 or carputer..... researching options

  4. #4
    Newbie
    Join Date
    Feb 2000
    Posts
    12

    Question

    Gutter, I am using 14 guage wire and my switch it a glow dot toggle switch rated 12vdc@ 16amp.

  5. #5
    Newbie
    Join Date
    Feb 2000
    Posts
    12

    Post

    oh my wire is about 15 ft long.

  6. #6
    Low Bitrate
    Join Date
    Dec 1999
    Location
    st. louis
    Posts
    107

    Post

    I'd recommend running the ground to the cigarette lighter ground. That's the way mine is...and it works great.

  7. #7
    FLAC Gutter's Avatar
    Join Date
    Dec 1999
    Location
    Casina, Italy
    Posts
    901

    Post

    14 gauge is way too small for a 15' length. Use 12 or even 10 gauge. The smaller the wire, the more heat is produced which could cause problems later. I don't know if your switch is big enough either. Try Radio Shack's SPST 12VDC@30A switch (Cat. No. 275-712). But first, take Spud42 and Old El Paso's advice and run a second line up to the cigarette lighter. If that doesn't work, then take my advice.

    Gutter
    http://impee3.hypermart.net
    The Impee3 Car Player

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •