Results 1 to 10 of 10

Thread: bit perfect

  1. #1
    _
    Join Date
    Mar 2004
    Location
    Little Elm, Texas
    Posts
    13,500

    bit perfect

    I've posted about this over in the car audio forum, but I'm thinking there may be some folks in the rest of the general public that migh know about it and just not use it in the car audio portion of their carPC installs.

    has anyone on here successfully implemented bit perfect playback on their home or car pc?

    please let me know if you have!
    Jan Bennett
    FS: VW MKIV Bezel for 8" Lilliput - 95% Finished

    Please post on the forums! Chances are, someone else has or will have the same questions as you!

  2. #2
    Constant Bitrate RawsonDR's Avatar
    Join Date
    Dec 2005
    Location
    Dayton, OH
    Posts
    221
    I just recently toyed with this using a Chaintech AV710 for its single stereo Wolfson DAC and kernel streaming with Foobar2000. It seemed to work fine.

    I didn't keep it configured that way, though, because of the problem where only one source can be output at one time. Music, or gps nav, not both. I might toy with using the onboard sound for everything but music, by splitting the amp input and connecting both.

  3. #3
    _
    Join Date
    Mar 2004
    Location
    Little Elm, Texas
    Posts
    13,500
    I've got a Chaintec sitting at home that I was originally going to use, but with it being a standard size PCI card, it's too tall to work in my install, at least it was only $30 when I bought it over a year ago....lol

    After reading up on how to acchieve bit perfect though, I'm going to hold onto this card and use it in a HTPC when I build it here in the future!

    so here's the update on what I've found for anyone reading this thread:

    I did some more searching, and apparently, it's only for .wma format, or CD. I put a cd in and it worked fine. So it won't work for MP3 format apparently. Which is actually fine for me, because then I'll just switch over to the ASIO_out.dll plug in in WinAmp for comps and be good to go...

    So, now I've got CDs to play, but I can't fully test to see if I'm running bit perfect.

    There are two ways to test, check if you have windows sounds, and check and see if you can run a DTS disk (but you need a DTS decoder to do so).

    Test 1 won't work for me since I didn't even install any windows sounds when I made the nLite install for hte carPC. So they aren't even there.

    Test 2 - I put in a DTS disk, and got static.

    So now the trouble shooting begins. I'm going to first go through the H701 and see about setting it up to read/spit out a DTS signal. I haven't even messed with that aspect of the processor since I don't really see a point for 5.1 in a car...

    Once I get that set-up, I'll then try the DTS cd again (the old USACi test CD from 3 years back - they had one in DTS and one in stereo). If that still gives be snow, I'll mess around with the buffers on ASIO4ALL and on the ASIO_out.dll plug in in WinAmp.

    Otherwise, just in enabling 'bit accurate playback' on the Audigy, I'm noticing a more crisp sound, however, I may not have a good test case here to judge that on. I also have a brand new set of kicks with the Focal Be mids in them that I'm trying to break in (need 100+ hours on them), so it could be skewing my test here...lol

    Once I know it's working right, I'll test both ways back to back and see if I notice a difference.
    Jan Bennett
    FS: VW MKIV Bezel for 8" Lilliput - 95% Finished

    Please post on the forums! Chances are, someone else has or will have the same questions as you!

  4. #4
    Constant Bitrate RawsonDR's Avatar
    Join Date
    Dec 2005
    Location
    Dayton, OH
    Posts
    221
    Blah. I'm giving up on it. I can get ASIO to work where playing other sounds fails and causes problems, but a DTS track I downloaded still just plays static. Even if I could get it working, it would only make me spend more time so I could hear other sounds (like gps nav).

    As far as the usefulness, I guess it only matters for audio which isn't at 44.1kHz, right? Aren't CDs 44.1kHz? I guess it depends on what the Windows Kmixer really does to the stream.

    Oh well.

  5. #5
    _
    Join Date
    Mar 2004
    Location
    Little Elm, Texas
    Posts
    13,500
    do you have a DTS decoder?

    Apparently the K-mixer messes with the audio cd as well.

    I've learned that bit accurate only works for .wma files to begin with, which would pretty much negate your last comment about it being useless on cds. If it were useless, how would it have come around in the first place?
    Jan Bennett
    FS: VW MKIV Bezel for 8" Lilliput - 95% Finished

    Please post on the forums! Chances are, someone else has or will have the same questions as you!

  6. #6
    Constant Bitrate RawsonDR's Avatar
    Join Date
    Dec 2005
    Location
    Dayton, OH
    Posts
    221
    I know it's not useless. I'm just trying to gain a better understanding of it so I can determine whether or not I should pursue it.

    Where did you read that it only worked for WMA files? I haven't seen that mentioned. It seems to me that it would work in any situation where the audio source is not 22kHz/channel as Windows wants it to be.

  7. #7
    _
    Join Date
    Mar 2004
    Location
    Little Elm, Texas
    Posts
    13,500
    http://www.driverheaven.net/archive/...p/t-69870.html

    not sure what to think of it though

    :|
    Jan Bennett
    FS: VW MKIV Bezel for 8" Lilliput - 95% Finished

    Please post on the forums! Chances are, someone else has or will have the same questions as you!

  8. #8
    Constant Bitrate RawsonDR's Avatar
    Join Date
    Dec 2005
    Location
    Dayton, OH
    Posts
    221
    Yeah I'm not sure either. (it says WAV btw, rather than wma) Might be an Audigy specific feature - not sure how it relates to ASIO or kernel streaming. For example, the control panel for my Chaintech card lets you choose "Auto" for the standard sample rate mode and will change between 44.1k and 48k depending on the source. Could be the same thing.

    I'm probably just going to forget all about it since I only plan on playing mp3s and such which all seem to be encoded at 44.1kHz anyway.

  9. #9
    _
    Join Date
    Mar 2004
    Location
    Little Elm, Texas
    Posts
    13,500
    Quote Originally Posted by RawsonDR
    (it says WAV btw, rather than wma)
    You are excatly correct, me and myself getting ahead of myself as usual...
    Jan Bennett
    FS: VW MKIV Bezel for 8" Lilliput - 95% Finished

    Please post on the forums! Chances are, someone else has or will have the same questions as you!

  10. #10
    _
    Join Date
    Mar 2004
    Location
    Little Elm, Texas
    Posts
    13,500
    ok - as I posted in the car audio forum:

    ok - I just found out that ASIO4ALL is not needed if you are running the creative drivers since they do the same thing. Good to know. This takes one more thing out of the equation and makes things simpler.

    On a side note, there is a SUBSTANTIAL difference when making the switch on winamp to the ASIO plug in. It pushes the sound stage out a good foot or two. I thought I was crazy and didn't say anything about it, but when Nick Wingate sat in the car and I made the change, he got all giddy and said the exact same thing.

    This is DEFFINATELY worth it for those in the hunt for the best possible sound.
    Jan Bennett
    FS: VW MKIV Bezel for 8" Lilliput - 95% Finished

    Please post on the forums! Chances are, someone else has or will have the same questions as you!

Similar Threads

  1. I'm a bit confused...
    By hematec in forum Road Runner
    Replies: 15
    Last Post: 11-28-2005, 07:01 AM
  2. what bit is this?
    By W6-Ryan in forum LCD/Display
    Replies: 2
    Last Post: 03-17-2002, 05:55 PM
  3. perfect sound with an invertor
    By jose in forum Power Supplies
    Replies: 17
    Last Post: 11-21-2001, 05:44 PM
  4. sproggy power supply drill bit size?
    By Ces///M3 in forum Power Supplies
    Replies: 2
    Last Post: 10-08-2001, 10:19 AM
  5. 20 bit = high color or 256 ??
    By hippie in forum LCD/Display
    Replies: 6
    Last Post: 05-08-2001, 10:12 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •