Results 1 to 7 of 7

Thread: Solenoid blows LED

  1. #1
    Newbie
    Join Date
    Aug 2006
    Posts
    4

    Solenoid blows LED

    Hey guys - I'm stumped here. I'm using the napa st85 85 amp continuos solenoid to power my electric fan. I'm using a 8+ comp panel from 12voltguy.com to power the solenoid. When I turn on the switch to the solenoid, it blows the LED "on" light for that switch. From what everyone has told me, I'm getting backfeed EMF from the solenoid, and that's blowing the LED. I've been told I need to use a diode, but I don't know which one I need or where to exactly put it. I've posted a link to my solenoid wiring diagram - can someone tell me which diode I need from Radio Shack and where exactly to put it? Thanks!

    http://rebelrockrunners.org/Mike/wiring.JPG

  2. #2
    FLAC Jahntassa's Avatar
    Join Date
    May 2005
    Location
    Conyers, GA
    Posts
    1,417
    So you want the Diode to stop backfeed to the switch/LED?

    This should do fine, I would think: http://www.radioshack.com/product/in...entPage=search

    You aren't putting more than a few milliamps through the wire to the solenoid (from the switch) right? If it's less than an amp, then that should do fine. I have used them before for various things, mostly including remote starters.

  3. #3
    Newbie
    Join Date
    Aug 2006
    Posts
    4
    yea - as far as I know - can you see any other reason why the LED would blow? None of the other LED's on my switch panel blow when they turn on gauges, etc

  4. #4
    FLAC evandude's Avatar
    Join Date
    Mar 2005
    Location
    Maine
    Posts
    937
    because a solenoid is a big inductor. when you have current flowing through it and you try to turn it off instantaneously (flipping the switch off) it creates a big voltage spike, which can easily be enough to blow an LED in a coil that big.

    The diode should be connected with the anode to ground, and the cathode (the side of the diode with the stripe) to the "12v switch w/ LED" wire, as it is labeled in your diagram. You can start with the 1N400x diode linked above, which can handle a 30A surge, and if that blows up on you then you can try something like the 1N5404 (also sold at radioshack) that can handle a 200A surge. Either diode will cost you like $1-2 at most.

    if you connect the diode backwards, it will just blow up when you turn the switch on. (probably the same thing that will happen if the diode you use is too small for the coil) usually no biggie with small diodes like that, just a little snap, but maybe wear glasses if you're not sure you have it hooked up the right way
    But don't take it from me! here's a quote from a real, live newbie:
    Quote Originally Posted by Viscouse
    I am learning buttloads just by searching on this forum. I've learned 2 big things so far: 1-it's been done before, and 2-if it hasn't, there is a way to do it.
    eegeek.net

  5. #5
    Newbie
    Join Date
    Aug 2006
    Posts
    4
    awesome - I'll give it a shot - what's the best way to wire in the diode? Strip back some of the coating on each wire and solder each end on? What if you don't have a soldering gun - any other option?

  6. #6
    FLAC evandude's Avatar
    Join Date
    Mar 2005
    Location
    Maine
    Posts
    937
    Quote Originally Posted by offroader423 View Post
    awesome - I'll give it a shot - what's the best way to wire in the diode? Strip back some of the coating on each wire and solder each end on? What if you don't have a soldering gun - any other option?
    soldering it directly to the terminals of the solenoid coil would be the best, if there are any. I'm not sure I'd recommend anything other than soldering, unless you can find a pretty secure way to make the connections, and that would depend entirely on how the terminals/wires are set up on your particular device.
    But don't take it from me! here's a quote from a real, live newbie:
    Quote Originally Posted by Viscouse
    I am learning buttloads just by searching on this forum. I've learned 2 big things so far: 1-it's been done before, and 2-if it hasn't, there is a way to do it.
    eegeek.net

  7. #7
    Newbie
    Join Date
    Aug 2006
    Posts
    4
    well - I put the diode in place, and it fixed the LED problem, but 5 mins later one of my 100w headlights' bulb melted and obviously stopped working. The other one is still working, but I'm wondering if that diode caused it? The lights worked fine before. Here's a wiring diagram of what i've got going on. I'm using one solenoid for my electric fan, and then the starter solenoid, and then a relay for lights. Any suggestions before I just buy a new headlight?

    http://www.rebelrockrunners.org/Mike/diagram.GIF

Similar Threads

  1. Replies: 21
    Last Post: 05-03-2006, 11:28 AM
  2. Power led on xenarc - necessary?
    By Barren in forum LCD/Display
    Replies: 7
    Last Post: 08-11-2005, 11:34 PM
  3. Red LED compass and/or thermo
    By WxGuy1 in forum Hardware Development
    Replies: 2
    Last Post: 08-06-2005, 12:26 PM
  4. Replies: 2
    Last Post: 05-29-2005, 02:29 AM
  5. 3mm LED into 5mm LED holder?
    By Coeus in forum Hardware Development
    Replies: 9
    Last Post: 01-28-2005, 12:18 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •