Results 1 to 5 of 5

Thread: Can I make headphones mute main speakers on an Intel D510MO running tinyXP

  1. #1
    Constant Bitrate
    Join Date
    Mar 2010
    Posts
    159

    Can I make headphones mute main speakers on an Intel D510MO running tinyXP

    I'm using an Intel D510MO system board running tinyXP. I've got my amp connected to the rear audio connectors and everything's working well.
    I'd like to hook up the front audio connector to a headphone jack and have it mute the main speakers when plugged in.

    Here's the problem I'm having...it doesn't look like the standard AC97 connection to the motherboard will mute the main speakers. I took the front panel connectors off an old case I had and didn't get any sound from them.
    There is a chance if I were to use an HD Audio connector it would. But, it's hard to find front panel connectors that say they are HD.

    Is it possible to have the headphones mute the main speakers? Where can I get the HD audio front panel connector?

    Any help would be appreciated.
    Thanks,
    davidk

  2. #2
    Neither darque nor pervert DarquePervert's Avatar
    Join Date
    Apr 2004
    Location
    Elsewhere
    Posts
    13,949
    Try installing the manufacturer-supplied drivers if you haven't already.

    If you have the manufacturer drivers installed, then it may be some functionalitythat is stripped out of TinyXP.
    Yet another reason NOT to use a stripped-out OS that you didn't strip down yourself.
    Have you looked in the FAQ yet?
    How about the Wiki?



    Under normal circumstances, a signature would go here.

  3. #3
    Variable Bitrate Zogg's Avatar
    Join Date
    Apr 2005
    Location
    Plano, TX
    Posts
    311
    A few of the current motherboards with integrated audio will let you switch between the old AC97 wiring and the newer HD audio (Azalia) wiring, but most can't, so you have to use the newer stuff. Almost all my cases are older and I've run into this problem.

    You should be able to find a cable/connector set that will work, and when working properly it will detect when you plug the headphones in. I purchased a SilverStone FP32 http://www.silverstonetek.com/produc...=fp32&area=usa for one case that has audio connections for both AC97 and HD Audio and it works like a champ. You could always pull the wiring out of the metal frame if you don't have an empty 3.5" slot.
    Zotac N630I-D-E M/B w/ Nvidia 7100, E5300 cpu, Xenarc 700IDT, M2-ATX, XP, RR & DFX 5.1.

  4. #4
    Constant Bitrate
    Join Date
    Mar 2010
    Posts
    159
    DarquePervert, it's not tinyXP and I've got the latest Realtek drivers. Part of the problem is that I had disabled the front audio connector in the bios and forgot about it till after I posted.

    Thanks Zogg, I found a pdf showing the wiring for AC97 and HD. It looks like AC97 can disable the rear audio but the cable/connector I got from an old case wasn't wired to do that.
    Also thanks for the link. I'd seen ones like that but none of them specifically said it was HD. Good to know this one will work.

  5. #5
    Constant Bitrate
    Join Date
    Mar 2010
    Posts
    159
    Success!
    Using the diagram on page 25 of the attached pdf showed what an HD connector was wired like. Pretty simple with only a 1k resistor to tell the system it's connected.
    My car already had an 1/8" jack in the center arm rest that was used by the factory head unit. So I took it apart and it was exactly what an HD connector needed. The important thing was a normally open switch that signalled when the jack was plugged in.

    So, now when I plug in headphones the main speakers are muted...but the Realtek software pops up to ask what I just plugged in. Not the worst thing. I only intend on using this when the wife and I take long trips. We just don't like the same music, so she'll have her ipod and I can plug into the carputer. If anyone knows how to disable the Realtek notifications I'd appreciate it.

    Thanks for the help.
    davidk
    Attached Images Attached Images

Similar Threads

  1. 2 questions about the Intel D510MO Board...
    By tritonasaurus in forum Newbie
    Replies: 6
    Last Post: 02-24-2012, 02:28 AM
  2. 800x480 from Intel d510mo MB
    By Slider1385 in forum LCD/Display
    Replies: 20
    Last Post: 12-20-2010, 12:59 PM
  3. Intel D510MO and M3-ATX
    By samail in forum Power Supplies
    Replies: 2
    Last Post: 09-24-2010, 10:28 PM
  4. Slow boot with Intel D510MO board
    By LeroyR in forum General Hardware Discussion
    Replies: 6
    Last Post: 08-21-2010, 02:04 PM
  5. New Mini ITX Motherboard from Intel D510MO/Mount Olive
    By theonlykid in forum General Hardware Discussion
    Replies: 19
    Last Post: 05-20-2010, 09:26 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •