Results 1 to 2 of 2

Thread: iGuidance 3.0 with Onstar Hack won't stay connected

  1. #1
    Variable Bitrate Uraijit's Avatar
    Join Date
    Aug 2007
    Location
    Utah
    Posts
    305

    iGuidance 3.0 with Onstar Hack won't stay connected

    I did the Onstar hack from this webpage on my 2001 Tahoe http://openminds.net/onstar/

    I'm running iGuidance 3.0.

    I have Winoncore installed which allows me to change the GPS mode of the receiver to NMEA Protocol, from Motorola Protocol. However, I can't seem to make it stay in NMEA mode. iGuidance will sometimes be connected for 20-30 min with no problems until I turn it off, and then it might, or might not, still be connected at the next startup...

    Or sometimes it will connect for long enough to change the map to display the correct "current location" and then immediately disconnect. Sometimes I can do an "auto search" in iGuidance, and it will rediscover the GPS and continue working, or sometimes it won't find it at all.

    I have to open Winoncore and play with COM port settings, switch the software back over to Motorola protocol, which will then see the hardware; then switch the software back to NMEA, which sometimes switches the hardware back, and sometimes does not for several tries.

    Then I open iGuidance, and rescan the ports, and sometimes it will find it, sometimes it won't. The problem seems independent of whether Winoncore can see the GPS data stream. A lot of the time when iGuidance loses the signal, Winoncore will still be getting a steady data-stream in NMEA...

    I can't figure it out. I'm thinking it might have something to do with my COM port speed settings, because playing with those seems to be the only thing makes it able to work.

    Best I can tell, in order for the Winoncore to see the hardware while in Motorola protocol, the port must be set at 9600 bps, in both the Xport software, and in the Oncore software. Then the mode must be switched, then both ports lowered to 4800 bps. At which time Winocore will get a fix in NMEA mode... iGuidance discovers it in 9600 bps, and at no other speeds.

    I've changed the COM port speed in the hardware manager to both speeds, and it seems to have no effect one way or another.

    I'm freaking losing my mind here. I can't seem to get things to stay working. Anybody have any ideas what I'm doing wrong? I'd like to test it on another computer, but the only other computers I have are newer model laptops, which don't have COM ports.

    I'm considering buying an RS232-USB adapter and trying it that way.

    EDIT: Oh, and I've already tried removing and reinstalling iGuidance. It had no effect.
    Greedy
    -Adj.
    Anybody who makes significantly more money than you do.

    The Hoe-Puter Worklog

    Progress (Phase one):

    Planning:
    [----------] 97.3%
    Parts Aquisition:
    [----------] 95%
    Install:
    [----------] 95%

  2. #2
    Variable Bitrate Uraijit's Avatar
    Join Date
    Aug 2007
    Location
    Utah
    Posts
    305
    Okay I've played with it some more, and I think I have it working properly.

    I set my COM port to 9600bps, then Xport at 4800bps, then in Iguidance/Oncore bumped it back to 9600. It's functioned reliably for several hours today. The only issue I've had, is off a cold boot into windows, the mouse goes crazy unless I unplug the gps and then plug it back in. I know I just need to change a registry setting to disable the serial mouse. So I think it's all good. I'm still waiting on my new windows license, so i'm not going to bother editing the registry until I get that installed.
    Greedy
    -Adj.
    Anybody who makes significantly more money than you do.

    The Hoe-Puter Worklog

    Progress (Phase one):

    Planning:
    [----------] 97.3%
    Parts Aquisition:
    [----------] 95%
    Install:
    [----------] 95%

Similar Threads

  1. OnStar integraded phone! HACK?
    By TangTang in forum Wireless Communications
    Replies: 25
    Last Post: 03-10-2010, 04:48 PM
  2. Replies: 570
    Last Post: 11-05-2009, 03:49 PM
  3. Onstar hack 2001 Yukon XL
    By reggiek945 in forum GPS
    Replies: 44
    Last Post: 01-24-2008, 09:09 PM
  4. easy way to hack iguidance
    By hari-bhari in forum GPS
    Replies: 8
    Last Post: 11-25-2006, 09:41 PM
  5. new gm onstar hack
    By kasemodz in forum GPS
    Replies: 1
    Last Post: 03-31-2005, 04:08 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •