Page 17 of 32 FirstFirst ... 789101112131415161718192021222324252627 ... LastLast
Results 161 to 170 of 320

Thread: GPSTracker on home server

  1. #161
    Low Bitrate
    Join Date
    May 2007
    Posts
    97
    Quote Originally Posted by Toxic0n View Post
    Just installed the client in the car when I got home and now I'm installing the server on my PC. I did not know the MAC address of the server while I was in the car so I left it blank- hopefully it will be OK; will test it out tomorrow
    It seems to have worked. I just drove to work and used remote desktop to connect to my home PC. I can see one pushpin right outside my work. Is it not supposed to show my car's track?

  2. #162
    Maximum Bitrate boelle's Avatar
    Join Date
    Oct 2008
    Location
    Odense, Denmark
    Posts
    685
    hmm.. for some funny reason i dont get a valid fix....will try some more on sunday

  3. #163
    Variable Bitrate
    Join Date
    Mar 2005
    Posts
    250
    BTW I finally installed this. The vehicle it is going to go in though has registration issues (it is owned by the university and they haven't renewed it so I can't drive it on public streets right now ). I will probably test it out in another car first.

    Questions for Lambo:
    Where will it save the files locally? (Eventually I will set up a server probably)
    Does tracking and retry period refer to milliseconds between updates? So a 5Hz rate would be 200?

    Thanks

  4. #164
    Maximum Bitrate boelle's Avatar
    Join Date
    Oct 2008
    Location
    Odense, Denmark
    Posts
    685
    Quote Originally Posted by lambosprit View Post
    The 600000 is the number of minutes you've set in your client ini file for retry period.

  5. #165
    Maximum Bitrate boelle's Avatar
    Join Date
    Oct 2008
    Location
    Odense, Denmark
    Posts
    685
    getting loads of valid fix's i got a new problem... the client is not contacting the server....

    i even disabled both firewalls and deleted all logs to start from scratch

    how do i proceed in troubleshooting?

    client debug log:

    Code:
    14-11-2009 12:53:33:Info   : GPSTracker client version :3.0.3565.30116
    14-11-2009 12:53:33:Info   : External Server IP address is 192.168.1.2
    14-11-2009 12:53:33:Info   : Internal Server IP address is 192.168.1.2
    14-11-2009 12:53:33:Info   : Home SSID is ********
    14-11-2009 12:53:33:Info   : Server port is 6000
    14-11-2009 12:53:33:Info   : Server pingable is True
    14-11-2009 12:53:33:Info   : Client will send GPS co-ords every 1Secs
    14-11-2009 12:53:33:Info   : Client will try to resend GPS co-ords every 600 Secs when no network connection
    14-11-2009 12:53:33:Info   : Client will send tracking data to your home server?: True
    14-11-2009 12:53:33:Info   : User ID is denblaa
    14-11-2009 12:53:33:Info   : Path to your pictures is: c:\gpspic
    14-11-2009 12:53:33:Info   : Wake on Lan disabled
    14-11-2009 12:53:33:Info   : Speed multiplier set to 1,85
    14-11-2009 12:53:33:Info   : GPS com port set to COM8
    14-11-2009 12:53:33:Info   : GPS baud rate set to 4800
    14-11-2009 12:53:33:Info   : GPS data bits set to 8
    14-11-2009 12:53:33:Info   : GPS data bits set to 6
    14-11-2009 12:53:33:Info   : Client will send anonamous mapping data to MP3car.com.True
    14-11-2009 12:53:33:Info   : Client will delete at least 0  points.
    14-11-2009 12:53:33:Info   : Client will upload mapping data automatically to MP3Car.com.
    14-11-2009 12:53:33:Info   : Your secure user id is 6f0d7d01-89b0-4280-987d-beb3ed166778
    14-11-2009 12:53:33:Info   : Client will send mapping data to MP3car.com via a proxy.False
    14-11-2009 12:53:33:Info   : Proxy IP address is 127.0.0.1
    14-11-2009 12:53:33:Info   : Proxy port number is 8080
    14-11-2009 12:53:33:Info   : Proxy log in name is User to log into proxy
    14-11-2009 12:53:33:Info   : Proxy password is Password to log into proxy
    service log:

    Code:
    14-11-2009 13:02:18:Info   : Service stopping
    14-11-2009 13:02:18:Error  : Unable to start listener. Check GPSTracker not already running in task manager and that the IP address is correct
    14-11-2009 13:02:18:Info   : Service stopped
    14-11-2009 13:02:18:Error  : Error message :System.Net.Sockets.SocketException: En blokeringshandling blev afbrudt af et kald til WSACancelBlockingCall
       ved System.Net.Sockets.Socket.Accept()
       ved System.Net.Sockets.TcpListener.AcceptTcpClient()
       ved GPSTracker.GPSTracker.ListenForConnections()
    14-11-2009 13:02:19:Info   : GPSTracker server version :3.0.3563.41970
    14-11-2009 13:02:19:Info   : Server IP address is 127.0.0.1
    14-11-2009 13:02:19:Info   : Server is pingable: True
    14-11-2009 13:02:19:Info   : Server port is 6000
    14-11-2009 13:02:19:Info   : Sms is enabled: False
    14-11-2009 13:02:19:Info   : Sms numbers are : +000000000
    14-11-2009 13:02:19:Info   : GPSTracker service started
    it's sure this one but not sure.... and a rough translate of the dansih (red text) part would be: a blockingactions was canceled by a call to

    i did try to uninstall and itstall the server again but still the same error.. i did check that another server was not running..

  6. #166
    Maximum Bitrate
    Auto Apps:loading...
    lambosprit's Avatar
    Join Date
    Sep 2006
    Location
    UK
    Posts
    809
    Quote Originally Posted by boelle View Post
    you are right about geofence... just deletede the log and got this in the new one:
    Congratulations. You found a bug

    I've made a fix and attached just the service client. You'll need to delete your tracking.db3 file again I'm afraid but it should work after that.
    Attached Files Attached Files

  7. #167
    Maximum Bitrate
    Auto Apps:loading...
    lambosprit's Avatar
    Join Date
    Sep 2006
    Location
    UK
    Posts
    809
    Quote Originally Posted by sxott View Post
    BTW I finally installed this. The vehicle it is going to go in though has registration issues (it is owned by the university and they haven't renewed it so I can't drive it on public streets right now ). I will probably test it out in another car first.

    Questions for Lambo:
    Where will it save the files locally? (Eventually I will set up a server probably)
    Does tracking and retry period refer to milliseconds between updates? So a 5Hz rate would be 200?

    Thanks
    for the client they are saved in your install directory\data. There is a file called tracking.db3 in there. Its just an sqlite database so you'll need something to open it and see the data stored. First post has a link to a suitable free app.

    Server saves it in C:\Documents and Settings\All Users\Application Data\GPSTracker\data or your equivalent. This is because its not user specific being a service.

    As for tracking period, your calculation is right in theory but not in practice. The app recieves all messages sent by GPS so it will get your gps every time it sends data. However the ini file only lets you specify seconds for the periods so the minimum is 1 sec. Sending the track every 200ms is not practical because its trying to connect over the internet or wireless and you'll have timing issues and probably performance issues. Also the track will look really bad on the service client as you'll have so many pin's. In theory there's nothing stopping it but in practice I dont see the point.

    Also if an alert is set it tracks at 2 seconds regardless of your ini settings

  8. #168
    Maximum Bitrate
    Auto Apps:loading...
    lambosprit's Avatar
    Join Date
    Sep 2006
    Location
    UK
    Posts
    809
    Quote Originally Posted by boelle View Post
    getting loads of valid fix's i got a new problem... the client is not contacting the server....

    i even disabled both firewalls and deleted all logs to start from scratch

    how do i proceed in troubleshooting?

    client debug log:

    it's sure this one but not sure.... and a rough translate of the dansih (red text) part would be: a blockingactions was canceled by a call to

    i did try to uninstall and itstall the server again but still the same error.. i did check that another server was not running..
    I wouldn't use port 8080. Its for normal internet stuff and may e blocked from use by another app. Just pick another number not used by anything else.

    Also when you change the number you need to restart the computer. Stopping the service and restarting it doesn't actually stop the listener which is the error you're getting. I haven't figuired that one out yet.

  9. #169
    Maximum Bitrate boelle's Avatar
    Join Date
    Oct 2008
    Location
    Odense, Denmark
    Posts
    685
    Quote Originally Posted by lambosprit View Post
    I wouldn't use port 8080.
    might be a bit stupid, but did you see that number in my logs? they are both set to port 6000 at client and server

  10. #170
    Maximum Bitrate
    Auto Apps:loading...
    lambosprit's Avatar
    Join Date
    Sep 2006
    Location
    UK
    Posts
    809
    Quote Originally Posted by boelle View Post
    might be a bit stupid, but did you see that number in my logs? they are both set to port 6000 at client and server

    Sorry. Saw your proxy port number and got mixed up. Your port number should be fine

Similar Threads

  1. it works.. auto syncing when you arrive home
    By collegeboyslive in forum General MP3Car Discussion
    Replies: 4
    Last Post: 11-29-2007, 06:36 PM
  2. Home
    By stasik-a4 in forum Map Monkey
    Replies: 1
    Last Post: 06-01-2007, 12:55 AM
  3. Image server
    By qwertylol in forum Software & Software Development
    Replies: 1
    Last Post: 01-10-2007, 03:02 AM
  4. MS Server 2003 help
    By nappyjim in forum Off Topic
    Replies: 3
    Last Post: 05-25-2006, 04:22 PM
  5. Replies: 2
    Last Post: 10-08-2005, 03:01 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •