Results 1 to 4 of 4

Thread: BU-303 & USB Problems...

  1. #1
    FLAC ShawJohn's Avatar
    Join Date
    Aug 2004
    Location
    On the edge!
    Posts
    1,790

    BU-303 & USB Problems...

    Hi Folks,
    I have had my GPS running trouble free for three weeks, until I changed the cabling; I put a USB extension cable in with a non-powered 4port hub on the end, with my GPS, WiFi, and Bluetouth dongles on. All works fine for a short while, then the GPS loses lock, then the WiFi stops working, then the bluetooth, then seconds later the touchscreen stops working and a couple of minutes after the PC reboots and crashed on reboot...!

    XP says that each USB port can support 500mA, and shows that 100mA's is used with all devices plugged in. Is it possible that I am overloading the USB Controller?

    Why does my BU-303 work flawlessly in some USB ports and not others, also the comm port number changes if its USB socket location is changed, why, is there anyway to force it to always use the same port number.

    In one port it will lock before the PC boots and will hold lock constantly, in others it takes an age to lock then loses it every couple of minutes!

    How many devices is it safe to run per port?

    Is the extention cable likely to be causing the problem as non of this occured before I plugged that in... The only other new part was the BT dongle?!?

    I've done the usual and checket baud rate, comm port number etc...

    I'm confused?!?? :-(


    John

  2. #2
    Low Bitrate
    Join Date
    Oct 2003
    Posts
    108
    Damn, post back with results cos that was the next bit of kit I was gonna buy for the same reason
    if you can't find time to do it right, when are you gonna find time to do it over.

  3. #3
    Maximum Bitrate Mad Ad's Avatar
    Join Date
    Oct 2004
    Location
    Hertfordshire UK
    Posts
    533
    Quote Originally Posted by Tuned Vitesse
    How many devices is it safe to run per port?

    Is the extention cable likely to be causing the problem as non of this occured before I plugged that in... The only other new part was the BT dongle?!?

    I've done the usual and checket baud rate, comm port number etc...

    I'm confused?!?? :-(


    John

    USB gremlins eh? In my experience, although USB was *supposed* to be able to chain upto 127 devices, reliability is at its best with just one per port. Any more than that and trial and error is all you have when things dont play together. Some things will tolerate each other on the same bus, others wont and it doesnt seem to matter wether its brand name kit or far east junk.

    Despite its backward compatibility, 2.0 and 1.1 devices can grumble when mixed together and really the only solution is to have at least as many ports on your mobo as you intend to have USB devices.

    Its not a solution but this guy explains it a bit better than I can. http://www.dansdata.com/gz005.htm

  4. #4
    Maximum Bitrate GruvThang's Avatar
    Join Date
    Jul 2004
    Location
    Northern Virginia, USA
    Posts
    683
    I have found that my GPS is very picky about what hub it was installed on and which it runs on. They have to be the same, end of story. If I want to change the port I have to un-install it on the old port (with it plugged in works the best) and install it again on the new port (again, with it moved to the new port).
    [COLOR=Navy][SIZE=1][FONT=Comic Sans MS]Tektility

Similar Threads

  1. Problem with ITPS / hibernation and External USB HD
    By veetid in forum Power Supplies
    Replies: 5
    Last Post: 01-02-2006, 09:35 PM
  2. USB HUB problems????
    By chuckctv in forum Input Devices
    Replies: 7
    Last Post: 10-08-2004, 12:38 PM
  3. usb problems
    By corsamel in forum General Hardware Discussion
    Replies: 0
    Last Post: 10-07-2004, 06:14 PM
  4. Navman USB problems
    By dannn in forum GPS
    Replies: 4
    Last Post: 07-23-2004, 04:19 AM
  5. USB Bandwidth Problems???
    By Altimat in forum Software & Software Development
    Replies: 7
    Last Post: 04-19-2004, 06:20 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •