Results 1 to 5 of 5

Thread: BU 303 GPS reciever died...

  1. #1
    Variable Bitrate
    Join Date
    Jul 2004
    Posts
    260

    Unhappy BU 303 GPS reciever died...

    Yup...I bought the unit and sealed the seams, or at least thought I did. Last week during my 1900 mile trip from Philly to GA to SC back to Philly it POURED...needless to say that this bad boy got moisture inside and now the LED is dim and its not being recognized by Routis. The computer still sees it...but the unit itself is FUBAR-ed. Oh...well I guess time to order a new one...not having GPS sux....

  2. #2
    Maximum Bitrate sfay93's Avatar
    Join Date
    Feb 2004
    Location
    Omaha, NE
    Posts
    777
    I thought mine was messed up by getting water inside too. Open it up and dry it with a hair dryer. I had mine apart for 2 days and then for giggles tried it again and it started working.
    7" Lilli TS, Soyo K7VME, Semperon 2200, 160GB Maxtor, 512mb PC3200, Deluo GPS, Panasonic Slim DVD/CD RW, Linksys WMP545G , Opus 150w, XMDirect, XP Pro, FP, IG [XXXXXXXXX-] 90%
    ATVMS.com

  3. #3
    Constant Bitrate captain_jim1's Avatar
    Join Date
    Nov 2002
    Location
    New Jersey
    Posts
    192
    The week I got mine I left for a cross country trip and back and we encountered all kinds of weather... pouring rain, 100+ deg heat and mine was great! That was in June and it's sat on my roof ever since (except when i go through the car wash). It's poured for days here and the unit's been great! No extra sealing either..

    Of course now i bet it'll break.
    -Brad
    83 mp320i
    99 mp323i
    _________

    7" Lilliput w/Touch, 150 W Opus, 2.4ghz P4 533fsb, 512 DDR 333mhz, GPS, WiFi Inet, 40g Maxtor 7200rpm, Laptop DVD/CD-RW w/USB2.0 Bridge, WinXP Pro.

  4. #4
    Maximum Bitrate carpcnoobie's Avatar
    Join Date
    Mar 2004
    Posts
    565
    Quote Originally Posted by sfay93
    I thought mine was messed up by getting water inside too. Open it up and dry it with a hair dryer. I had mine apart for 2 days and then for giggles tried it again and it started working.

    I had the same problem with mine. Dry it out... let it sit for several days. Mine actually took a couple weeks to dry out. I was just about to order a new one when I tried it one more time. Sure enough, it started working.
    Progress Meter:

    [|||||!||||'] 95% complete

    It's in... it's finally installed!!!! But never finished!

    "It works! It works! I've finally invented something that works!" -- Doctor Emmit Brown

  5. #5
    Variable Bitrate
    Join Date
    Jul 2004
    Posts
    260
    I've still got it and will wait for another couple of weeks and try it again, but I've already ordered a Holux, so soon enough..I'll be back up and running

Similar Threads

  1. CoPilot GPS reciever?
    By saintx in forum GPS
    Replies: 2
    Last Post: 10-18-2004, 11:38 AM
  2. Yet another BU 303 issue
    By G-Han in forum GPS
    Replies: 7
    Last Post: 10-05-2004, 04:59 AM
  3. Using Jap Pioneer GPS reciever in UK?
    By MegatronUK in forum GPS
    Replies: 6
    Last Post: 09-13-2004, 06:14 AM
  4. Whats a good GPS reciever?
    By SilverGT in forum GPS
    Replies: 10
    Last Post: 07-08-2004, 11:28 AM
  5. Holux GPS NMEA reciever Group-buy?
    By vickumar in forum General Hardware Discussion
    Replies: 21
    Last Post: 04-24-2002, 06:09 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •