Results 1 to 5 of 5

Thread: HELP Need Drivers for Evermore GM-307 by morning!

  1. #1
    Newbie
    Join Date
    May 2003
    Posts
    34

    Exclamation HELP Need Drivers for Evermore GM-307 by morning!

    Hey this is a long shot, but I bought an Evermore GM-307 gps off of ebay a year back and I lost the driver CD. I'm going camping in the morning I want to use my GPS as a safety net. Does anyone have the drivers?

    Description of Evermore GM-307:

    USB
    Dark Clear Green Casing
    Retangular shaped
    Chipset: EverMore BBP1202

    If you have anything that could help, post a reply and email me the files @
    curt ([at]) curtkay []dot[] com. Thank you.

    Regards,
    Curt Kay
    [ L ] ive. [ D ] ream. [ C ] reate.

  2. #2
    Neither darque nor pervert DarquePervert's Avatar
    Join Date
    Apr 2004
    Location
    Elsewhere
    Posts
    13,950
    http://www.acte.no/techstuff/gps/GM-307-drivers.htm
    It's in Norweigan, however. With my limited Norweigan translation skills (NONE!), I can make out the drivers for Win98, Win2k/XP and so on.

    FYI, that took a 15 second GOOGLE search.
    GOOGLE is your friend. Know it. Love it. Use it.
    Have you looked in the FAQ yet?
    How about the Wiki?



    Under normal circumstances, a signature would go here.

  3. #3
    Newbie
    Join Date
    May 2003
    Posts
    34
    Yosemite kicked our asses, but those GPS drivers didn't work oh well. Does anyone else have the driver cdrom for the damn gps? Thanks again.

    -Curt Kay
    [ L ] ive. [ D ] ream. [ C ] reate.

  4. #4
    Maximum Bitrate MaleBuffy's Avatar
    Join Date
    Aug 2003
    Location
    Greece
    Posts
    489
    Well maybe its not the drivers that dont work?

  5. #5
    Constant Bitrate
    Join Date
    Jul 2005
    Location
    NJ
    Posts
    183
    did you ever find these drivers...i tried installing this and i still cant get my computers to recognize it. dont know whats wrong with it??

Similar Threads

  1. Evermore GM 307
    By ildena in forum GPS
    Replies: 2
    Last Post: 06-15-2005, 08:58 AM
  2. Via Epia M-900 Video Drivers Not working
    By mattdisaster in forum General Hardware Discussion
    Replies: 2
    Last Post: 01-06-2005, 10:33 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •