Page 17 of 33 FirstFirst ... 789101112131415161718192021222324252627 ... LastLast
Results 161 to 170 of 327
Like Tree1Likes

Thread: DAB DAB+ FM Digital Radio Development Board

  1. #161
    Newbie
    Join Date
    Feb 2012
    Location
    UK
    Posts
    49
    Mickz, thanks for your continuing efforts. But please don't worry about us for bit and concentrate on your renovation work!

  2. #162
    Maximum Bitrate Mickz's Avatar
    Join Date
    Sep 2009
    Location
    Australia
    Posts
    812
    Thanks for the support guys, did too much renovating yesterday and had a few hours forced time off with a heat pack today, getting old.

    So I spent a few minutes on the PC and added auto-port detect, as others have said thanks to JJ posting that neat idea.

    In my case auto-detect can be overridden if needed by selecting a port other than NONE. If the manual selected port fails then auto port is invoked. It’s also invoked on a new install, IE no radio.ini file. If autoport finds the DAB port then the Radio.ini setup file is updated.
    GA-Z77N-WIFI, i5-2400S, 8GB, Intel 520 128GB SSD, M4-ATX Modified, 2 Rev Cams, 2 Web Cams
    8" 16:9 TRANSFLECTIVE, Win8-64, Dual GPS RX and Garmin PC + Odyssey Nav, FM-DAB+, BB-Rec
    T-Screen HVAC control, custom microcontrollers, code and FE. CarPC Project

  3. #163
    Newbie
    Join Date
    Apr 2012
    Posts
    44
    Quote Originally Posted by Dabbler View Post
    Thanks for that code snippet JJ, very handy.

    I've assumed 'DABFMMonkeyUSBVIDPID' is supposed to be 'USB\VID_04D8&PID_000A'. Is that correct?
    It works for me anyway!
    Jepp, that's the same VID and PID I use. I pull this from an external config file, allowing the user to modify from my default should it change in the future.

    Also, you can grab a copy of the code from CF's new forums as I've just uploaded a first edition of my Centrafuse plugin w/source code.
    (Needs a lot of testing testing so there may be coding issues)


    JJ

  4. #164
    Newbie
    Join Date
    Apr 2012
    Posts
    44
    Mickz,

    Just tried saving and loading presets with , / .
    Works fine for me now. Good job, europeans should be happy with it


    JJ

  5. #165
    Newbie
    Join Date
    Feb 2012
    Location
    UK
    Posts
    49
    Quote Originally Posted by pierrotm777 View Post
    It's possible to add the TP TA RDS option for the FM please ?
    Quote Originally Posted by Dabbler View Post
    It should be possible, the RDS stream is available, and this is one of the features I'm looking into. I'm interested in picking up the DAB EPG also.

    Don't hold your breath though, its not trivial! if I get anywhere I'll post on here of course.
    Sadly, myself and JP at MonkeyBoard have discovered that the RDS stream data is not supported in this version of the module.

    This and the raw MOT data is described in the documentation but appears to be only available in a more expensive version.
    JP is looking into the possibilty of another version of the board that would support this at extra cost.

  6. #166
    Raw Wave pierrotm777's Avatar
    Join Date
    May 2008
    Location
    Bordeaux, France
    Posts
    2,839
    Quote Originally Posted by Dabbler View Post
    Sadly, myself and JP at MonkeyBoard have discovered that the RDS stream data is not supported in this version of the module.

    This and the raw MOT data is described in the documentation but appears to be only available in a more expensive version.
    JP is looking into the possibilty of another version of the board that would support this at extra cost.
    I can wait , FM without RDS isn't the best !
    The good module would be if i understand well the T2-L4A-8650C and not the actual T1_L4A_8290C.
    But , on the MonkeyBoard web page they say:
    FM with RDS (RDS reception is subject to certain condition of power level and frequency deviation)

  7. #167
    Newbie
    Join Date
    Feb 2012
    Location
    UK
    Posts
    49
    Quote Originally Posted by pierrotm777 View Post
    I can wait , FM without RDS isn't the best !
    The good module would be if i understand well the T2-L4A-8650C and not the actual T1_L4A_8290C.

    Yes, I imagine it is the 8650.

    Just to clarify. The module does support FM RDS Radio Text, and Program Name etc.
    It is the more advanced features like EON, which is needed for Traffic announcements, alternative frequencies etc., which are not possible.
    These could have decoded from the RDS data if it was provided.

    Quote Originally Posted by pierrotm777 View Post
    But , on the MonkeyBoard web page they say:
    FM with RDS (RDS reception is subject to certain condition of power level and frequency deviation)
    I believe this is mainly saying the signal needs to be strong enough. If the FM signal is a little noisy, you soon lose the RDS data.

  8. #168
    Maximum Bitrate Mickz's Avatar
    Join Date
    Sep 2009
    Location
    Australia
    Posts
    812
    Quote Originally Posted by johnjore View Post
    Mickz, just tried saving and loading presets with , / . Works fine for me now. Good job, europeans should be happy with it JJ
    Thanks JJ for bringing that to my attention and for testing.

    On the subject of PID port detection. I modified my code to auto update the PID for the module interface if it should change, it saves the user looking for it on a small CAR-PC screen.

    I’ve implemented this in my FE as it simplifies and automates the process (for me anyway).

    1. The Default PID for a device can be (optionally) coded into the initial configuration file, as is the case with this radio module.

    2. If the PID is missing or not found and the device does not open then the user is prompted to select the device COM PORT.

    3. If / when the Radio (or other device) successfully opens, the PID is retrieved and compared to the existing PID and if needed the configuration file is updated.

    Now, like the radio module, all USB COM port devices in the system (in this case of my FE) can be plugged in to any HUB or USB port and are automatically configured should the COM ports change.

    .


    EDIT UPDATE: Fixed a Bug not saving the PID on an uninitialised configuration entry.
    Last edited by Mickz; 09-22-2012 at 11:01 PM.
    GA-Z77N-WIFI, i5-2400S, 8GB, Intel 520 128GB SSD, M4-ATX Modified, 2 Rev Cams, 2 Web Cams
    8" 16:9 TRANSFLECTIVE, Win8-64, Dual GPS RX and Garmin PC + Odyssey Nav, FM-DAB+, BB-Rec
    T-Screen HVAC control, custom microcontrollers, code and FE. CarPC Project

  9. #169
    Maximum Bitrate Mickz's Avatar
    Join Date
    Sep 2009
    Location
    Australia
    Posts
    812
    Revised how Auto Port Search with PID is handled. Added PID display and editing of full PID in Com setup, just in case it’s ever needed.

    I doubt this will ever be needed: Briefly, recent testing on a dozen USB devices has shown that a PID returned in device manager can be exactly the same for 3 or more totally different devices that obviously have a common USB interface chip sourced from somewhere. This mod allows you to view and edit the longer returned PID string for the device.
    GA-Z77N-WIFI, i5-2400S, 8GB, Intel 520 128GB SSD, M4-ATX Modified, 2 Rev Cams, 2 Web Cams
    8" 16:9 TRANSFLECTIVE, Win8-64, Dual GPS RX and Garmin PC + Odyssey Nav, FM-DAB+, BB-Rec
    T-Screen HVAC control, custom microcontrollers, code and FE. CarPC Project

  10. #170
    Constant Bitrate
    Join Date
    Jun 2010
    Location
    Syd, Australia
    Posts
    123
    On a different note to your great app mike,

    I recently installed the board into the jeep (stock antenna amped) and found this aerial is am/FM only - no dab.

    I am thinking of buying this http://www.dabonwheels.co.uk/Kinetic...ar_aerial.html . The question is how can we connect both dab output and FM output from this antenna to our dabboard?

    The supplied antenna handled FM and dab with the 1 lead.

    Is this where a 'multiplexer' comes into play?

Similar Threads

  1. Replies: 1
    Last Post: 04-28-2008, 11:52 PM
  2. On-Board Digital Equalizer
    By Cheekz185 in forum Car Audio
    Replies: 4
    Last Post: 05-24-2005, 05:47 PM
  3. Frustrated with my digital WW board....
    By Waveblaster785 in forum LCD/Display
    Replies: 15
    Last Post: 03-12-2005, 04:42 PM
  4. Fried my Digital WW board....
    By Waveblaster785 in forum LCD/Display
    Replies: 9
    Last Post: 02-21-2005, 09:26 PM
  5. SB Value Digital I/O Board???
    By RaZor in forum General Hardware Discussion
    Replies: 6
    Last Post: 04-18-2001, 11:45 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •