Results 1 to 9 of 9

Thread: T3 Problems

  1. #1
    Low Bitrate
    Join Date
    Apr 2007
    Posts
    62

    T3 Problems

    My T3 (bottom half) is not functioning, it does not light up and it does not close by switch or remote. It looks like it has no power going to it. I tried the upgrade utility for the panel and it detects it but it still does not work. Any ideas?

  2. #2
    Low Bitrate
    Join Date
    Feb 2007
    Location
    CA
    Posts
    99
    Did you check to see if there's actually juice flowing into the bottom unit? I recently had a similar problem where T3 suddenly turned off. I wasn't even getting anything to light up on the LCD screen. I found the culprit to be a loose soldering in the EMI/RF suppression toroid wrapped in a black rubber heat shrink. It's a piece right before the power adapter attaches to the bottom unit. My unit gets cramped into a dash so I think that's how it got loose.
    Infill T3 with Infill Station
    2007 Hyundai Sonata

  3. #3
    Low Bitrate
    Join Date
    Apr 2007
    Posts
    62
    checked all that, it went all one solid grey colour and then it stopped working. the only thing right now is that the power light and the tilt lights on the bottom unit is always on....

  4. #4
    Low Bitrate
    Join Date
    Feb 2007
    Location
    CA
    Posts
    99
    Have you tried unplugging the power adaptor for few minutes? And then plugging it back in.

    Also, have you tried pressing the reset button?
    Infill T3 with Infill Station
    2007 Hyundai Sonata

  5. #5
    Low Bitrate
    Join Date
    Apr 2007
    Posts
    62
    tried everything, might have to send it in. do u know where i can get it fixed?
    Korea?

  6. #6
    Low Bitrate
    Join Date
    Feb 2007
    Location
    CA
    Posts
    99
    Well, if you bought it from mp3car.com, shouldn't it be under warranty?

    When I talk to Infill Korea for any problems, they always tell me, talk to mp3car.com. Ask them questions. Ask them for drivers. Ask them for repairs. Ask them for answers. They don't have good customer service.

    And by the way, they used to have a bulletin board for Q&A on their website, but after so many negative feedback, unresolved issues, unfriendly responses from the customers, Infill just got rid of the bulletin board and went to 1:1 email support system.

    Too bad they have pretty decent product, but really bad customer service.
    Infill T3 with Infill Station
    2007 Hyundai Sonata

  7. #7
    Newbie rburhum's Avatar
    Join Date
    Mar 2007
    Location
    SoCal, USA
    Posts
    40
    Quote Originally Posted by irdrive View Post

    When I talk to Infill Korea for any problems, (...)
    You mean you actually get a response to your e-mails from them!?!?!!!

  8. #8
    Low Bitrate
    Join Date
    Feb 2007
    Location
    CA
    Posts
    99
    Not email. Using their online customer service communication system. You have to first log in. And that requires registration. Which may be a bit difficult if you don't read Korean.
    Infill T3 with Infill Station
    2007 Hyundai Sonata

  9. #9
    Newbie
    Join Date
    Apr 2008
    Posts
    14
    Old thread but replacement FFC ribbon cables fixed my very similar problems.

Similar Threads

  1. Replies: 33
    Last Post: 03-28-2008, 02:18 PM
  2. Harddrive problems (booting)
    By Axxess in forum General Hardware Discussion
    Replies: 1
    Last Post: 05-15-2007, 04:13 PM
  3. SD on T3 problems.
    By SteTommo in forum StreetDeck
    Replies: 2
    Last Post: 04-02-2007, 06:33 PM
  4. Replies: 4
    Last Post: 12-27-2006, 03:22 PM
  5. Dell Inspiron 8200 & Lilliput TS problems?
    By bkpsu in forum LCD/Display
    Replies: 1
    Last Post: 08-15-2004, 01:55 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •