Results 1 to 8 of 8

Thread: Griffin PowerMate Problem - please HELP! (it acts like a mouse)

  1. #1
    Newbie
    Join Date
    Jul 2008
    Posts
    4

    Griffin PowerMate Problem - please HELP! (it acts like a mouse)

    I successfully installed the latest drivers from the Griffin website (after about 25 tries - I kept getting an error message) but when I plug in the PowerMate it is not recognized by my computer. When I scroll the wheel left and right it moves the mouse arrow (very slowly) along the x-axis and when I click the wheel in it acts like a mouse click. The LED is lit. Any advice? I'd really like to get this thing working.

    Thanks!

  2. #2
    Newbie
    Join Date
    Oct 2008
    Posts
    3

    I have the same problem.

    I bought an used powermate from ebay.
    It acts just like you said: like a mouse.
    What a coincidence!
    Did you fix the problem?

  3. #3
    Newbie
    Join Date
    Jul 2008
    Posts
    4
    Quote Originally Posted by axon View Post
    I bought an used powermate from ebay.
    It acts just like you said: like a mouse.
    What a coincidence!
    Did you fix the problem?
    I did get it working (sort of - the "mute" doesn't work but I think it might be due to a hardware issue). I emailed customer support and they knew the problem right away and emailed me an updated driver. I installed it and it started working.

  4. #4
    Maximum Bitrate fixerofallthing's Avatar
    Join Date
    May 2005
    Location
    Lawrenceville GA
    Posts
    769
    Quote Originally Posted by javeryh View Post
    I did get it working (sort of - the "mute" doesn't work but I think it might be due to a hardware issue). I emailed customer support and they knew the problem right away and emailed me an updated driver. I installed it and it started working.
    Could you post that driver here or upload it somewhere. I would like to use mine.
    The Car 2005 Scion xB

    The Truck 2004 GMC Canyon

  5. #5
    Newbie
    Join Date
    Oct 2008
    Posts
    3
    Quote Originally Posted by javeryh View Post
    I did get it working (sort of - the "mute" doesn't work but I think it might be due to a hardware issue). I emailed customer support and they knew the problem right away and emailed me an updated driver. I installed it and it started working.
    Thanks for your reply.
    I wonder why the company doesn't upload the driver on its web site.

  6. #6
    Maximum Bitrate fixerofallthing's Avatar
    Join Date
    May 2005
    Location
    Lawrenceville GA
    Posts
    769
    I found the 1.5.3 driver file. After you install it you can use the updater on the griffin site to get your powermate working. I have found the mute function does not work and I know it is not a hardware issue but if you want to use it to control volume here is the file.
    Attached Files Attached Files
    The Car 2005 Scion xB

    The Truck 2004 GMC Canyon

  7. #7
    Newbie
    Join Date
    Jul 2008
    Posts
    4
    Quote Originally Posted by fixerofallthing View Post
    I found the 1.5.3 driver file. After you install it you can use the updater on the griffin site to get your powermate working. I have found the mute function does not work and I know it is not a hardware issue but if you want to use it to control volume here is the file.
    Thanks for the upload. The file is on my home computer. So the mute button not working isn't a hardware issue? Hmmm... that is very disappointing. I'm actually disappointed by this product but I don't know of any alternatives. Maybe I should just buy a new one from the manufacturer.

  8. #8
    Newbie
    Join Date
    Oct 2008
    Posts
    3

    It works!

    Quote Originally Posted by fixerofallthing View Post
    I found the 1.5.3 driver file. After you install it you can use the updater on the griffin site to get your powermate working. I have found the mute function does not work and I know it is not a hardware issue but if you want to use it to control volume here is the file.
    Software version 2.0.1 couldn't recognize my Powermate,
    but your 1.5.3 recognize it.
    I guess I have an old model.
    For another Powermate of mine work well with software version 2.0.1.

Similar Threads

  1. Replies: 8
    Last Post: 10-28-2007, 11:15 AM
  2. Griffin Powermate does not work after reboot.
    By sgtpepperaut in forum Input Devices
    Replies: 3
    Last Post: 10-24-2007, 01:22 PM
  3. Post your Griffin Powermate config files
    By WuNgUn in forum Input Devices
    Replies: 2
    Last Post: 10-03-2007, 10:41 PM
  4. Griffin Powermate
    By mygti02 in forum StreetDeck
    Replies: 2
    Last Post: 10-02-2007, 08:12 AM
  5. Griffin Powermate
    By [email protected] in forum Input Devices
    Replies: 14
    Last Post: 08-20-2003, 11:49 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •