Results 1 to 5 of 5

Thread: USB Hub Malfunction?

  1. #1
    Newbie
    Join Date
    Dec 2006
    Posts
    19

    USB Hub Malfunction?

    Hi all,

    This is probably more of a general computer question, but since it happens on my carputer I figure here is a great place to start.

    I have a bunch of USB devices in my rig. The PC is in the trunk and I run 1 USB cable to the dash where I have a USB hub. The hub is powered of my pc power supply so its getting 5V when the car is on. However, I keep getting all sorts of random errors with the hub. I have tested each and every device separately in the onboard USB ports and everything works perfect. However when I connect the devices (GPS, touchscreen, etc) to the hub I get "usb device has malfunctioned" or "windows cannot recognize your USB device". This is annoying the &*#@ out of me since whenever this happens, the carputer is rendered useless as I cant use the touch screen. I am at a point now where I am thinking of once again taking the seats and carpet out so I can run dedicated USB cables from the trunk to the front for each device. Before I do this I figured I would see if anyone else has this problem? This is also my 2nd hub (as I thought the 1st might have been faulty) and about 6th different cable I've used to connect it.

    I am running Win7 x86. Any ideas????
    Thanks!

  2. #2
    FLAC
    Join Date
    Jan 2008
    Location
    Dartmouth, MA
    Posts
    914
    It's a power problem.

    A usb port can only put out 500mA.
    A usb hub uses roughly 100mA.
    That leaves 400 mA for the devices.

    Run dedicated 5 volts to the hub's power input if it is a powered hub. If not, get a powered hub.

    It's usually a good idea to run a dedicated USB cable for the touch screen, that way no matter what happens you can still control the screen.
    My Nearly Complete Car:
    http://www.mp3car.com/vbulletin/show...ed-car-pc.html

    Micro Control Center... Control Your Car Across the Internet
    http://www.mp3car.com/fusion-brain/1...-internet.html

    Website: (It's a work in progress, really. All my projects have taken me from ever really developing it.)
    http://paulfurtado.com/

  3. #3
    MySQL Error soundman98's Avatar
    Join Date
    Jan 2008
    Location
    on the border of northern IL/IN
    Posts
    5,820
    Quote Originally Posted by PaulF View Post
    It's a power problem.

    A usb port can only put out 500mA.
    A usb hub uses roughly 100mA.
    That leaves 400 mA for the devices.

    Run dedicated 5 volts to the hub's power input if it is a powered hub. If not, get a powered hub.

    It's usually a good idea to run a dedicated USB cable for the touch screen, that way no matter what happens you can still control the screen.
    something like that...

    he said that it is getting power from the 5v rail of the power supply, but neglected to mention if he has tried 2 of the same hub, or if they are powered externally from the power supply(the mention of getting power from the 5v rail leads me to assume that it is a externally powered hub)

    if you have tried 2 of the same model hub, you might need to try a different model/brand hub to resolve it.

    also, i second the idea to run a secondary usb ext. for the touch screen control-- that way, you can at least still control the pc..

    otherwise, i am told that the car-specific powered hub in the mp3car store works very well with very little issues.

  4. #4
    Newbie
    Join Date
    Dec 2006
    Posts
    19
    I am powering the hub off one of my psu 5v rails so it only gets power when the mobo is powered (it is externally powered). I have also tried 2 different brands of hubs.

  5. #5
    FLAC
    Join Date
    Jan 2008
    Location
    Dartmouth, MA
    Posts
    914
    how long is the wire run? What guage wire? Use a multimeter... is 5 volts really making it to the other end of the wire? Is the USB cable shielded? Try messily running another USB cable through the car above the carpet for a couple days to test. Does that eliminate the issue?
    My Nearly Complete Car:
    http://www.mp3car.com/vbulletin/show...ed-car-pc.html

    Micro Control Center... Control Your Car Across the Internet
    http://www.mp3car.com/fusion-brain/1...-internet.html

    Website: (It's a work in progress, really. All my projects have taken me from ever really developing it.)
    http://paulfurtado.com/

Similar Threads

  1. Opus 320 and 2 StarTech.com 7 Port USB 2.0 Hub
    By HiJackZX1 in forum General Hardware Discussion
    Replies: 4
    Last Post: 01-07-2008, 04:42 PM
  2. Powered Hub, Lots of USB Devices! Will this work?
    By adamharrisuk in forum General Hardware Discussion
    Replies: 4
    Last Post: 05-15-2006, 12:00 AM
  3. My USB/Wifi troubles.
    By JPuma in forum General Hardware Discussion
    Replies: 0
    Last Post: 09-23-2005, 12:44 PM
  4. USB Hub does not show HD after cold boot
    By d_sellers1 in forum General Hardware Discussion
    Replies: 9
    Last Post: 04-05-2005, 02:46 PM
  5. USB HUB problems????
    By chuckctv in forum Input Devices
    Replies: 7
    Last Post: 10-08-2004, 12:38 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •