Page 24 of 26 FirstFirst ... 14151617181920212223242526 LastLast
Results 231 to 240 of 260

Thread: sony "joystick" commander.

  1. #231
    tja
    tja is offline
    Variable Bitrate
    Join Date
    Aug 2005
    Location
    sydney, australia
    Posts
    442
    hi,

    just got my rm x4s hooked up to the joystick port, and im using the joyaxis.dll (it's brilliant!!) plugin for girder. The x value fluctuates quite a bit in the plugin settings screen - is this normal? i just increased the deadzone area...

    anyway, i have girder reading button presses so i get a different stable value for each button. i have also set it up to perform a "vol+" action in rr and have the volume going up and down etc.. that was easy. my question is, how do i get it to hold the value so the volume continues to go up if i hold the button on the remote down? at the moment i have to press it, release it, press it, release it etc...

    id like to do the same with the next track/fast forward... so if i press the button once momentarily, it goes to the next track.. but if i hold the button down and dont let go, it fast forwards instead of going to the next track.... is this possible?

    cheers,

    tim.
    2005 Nissan Xtrail
    DFI 855GME-MGF - Celeron M 1.4GHz - 256Mb RAM - 200Gb SATA HDD - OPUS 150w - Xenarc 700TSV

    worklog

  2. #232
    What can I say? I like serial. Curiosity's Avatar
    Join Date
    Mar 2004
    Location
    Florence Yall, BFKY
    Posts
    2,684
    It's been a while since I've looked at that plugin, but I think there was an option for repeat, repeat speed and delay before repeat. The winamp plugin I did could do something different for momentary and for repeat, but for girder I figured it could all be configured with the scripting. Not sure though?

  3. #233
    tja
    tja is offline
    Variable Bitrate
    Join Date
    Aug 2005
    Location
    sydney, australia
    Posts
    442
    yeah i saw the option for the repeat delay time and the tick box but it didnt seem to do anything when i played around with it... and i've never done any scripting in girder so im kinda lost there.. can set up simple commands and what not but thats about the extent of it.. sorry..

    when i press press a button on the joystick i get an event in girder, but the green icon only turns yellow momentarily, then straight back to green.
    2005 Nissan Xtrail
    DFI 855GME-MGF - Celeron M 1.4GHz - 256Mb RAM - 200Gb SATA HDD - OPUS 150w - Xenarc 700TSV

    worklog

  4. #234
    Maximum Bitrate Bravellir's Avatar
    Join Date
    Dec 2003
    Location
    Porto, Portugal
    Posts
    741
    Watch the code thats shows up in girder, It's diferent for a press and for repeated pressing.
    Ikea Case. Epia M10000.M1-ATX. 512 Mb. 2,5" 80 GB HDD. 7" Lilliput. BU-303 GPS. Sony Joystick.
    Status -->
    Lilliput Installed (not indash yet..)
    BraveCar 2.5

  5. #235
    tja
    tja is offline
    Variable Bitrate
    Join Date
    Aug 2005
    Location
    sydney, australia
    Posts
    442
    ah!

    im getting somewhere now...

    but the repeat only works for some buttons? like the vol- button doesnt work .. it stays at :00:00 instead of 01... could that be a hardware problem? it works sometimes (maybe once in 5 presses i will get the repeat bit showing)..

    also, how do i capture the repeat event in girder? when i do learn event, it automatically captures the first even (:00), so no repeat... maybe if i set the repeat delay high, press button, then press learn event and wait for the change in state? or is there a way i can manually edit the event code?

    thanks so much for your help guys.

    edit: oh yeh i have version 1.0 of the plugin.. i assume thats the correct one?

    and im sorry for asking you guys to help so long after writing the plugin!

    edit2:

    its ok i had to adjust the range and threshold a bit - the volume switches were fluctuating a bit but now i have it so they always return the same value and it works!

    and i realised that the rr.gml file is just a .xml file so i can edit the commands easily!

    thankyou so much curiousity and gore and bravellir and marsupial and others!
    2005 Nissan Xtrail
    DFI 855GME-MGF - Celeron M 1.4GHz - 256Mb RAM - 200Gb SATA HDD - OPUS 150w - Xenarc 700TSV

    worklog

  6. #236
    Newbie
    Join Date
    Oct 2005
    Posts
    5

    Unhappy I'm missing something about the Sony --> gameport circuite

    can you please confirm my understanding of the circuite?

    120K ohm R1 between joystick ports 6 & 8.
    connect joystick port 3 to sony port 3.
    attach 120K ohm R2 to the link between (joystick port 3 & sony port 3) and sony port 1
    attach a transistor between joystick ports 2(out) & 4(in), and 4.73K ohm R3 to sony port 2 (Ground).

    Also, can someone please provide me with the RadioShack partnumber for the transistor, and is the transistor a PNP, or NPN.

    I'm using the diagram from Bravellir's post for the resistors connections, but confussed about the three connections for the transistor.

    Name:  schema_cablage11.jpg
Views: 710
Size:  17.3 KB

    I forgot to add that i'm learning about these electrical components as I go, no background knowledge of electronics before, so wish me luck

  7. #237
    Low Bitrate Gore-'s Avatar
    Join Date
    Apr 2004
    Location
    France
    Posts
    86
    @tja :
    You can press and hold first, and click "learn"
    But you have find a cool solution

    @eric237 : have you any schematic and/or software?

    @tareqwalid : sorry but I don't knaw, my shop have give me the correct transistor when I have give him the schematic

    A little problem with the plugin everytime :
    when I wake Up the PC, the plugin send lot of commands (icon blink everytime)
    it stops when a send a first command, and it's ok...

  8. #238
    Maximum Bitrate Bravellir's Avatar
    Join Date
    Dec 2003
    Location
    Porto, Portugal
    Posts
    741
    @tareqwalid

    This solution is based on this: http://llg.cubic.org/tools/sonyrm/

    The transistor is an BC547 http://www.semiconductors.philips.co...html#datasheet

    Ikea Case. Epia M10000.M1-ATX. 512 Mb. 2,5" 80 GB HDD. 7" Lilliput. BU-303 GPS. Sony Joystick.
    Status -->
    Lilliput Installed (not indash yet..)
    BraveCar 2.5

  9. #239
    Newbie
    Join Date
    Jun 2004
    Posts
    30

    Something wrong…!

    Hello

    I'm using the JoyAxis Plugin in Girder.
    I've had it working in another computer, but now it doesn't work...
    The rmx-4s is connected to the y axis of a gamepad (4,7khom res. used, because 10k var. res. original).
    I can’t use x axis because the line in the PCB is braked and can not be used.
    The y axis is good (it worked)

    In windows calibration I get values from 139 (centred) to 255 (source and off).

    In joy axis I get:

    -99 (centred),
    10 (mode),
    13 (sound),
    19 (vol down),
    25 (vol up),
    33 (seek down),
    42 (seek up),
    53 (list),
    69 (ATT),
    100 (off),
    100 (source).

    I only get a response when the dead zone max is set to 15, and is x4s:0:0:0:0 when push the “sound” or the “mode” key, and x4s:0:-9:0:0 when released.

    I’ve tried many combinations, but none successful.

    Thanks!

    Alex R

  10. #240
    Low Bitrate Gore-'s Avatar
    Join Date
    Apr 2004
    Location
    France
    Posts
    86
    the dead zone must be the values taken by joystick when ther is no action.

    for example when you don't push any button the RMX4S give you -99 to -96 :
    dead zone min can be -99 (or -100)
    dead zone max -96 (or -95)


Similar Threads

  1. Sony UniLink protocol explained here, can someone?
    By SuperSonic in forum General Hardware Discussion
    Replies: 15
    Last Post: 06-28-2005, 11:37 AM
  2. Would anyone buy CD Changer/Unilink cable hacks for Sony head units?
    By Ashlawn Kemling in forum Classified Archive
    Replies: 56
    Last Post: 06-14-2004, 02:55 PM
  3. Replies: 6
    Last Post: 10-19-2002, 11:18 AM
  4. Use my touch screen to control my SONY head unit
    By cproaudio in forum General Hardware Discussion
    Replies: 1
    Last Post: 10-14-2002, 09:37 AM
  5. How do I get sound into my Sony CDX-M700R?
    By percyt2k in forum General Hardware Discussion
    Replies: 4
    Last Post: 06-05-2001, 10:17 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •