Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Com Port issues.... Number too high!!!

  1. #1
    Newbie
    Join Date
    May 2005
    Posts
    33

    Com Port issues.... Number too high!!!

    Hi All, im hunting around for the answer to this but cant find out how to change it....

    The COM port numbers on my system have now climbed to 20 and 21... too high for Phone Control.net

    How can i change these numbers to get them down?
    Ive been using my bro's computer for testing and his is now up to 40 LOL

    HELP PLEASE!
    Epia M10k, 1GB RAM, 40GB HDD, 7" Touch, DVD-RW Drive, Bluetooth, GPS, GPRS, all neatly hidden away in my Audi S2

  2. #2
    Neither darque nor pervert DarquePervert's Avatar
    Join Date
    Apr 2004
    Location
    Elsewhere
    Posts
    13,949
    You probably have a lot of COM port assigned to nothing. You can clean them out in the registry, reboot and hav elower COM ports available.
    This is the result of ****ty drivers.
    Have you looked in the FAQ yet?
    How about the Wiki?



    Under normal circumstances, a signature would go here.

  3. #3
    Newbie
    Join Date
    May 2005
    Posts
    33
    Yeh, they all think they are in use when they arent, trouble is i cant find how to get rid of the damn things!!

    Where abouts in the registry, as i went on a deleting spree earlier but i obviously missed what i needed to get as it didnt help, just put the COM ports i want 2 ports higher still! LOL
    Epia M10k, 1GB RAM, 40GB HDD, 7" Touch, DVD-RW Drive, Bluetooth, GPS, GPRS, all neatly hidden away in my Audi S2

  4. #4
    Neither darque nor pervert DarquePervert's Avatar
    Join Date
    Apr 2004
    Location
    Elsewhere
    Posts
    13,949
    Search for the registry for COMx
    Have you looked in the FAQ yet?
    How about the Wiki?



    Under normal circumstances, a signature would go here.

  5. #5
    Newbie
    Join Date
    May 2005
    Posts
    33
    Yeh tried that, but didnt work.
    Went in to safe mode to do it, so that it would allow me to, there must have been something i missed, but i found all entries using that for the search.

    Oh well, i'll keep on looking, its hammering down with rain so i cant go clean the car or anything anyway
    Epia M10k, 1GB RAM, 40GB HDD, 7" Touch, DVD-RW Drive, Bluetooth, GPS, GPRS, all neatly hidden away in my Audi S2

  6. #6
    Newbie
    Join Date
    May 2005
    Posts
    33
    Problem resolved....

    Registry value to change as follows.....

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\COM Name Arbiter

    The "COMDB" value is a binary field that seems to be a bitmap of installed ports. If you have COM1 and COM2, the first byte will be 0x03. Add COM3, 4, 5 and 6 and the first byte will be 0x3F. Go up to COM8 and you'll see 0xFF,
    0x01. And so on.

    Be careful not to change the length of the string of bytes when you edit it.
    Epia M10k, 1GB RAM, 40GB HDD, 7" Touch, DVD-RW Drive, Bluetooth, GPS, GPRS, all neatly hidden away in my Audi S2

  7. #7
    What can I say? I like serial. Curiosity's Avatar
    Join Date
    Mar 2004
    Location
    Florence Yall, BFKY
    Posts
    2,684
    You can also change it in device manager. Go to "Ports (COM & LPT)" and double-click on the one you want to change. The port number is in Advanced under Port Settings.

  8. #8
    Neither darque nor pervert DarquePervert's Avatar
    Join Date
    Apr 2004
    Location
    Elsewhere
    Posts
    13,949
    Quote Originally Posted by Curiosity
    You can also change it in device manager. Go to "Ports (COM & LPT)" and double-click on the one you want to change. The port number is in Advanced under Port Settings.
    But if the port number you want to select is being recognised as 'in use', you won't be able to select that COM port number...
    Have you looked in the FAQ yet?
    How about the Wiki?



    Under normal circumstances, a signature would go here.

  9. #9
    Newbie
    Join Date
    May 2005
    Posts
    33
    Quote Originally Posted by DarquePervert
    But if the port number you want to select is being recognised as 'in use', you won't be able to select that COM port number...
    Exactly, there is no way of getting to any of them to remove them, hence the reg fix.... also that "port settings" option isnt available for bluetooth com ports, only fixed ports eg COM1
    Epia M10k, 1GB RAM, 40GB HDD, 7" Touch, DVD-RW Drive, Bluetooth, GPS, GPRS, all neatly hidden away in my Audi S2

  10. #10
    What can I say? I like serial. Curiosity's Avatar
    Join Date
    Mar 2004
    Location
    Florence Yall, BFKY
    Posts
    2,684
    I see it for bluetooth as well, but when I change it, the name still has the old COM port but it's really using the new one. That kind of sucks.
    Oh, yeah I see all those ones with (in use) from all previous installs of ports now.

Page 1 of 2 12 LastLast

Similar Threads

  1. anyone using FIR port on EPIA M board?
    By stimps in forum Input Devices
    Replies: 11
    Last Post: 04-25-2009, 09:29 AM
  2. windows ce com port redirector?
    By lazarus in forum GPS
    Replies: 3
    Last Post: 07-29-2004, 02:19 PM
  3. Serial port gone bang?
    By Jamez_Warner in forum General Hardware Discussion
    Replies: 1
    Last Post: 02-10-2004, 02:29 PM
  4. Where to get long high quality VGA cables....
    By psyclobe in forum General Hardware Discussion
    Replies: 6
    Last Post: 10-22-2003, 01:07 AM
  5. Serial port?
    By Alphared in forum General Hardware Discussion
    Replies: 10
    Last Post: 01-17-2003, 11:05 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •