Results 1 to 9 of 9

Thread: "SUPER" (Xenarc repackage) touch screen- can not get the touch drivers working

  1. #1
    Low Bitrate
    Join Date
    Feb 2004
    Location
    Milwaukee, WI
    Posts
    59

    "SUPER" (Xenarc repackage) touch screen- can not get the touch drivers working

    I have tried everything! I first installed the drivers from the CD that came with the "Super" LCD touch panel. I Installed them without the USB cable plugged in (VGA was plugged in though). Under the mouse list in the device manager it shows the touch panel, but under the USB list there is an Unknown device. Drivers will not attach to it. The touch panel settings do not show an available panel to configure and calibrate. I then uninstalled the drivers. I then left the USB plugged in and installed the drivers. Still nothing. I then attempted to use the Xenarc V4 drivers both ways- usb not plugged in and then with it plugged in. I tried a variety of ways and reboot combinations. I just can not get it to recognize!

    When using just the Xenarc drivers I do not get the touch panel under the mouse section of the device manager.

    Anyone out there able to get this installed, I know people out there have this screen working, and I used to several months ago with a different PC, but now I just can't get it.

  2. #2
    Low Bitrate tarpitblue's Avatar
    Join Date
    May 2005
    Location
    Tampa, FL
    Posts
    63
    I have responded to this exact question several times (and asked it myself when they first came out). Search my name and you will find the answers.

  3. #3
    Low Bitrate
    Join Date
    Feb 2004
    Location
    Milwaukee, WI
    Posts
    59
    I searched, found and it still does not work . Would I be able to get a copy of your drivers? Here is what I did, step by step...

    -Left USB UNPLUGGED
    -Inserted CD
    -Ran setup for 2000/XP
    -Installed software and when asked to install drivers I continued
    -Restarted computer
    -Opened Device Manager- noted that under Mice that "TouchKit TouchController" was installed and working
    -Plugged in USB cable
    -"Unknown Device" showed up under USB Controllers- which would not start
    -"Unknown Device" would not pickup any driver from the CD, but the "TouchKit TouchController" driver reinstalled after selecting from the list and choosing "Have Disc" and selecting a driver
    -Rebooted system as instructed again

    Still nothing and the TouchKit Configuration Application does not find any controllers. Think it has something to do with the "Unknown Device" but I can't get anything installed with it. Downloading the Xenarc drivers does not seem to help either. Do you have a copy of your drivers I could try maybe? Are you using the SUPER screen as well with XP?

    Thanks again for your help!

  4. #4
    Maximum Bitrate Jarrod's Avatar
    Join Date
    Jan 2002
    Location
    Melb, Australia.
    Posts
    475
    I've got the SUPER 7" touchscreen and its working perfectly. Heres what I did:

    Im using 4.0.2.1929 TouchKit drivers (available here if you need: LINK)
    then you can attach the VGA, as this shouldnt need any driver installation.
    Now DO NOT connect the USB touch screen.
    Install the drivers from above. (do not install ps2 drivers)
    Restart computer.
    Plug in USB touch screen.
    Now run the touchkit config utility and it should read from the touch controller then you can calibrate and adjust any settings (like remove the stupid sound on touch option).

    Thats all I did. If it doesnt work, can you try on another computer to ensure its not a USB problem with the PC? I've had problems installing it on some motherboards.
    Jarrod - Holden VX S!

  5. #5
    Low Bitrate
    Join Date
    Feb 2004
    Location
    Milwaukee, WI
    Posts
    59
    Well I did exactly this, and still nothing, still get the "Unknown Device" under the USB area. I tried it on my desktop machine (totally different config), and it came up with the same crap.

    I even tried to manually install the drivers after rebooting and it was not working. I am at a lose, I know this has worked in the past- about 6 months ago, so I know the screen is good, just seems like the drivers I keep trying to install are screwed up (I was using the drivers you listed above- downloaded from that link)

    Any more ideas?

  6. #6
    Newbie Smokemaximus's Avatar
    Join Date
    Dec 2005
    Location
    TX
    Posts
    46
    Quote Originally Posted by HACKTHS
    Well I did exactly this, and still nothing, still get the "Unknown Device" under the USB area. I tried it on my desktop machine (totally different config), and it came up with the same crap.

    I even tried to manually install the drivers after rebooting and it was not working. I am at a lose, I know this has worked in the past- about 6 months ago, so I know the screen is good, just seems like the drivers I keep trying to install are screwed up (I was using the drivers you listed above- downloaded from that link)

    Any more ideas?
    Do a windows update on your comp. I had that problem installing usb drivers for my phone. I had to update the usb drivers from windows. hope that helps.

  7. #7
    Newbie
    Join Date
    May 2006
    Posts
    8
    Hi

    I've also a driver problem with my innovatek 8'' tm-868 touchscreen. When I install drivers (downloaded from http://www.egalax.com.tw) http://www.egalax.com.tw/drivers/Win...4.0.2.1929.zip
    it freeze my winXP pro just after I've click continue installation without digitaly signed driver .... ... (ps2 driver not installed)

    I've tried several driver's version always the same problem.

    The touchkit software is installled but doesn't recognise my touchscreen.

    I've tried to install my touchscreen on my desktop and no problem, everything working fine.

    I think the problem comes from my sony vaio tr5mp, because it's doesn't have any physical com/ps2 port. My integrated bluetooth emulate a com port and also my gps mouse receiver which probably interfer with my touchscreen.

    help please !

    Thank

  8. #8
    Constant Bitrate
    Join Date
    Oct 2004
    Location
    St. Louis area
    Posts
    148
    Quote Originally Posted by minhtam
    I think the problem comes from my sony vaio tr5mp, because it's doesn't have any physical com/ps2 port. My integrated bluetooth emulate a com port and also my gps mouse receiver which probably interfer with my touchscreen.
    That shouldn't matter. I've had my Xenarc working on my Fujitsu Lifebook N3510. It has no PS2 or com ports either...but it worked the first time. The only problem I had was my internal mouse pad stopped working while the TS was enabled (which doesn't matter cause a USB mouse can still operate).
    Toyota Tacoma Install
    BMW 325Ci Install - Old

    ZOTAC H55-ITX, Intel i3 & 320 Series SSD
    7" Lilliput 669GL, M4-ATX, SB X-Fi, XMPCR
    Win 7, RR, Garmin, DashCmd

    Morel Elate 9 3way & IDQ10 ported (active 4-way),
    JL Audio HD Amps, Audison BitOne.1

  9. #9
    Low Bitrate snoopdan's Avatar
    Join Date
    Aug 2005
    Location
    Louisville, KY
    Posts
    74
    this thread is refereing to the inoovatek tm-868 right? if so, I have one with this exact same problem, and im about to kick my touchscreen in. Its very agrivating to see it detect "unknown USB device" and have the drivers installed and it tries to look for the device. Sure would be nice if there was some actual installable real drivers for windows for this thing! My touchscreen is worthless.
    MECA Car Audio Judge

Similar Threads

  1. exchange Xenarc Touch screen
    By bluehcc in forum Classified Archive
    Replies: 0
    Last Post: 05-29-2005, 09:21 PM
  2. Xenarc 7" touch screen bracket question
    By emiperformance in forum LCD/Display
    Replies: 0
    Last Post: 01-30-2005, 10:09 PM
  3. Xenarc Touch Not Working
    By MSUC5Vette in forum LCD/Display
    Replies: 1
    Last Post: 08-18-2004, 12:42 PM
  4. Datalux touch screen not working
    By infx708 in forum LCD/Display
    Replies: 2
    Last Post: 08-05-2004, 02:16 AM
  5. FS: Xenarc 7" VGA touch screen
    By rdliou in forum Classified Archive
    Replies: 1
    Last Post: 09-27-2002, 09:44 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •