Results 1 to 6 of 6

Thread: Lilliput Touchscreen Stops Working!!!

  1. #1
    Low Bitrate
    Join Date
    Aug 2005
    Posts
    95

    Lilliput Touchscreen Stops Working!!!

    Okay I bought a Lilliput 7" Touchscreen not very long ago. It's the 629GL-70NP. I'm using Windows XP SP2 with all updated drivers and firmware. I have tried using a bunch of different drivers for the touchscreen. Every so often when I boot the computer up, the touchscreen doesn't work. I look in the device manager and it's not even listed! It's like sometimes when windows boots, it forgets that the USB cable is even plugged in! I tried pulling out the cable and reinserting it but that doesn't work. I tried using a different USB port and that usually works after reinstalling the drivers. Let me tell you, this has been a huge pain. I've gotten to the point of almost wanting to get rid of the computer setup because not being able to use the touchscreen takes all the fun away! I searched all through the forums and it seems like no one has been able to find a fix for this issue. I found a lot of posts on this problem so it seems to be very common.

    Has anyone found a fix for this problem?

  2. #2
    FLAC edrex's Avatar
    Join Date
    Dec 2004
    Location
    West Chestinghamshire, UK init!!
    Posts
    1,088
    Quote Originally Posted by L-U-R-C-H
    Has anyone found a fix for this problem?
    Get a Xenarc!

    Sorry, I really couldn't help myself...
    Spent so far: $1,755
    Check Out My Work Log for Specs/Pics
    CarPC Progress[!!!!!!!!!!!!!!].....Installation[---------+].....Pastrami Progress[!!!!!!!!!!!!!!]
    Don't mess with Texas.
    It's not nice to pick on retards!

  3. #3
    Low Bitrate
    Join Date
    Aug 2005
    Posts
    95
    Too bad I paid $270 for my Lilliput...that's not gonna happen!

  4. #4
    Newbie
    Join Date
    Apr 2006
    Location
    Australia
    Posts
    16
    hey i had a simlar problem it says usb dvice failed. realy ****ed me off. try pushing the small vga conector into the screen end or wiggle it a bit worked for me.

  5. #5
    Low Bitrate
    Join Date
    Aug 2005
    Posts
    95
    Haha! Guess what guys...I fixed the problem!! It was the USB extension I was using! For some reason it didn't like the active USB repeater cable I was using. I tested er out with a regular passive USB extension and it solved all my problems! It works for hibernation just fine now...whoohoo! Sorry, I'm in a good mood lol.

  6. #6
    FLAC W3bMa5t3r's Avatar
    Join Date
    Apr 2006
    Location
    Washington, DC
    Posts
    1,268
    Just some info. I have a 10.4" Lilliput Touchscreen LCD. I was having a problem where the cursor/touchscreen would get reallllyyy sluggish. It was really ****ing me off as it would take 4-5 'presses' to move the cursor. I tried numerous usb ports with no luck. It would even prevent Windows from booting at times. Downloading and installing the latest lilliput drivers helped, but it was still lagging quite a bit. I originally had it plugged into a powered hub, which was plugged into the laptop. Once I ran a regular usb extension cable directly from the monitor to the laptop, it worked perfectly. Go figure. Anyways, I'm happy now too :-) Everything works perfectly.

Similar Threads

  1. FS:: 7" Lilliput touchscreen lcd
    By carfreak01 in forum Classified Archive
    Replies: 11
    Last Post: 08-29-2005, 11:47 AM
  2. Replies: 5
    Last Post: 04-29-2005, 03:47 AM
  3. Replies: 2
    Last Post: 12-03-2004, 12:58 PM
  4. Lilliput Touchscreen Problem
    By BrUTaL in forum LCD/Display
    Replies: 12
    Last Post: 10-23-2004, 10:52 AM
  5. Replies: 4
    Last Post: 10-13-2004, 09:17 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •