Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: DWW-700 problems, no tech support response yet

  1. #1
    Newbie
    Join Date
    Oct 2006
    Posts
    12

    DWW-700 problems, no tech support response yet

    I bought the DWW-700 from digitalww.com about a year ago and it has been having problems for a little while now. The screen still looks fine, but the touchscreen won't calibrate correctly. It recognizes that i have touched the screen, but no matter where i touch it, the cursor jumps up to the top right corner of the screen.

    I have tried calibrating the screen several times. I have even tried uninstalling and reinstalling the drivers. Nothing has worked so far. I sent 3 emails to digitalww tech support so far over the course of MANY days, and he has not responded at all.

    Anyone run into this before? Does anyone have any suggestions?


    Thanks,
    Sean

  2. #2
    Constant Bitrate legacy05gt's Avatar
    Join Date
    May 2005
    Location
    Georgia
    Posts
    154
    Try the drivers listed on this page: DWW-700 problem solutions


    as per Digital WW's response, look here:
    http://www.mp3car.com/wiki/index.php/Where_is_Armen%3F
    <[[][][][][][][][][][][][]>
    Progress:99% not 100% because theres always something to do...
    Centrafuse on XP (lited)
    EN15000
    120GB 2.5" SATA HD
    1GB DDR2 Ram
    M2-ATX PS
    Slot-Load DVD
    BU-353 GPS w/Mappoint 2k6
    DWW-700M

  3. #3
    cheap custom title JC-S60's Avatar
    Join Date
    Mar 2004
    Location
    Ghent - Belgium
    Posts
    1,863
    Check if your touchscreen isn't pressed by something in the corner.

    Slide a piece of paper between the screen and the housing or open up the screen, clean out any dirt or dust and re-assemble.

    Good luck!

  4. #4
    Low Bitrate XMatrix's Avatar
    Join Date
    Jan 2007
    Posts
    69
    Quote Originally Posted by sregger View Post
    I bought the DWW-700 from digitalww.com about a year ago and it has been having problems for a little while now.

    I sent 3 emails to digitalww tech support so far over the course of MANY days, and he has not responded at all.

    I would like to share my experience about digitalworldwide.com with you folks. Armen doesnt reply back to his emails despite me a very potential customer. Heck I have even a paypal account infront of me ready to make payment and yet he refuses to reply nor answer my questions.

    Some service!

  5. #5
    Neither darque nor pervert DarquePervert's Avatar
    Join Date
    Apr 2004
    Location
    Elsewhere
    Posts
    13,950
    You'll find that a number of members here will disagree with you, myself included.

    Have you sent another email? Have you called him on the phone? How long have you waited for a response?
    Have you looked in the FAQ yet?
    How about the Wiki?



    Under normal circumstances, a signature would go here.

  6. #6
    Constant Bitrate cMags's Avatar
    Join Date
    Jun 2005
    Location
    Marietta, GA
    Posts
    215
    I'm experiencing the same issue as the OP. I've been chasing this issue since I bought my DWW-700H also about a year ago. Back in june, Armen sent me a new TS to try out, but it seems that's not the cause since both TS's have the same issue. It must be the controller board (It's not the software/driver).

    I've been trying to get a hold of Armen since October regarding an RMA of the TS controller (or the whole monitor) via email, but have had no luck. I'll probably try calling him next.

    I'd hate to have to pay for it, but it might be easier, so does anyone have a TS controller for sale?

    CarPC v2.5 up and running - all hardware installed, skin configured, and iG tweaked like crazy. Now for OBD-II, and voice control, and camera plugin, and... :nutz: - it never ends!

  7. #7
    Maximum Bitrate buurin's Avatar
    Join Date
    Sep 2005
    Location
    Seattle, WA
    Posts
    463
    There was a post a long time ago that said the plastic casing was pressing against the screen, causing the behavior you two are experiencing.

    My experience with the 700H has been pretty good overall. I did however have an issue getting in touch with Armen which was frustrating but I will admit that he did do his best considering he is running such a small operation.

    Ill try to find the thread on the casing...

    EDIT:
    Hardware Review: DWW-700H First Impressions
    B Smoov
    Project Status: 90% Complete

    Next Step: TIVO for Radio

    Ampie Case :: MII10000 Mobo :: M1-ATX PSU :: 512MB RAM :: 2.5" HD, 60GB, 5400rpm, 16MB Buffer :: DWW-700H :: Centrafuse

  8. #8
    Constant Bitrate cMags's Avatar
    Join Date
    Jun 2005
    Location
    Marietta, GA
    Posts
    215
    Thanks for the link. I remember seeing that and trying it out myself, but to no avail. Well, I suppose I could see for sure by pulling the screen out of the case and running it on the bench to see if I can get it working. If that's the case, I'll figure out something. Otherwise, I think I'll need a new TS controller..

    CarPC v2.5 up and running - all hardware installed, skin configured, and iG tweaked like crazy. Now for OBD-II, and voice control, and camera plugin, and... :nutz: - it never ends!

  9. #9
    Low Bitrate XMatrix's Avatar
    Join Date
    Jan 2007
    Posts
    69
    Quote Originally Posted by DarquePervert View Post
    You'll find that a number of members here will disagree with you, myself included.

    Have you sent another email? Have you called him on the phone? How long have you waited for a response?

    Well honestly speaking, I have send countless emails to him. Put it like say 7-10 emails per day til one reply comes back. Even now, when I send out one email about 2 weeks back, there has been no reply since. Yes I agree that he is sincere in helping when he do reply. But if such replies comes like 7-10 days, it best to seek elsewhere. No offence guys! Maybe it just that I'm overseas and it's frustrating.

    Another thing - his contact number refused to accept unknown numbers which if you dial from overseas, thet's what it shows.

  10. #10
    Newbie
    Join Date
    Oct 2006
    Posts
    12
    Work has been nuts lately, so i haven't gotten a chance to try the drivers linked here yet - but thank you for the advice. I will be looking into the casing issue soon as well.

    My biggest concern with Armen not responding to me (still no response to any of my 4-5 emails) is that when i started emailing him weeks ago, my screen was still under warranty. Now the warranty has ran out due to lack of reply. I didn't see his phone number on the site, can anyone post that?

    As of this morning, the website wasn't pulling up for me either. I am fully willing to give people the benefit of the doubt, but after awhile you have to accept that you have been screwed.

    -Sean

Page 1 of 2 12 LastLast

Similar Threads

  1. Tech Support for Backlighting (EL) and Inverters offered
    By Electrolumin in forum LCD/Display
    Replies: 2
    Last Post: 09-01-2004, 11:42 PM
  2. Network problems... tech support
    By cadence117 in forum Wireless Communications
    Replies: 37
    Last Post: 04-30-2004, 04:30 AM
  3. Problems, Problems. Need some support.
    By mhermann in forum General Hardware Discussion
    Replies: 8
    Last Post: 04-22-2004, 08:59 AM
  4. Network problems... tech support
    By cadence117 in forum Wireless Communications
    Replies: 0
    Last Post: 04-20-2004, 06:47 PM
  5. For the love of tech support
    By ShinkunoNamida in forum Off Topic
    Replies: 1
    Last Post: 05-21-2002, 01:12 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •