Results 1 to 3 of 3

Thread: DWW-700M - Dieing? Flickers and then turns off :(

  1. #1
    Constant Bitrate
    Join Date
    Aug 2004
    Location
    Bundaberg QLD AU
    Posts
    154

    DWW-700M - Dieing? Flickers and then turns off :(

    I have a DWW-700M now i have had it installed in my car for about 3-4 months, it had been working fine until about a week ago... It now turns on for a bout 10 seconds the screen then flickers and it turns off...

    Whats going wrong? do i need to send it back to DWW for repair?

  2. #2
    Constant Bitrate
    Join Date
    Aug 2004
    Location
    Bundaberg QLD AU
    Posts
    154
    I know this is an old thread... but save creating a new one... does anyone know what causes this problem and how to fix it?

    Last i remember i needed to get a full new replacement panel as far as i remember being told...? if so anyone know what the suitable replacement screen is?

  3. #3
    Variable Bitrate xs10x's Avatar
    Join Date
    Jul 2005
    Location
    Bronx, NY
    Posts
    263
    If you are interested I have mine forsale. all it needs is a ribbon cable. everything else works. no dead pixels on screen. motor and gears work.

    Asking $200
    ````` _____||.\__
    .:.:.:.:.:.:;!_(o)______(o)'i
    TruckputerX - Vortech SuperCharger Vid
    TruckputerX Progress Bar [|||||||||-] 90% Complete [It's never 100% done]

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •