Results 1 to 8 of 8

Thread: Lilliput 889gl Brand new, stopped working(no warranty)HELP!

  1. #1
    Newbie
    Join Date
    May 2007
    Posts
    47

    Lilliput 889gl Brand new, stopped working(no warranty)HELP!

    Hi guys i had just set up my car pc and i turned it all on.
    Everything seemed to be going to plan but when my computer was powering up i could see the POST then the resume from hibernation but with a box saying "monitor auto adjusting" or soemthing along those lines, then it got to the desktop and after a few seconds the screen started flickering with white and then it went all white!

    So i unplugged it and plugged back in but now i get a power light on but the screen is completely blank.

    I hope someone can help me because this is only about the 3rd time i have tried using the monitor to test it and i have modified the housing so my warranty is void.

    I hope i havent ruined a brand new 160 screen.

    BTW the way i have modified the screen housing leaves a slight part of the bottom of the circuit board exposed, i shouldnt think this had anything to do with it?
    Also i have tryed the screen off my home pc witht he exact same results.

    ALSO previous to having this problem with the screen when connecting it into my car i had tried it on my home PC and it worked fine!

  2. #2
    Newbie
    Join Date
    May 2007
    Posts
    47
    Anyone got any ideas?

  3. #3
    Variable Bitrate
    Join Date
    Mar 2007
    Posts
    356
    when trying to build a lcd projector, I destroyed 3 or 4 lcd monitors when trying to remove the backlight. (probably the most difficult thing to do in the world)

    and every single failure was due to the data ribbon being pulled too much. they are super super fragile. they sell ffc ribbon extensions from some places for certain lcd's. but mostly for the larger 15 inch to 19 inch computer lcd's.

    if you're lucky, maybe your lilliput is just not grounded. that is a nother problem when you take apart lcd's. they often become ungrounded when parts are off or modified.

    the only other possibility is that maybe you had a power surge from cranking yoru engine and it blew the lilliput?

    who knows,

  4. #4
    Newbie
    Join Date
    May 2007
    Posts
    47
    Ok thanks for your reply.

    If i cant see any burn marks on it at all though wouldnt it mean i havent blown it?

    Also i dont think the grounding should matter cos it would ground from the power source and the only bits i have removed are some parts of the outer housing.

    Also i am puzzled the most by the fact that it is obviously recieving power becasue the light comes on but i cant actualyl ge tthe screen to power on pressing the button it just stays red.

  5. #5
    Variable Bitrate
    Join Date
    Mar 2007
    Posts
    356
    I am leaning towards the ffc ribbon (I believe that's what they are called) being the culprit.

    when you took off some of the case pieces, did you pinch or bend the lcd panel ribbon/s? sometimes just bending them a little can destroy the ribbon's functioning.

    But I do know that lilliputs are supposed to be one of the more DIY friendly lcd's for taking apart, so you'd have to be unlucky to have a fragile one.


    have you tested the liliput with differenent sources (out of car, etc.)?

  6. #6
    Variable Bitrate
    Join Date
    Mar 2004
    Posts
    286
    does it just stay white all the time?

    usually that's a loose/broken ffc cable, like everyone else has said

  7. #7
    Newbie
    Join Date
    May 2007
    Posts
    47
    When i took it apart i was very careful but i obviously could prevent a bit of bending of the cables.

    I have tried it with other sources and the same happens.

    All i get is a blank black screen and the power light stays on red.
    I cannot change from vga to rca or anything.

  8. #8
    Newbie
    Join Date
    May 2007
    Posts
    47
    Here are some photos of my board, maybe someone can spot something.



Similar Threads

  1. Help Lilliput 889gl not working
    By blown_mx5 in forum LCD/Display
    Replies: 0
    Last Post: 11-02-2006, 12:22 PM
  2. Replies: 4
    Last Post: 06-10-2006, 11:46 PM
  3. xenarc first impressions, tried lilliput before
    By emdzey01 in forum LCD/Display
    Replies: 7
    Last Post: 06-09-2005, 06:26 PM
  4. Replies: 5
    Last Post: 04-01-2004, 04:37 AM
  5. Lilliput Touch Screen Stopped Working
    By XtReMaTriX in forum LCD/Display
    Replies: 26
    Last Post: 12-10-2003, 05:21 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •