About a month ago i put my icivic together, running an intel mac mini and a Xenarc in-dash monitor 700.
Below you will find a review that I wrote along with a grading system beside each characteristic

Pictures
[IMG][/IMG]


[IMG][/IMG]
Here is my initial review - my question will be at the bottom.


[IMG][/IMG]

[IMG][/IMG]

Construction

The unit is fairly sturdy and tough looking when holding it in your hand. There is a spring mechanism that allows the screen to pop out, and then you have to flip it up with your hand. The springing motion just seems very rough. I feel as if it'll break (it hasn't).

The instructions state to use the screws (not included) to mount the unit to the frame. Well first of all, why are screws not included? After I pulled some screws off and older unit, I found that the holes on the bracket and the holes on the unit do not line up. With no desire to drill into the frame of the unit, I just let gravity and tension to hold it there. That worked fine, except that a thief could easily remove it. The unit does have security bars on the back, but I was at a loss as to how I would utilize them. F

Screen controls

The screen does have a power button, menu button, selector button, arrows up and down and a brightness button.

The buttons were okay and for the most part worked fine. They controlled brightness levels, backlight, contrast and there is even an auto-detection button where the screen will adjust the lighting based on the ambient lighting. Although that sounds great, I found the range of brightness and contrast was limitted especially during the day.

For the most part, I had no real complaints about the controls. There is a remote control but I never used it yet.

The unit does allow for 3 inputs: Av1, Av2, and Pc mode. So by a push of a button the unit can switch to an onboard camera (assuming it is on). I thought that was a neat feature (one that I haven't used yet though as I don't have a camera installed). I believe it also allows for picture in picture with those AV options. B+

Touch Screen

As for the touch screen it was very easy to calibrate. The unit came with mac compatible software, and just installed and like a mac always does, it just worked. As for touching the screen, there is no problem there at all, the controls are not overly sensative. As this is my first touch screen, i don't have much to compare it to. As far as i'm concerned the touch Screen controls get an A+

Screen Resolution

This is what most people I believe are interested in. I'll start off by saying that in direct sunlight the screen is not visible at all. No amount of adjusting will change anything. I imagine though that might be the case for most screens. In in-direct sunlight but very bright conditions the screen is visible, but you may need to squint a few times. The screen is 'matt' not glossy which does help for visibility purposes but it still needs more work.

Grey, rainy, or dark conditions the screen is very visible. In fact, i'd say the screen quality WAS exceptional. 800 x 600 is what was being run. I played a few DVD's and the quality was incredible. So I have no complaints about the actual video quality. What I do have a complaint though was that it took about a minute or 2 for a video to start. To eliminate the mac as the faulty part, I brought it in the house and it worked fine...so it must be somewhere between mac and stereo. B I give it a B as I think the screen resolution is good overal, but not perfect. I think all displays will washout in direct sunlight. Also because I now after one month am experiencing problems with it. See below for issue.

So that is my initial review of the unit. That being said, after about a month of working without problems, yesterday my screen went GREEN. It is as if the contrast is set to an extreme setting. Everything has a green tint to it. I tried fiddling with the contrast, but nothing would work. To eliminate the mac as the problem, I tried it on another screen and it worked like a charm. I changed the dvi-vga connector (thinking that might have been it) but it was not the problem. I re-checked all connections, but I can't get it out of Green mode. I am going to call Xenarc and see if they will honour their warranty as I am within the one year mark.

So that's, there is my review. I give it thumbs down for it's shotty at best construction, screws not included, holes not aligned and for the fact that my screen now has a green tint to it.

If anyone has any solutions to my screen problem, please let me know


**** EDIT **** UPDATE:

Just got off the phone with the company from where I purchased it from. They told me the issue with the green tint can be resolved either through them or xenarc as the unit has an 18 month warranty.

As for the bracket screws, they told me when I bought it, Xenarc was switching between two models (I have the newer one, supposed to be brighter) and that they probably just shipped the wrong bracket. I was told Xenarc would send me one free of charge.

So i'm gonna send the unit in, and we'll see if Xenarc will replace or repair the unit. With this in mind, i'm stuck between thumbs up and down. The unit should have come with the correct screws and last longer than 1 month.