Results 1 to 5 of 5

Thread: Help troubleshooting touchscreen controller for Xenarc (TouchKit)

  1. #1
    Newbie
    Join Date
    Aug 2007
    Posts
    16

    Help troubleshooting touchscreen controller for Xenarc (TouchKit)

    Before I started making my custom case for the LCD I test the screen and the touchscreen work fine right out of the box. The alignment was a little off, but it would at least attempt to work.
    I now have everything assembled and working in my carpc with exception of the touchscreen. Despite the several troubleshooting sessions that I was almost certain would fix the problem, I have yet to figure this one out.

    My touchscreen is somewhat responsive for a limited time I can make the cursor move by touching the screen but the movement does not follow my finger nor does it go in the correct direction.
    From time to time the cursor will recenter itself in the middle of the screen. Other times the cursor will center itself so rapidly that it is impossible to move away. Sounds like a calibration issue, right?

    I try to run the calibration utility... but it doesn't work. Either it takes way too long (10+ mins) to 'read parameters' or if I am lucky I can make it to the 4 point calibration screen but the screen goes non-responsive and will not accept me taping on the X (which only blinks for 1-2 seconds) I also experience random right clicks, which I think are resulting from the touchscreen sending a 'click' command continuously (I believe the software is setup to simulate a right click if you 'click and hold')

    Just recently I tried updating my video drivers and ever since the 'xTouchMon.exe' app will crash at startup making it impossible to calibrate.

    Does any one have advice to fix this?
    Has anyone experienced similar issues with xenarc's touchscreen controller?
    Does this appear to be a software issue or a hardware issue? (keep in mind built a complete custom case for the lcd screen and there is a chance damage could have been done)

    I am linking to a video to try and demonstrate the issue I am having. (sorry for the size, 23MB) At the beginning of the video you can see the 'xTouchMon.exe' stop responding pop up. After that you can see how the cursor does not accurately follow my finger, or click. Then towards the end you can see how it randomly right clicks.

  2. #2
    Newbie
    Join Date
    Feb 2008
    Posts
    24
    i'm also having this issue now that i got my screen i my car (worked fine before hand) i'm wondering if somehow the connector got broken (there is a post about it on these forums about the tsv not working)

  3. #3
    Variable Bitrate
    Join Date
    Oct 2007
    Posts
    302
    Quote Originally Posted by ahave View Post
    Before I started making my custom case for the LCD I test the screen and the touchscreen work fine right out of the box. The alignment was a little off, but it would at least attempt to work.
    I now have everything assembled and working in my carpc with exception of the touchscreen. Despite the several troubleshooting sessions that I was almost certain would fix the problem, I have yet to figure this one out.

    My touchscreen is somewhat responsive for a limited time I can make the cursor move by touching the screen but the movement does not follow my finger nor does it go in the correct direction.
    From time to time the cursor will recenter itself in the middle of the screen. Other times the cursor will center itself so rapidly that it is impossible to move away. Sounds like a calibration issue, right?

    I try to run the calibration utility... but it doesn't work. Either it takes way too long (10+ mins) to 'read parameters' or if I am lucky I can make it to the 4 point calibration screen but the screen goes non-responsive and will not accept me taping on the X (which only blinks for 1-2 seconds) I also experience random right clicks, which I think are resulting from the touchscreen sending a 'click' command continuously (I believe the software is setup to simulate a right click if you 'click and hold')

    Just recently I tried updating my video drivers and ever since the 'xTouchMon.exe' app will crash at startup – making it impossible to calibrate.

    Does any one have advice to fix this?
    Has anyone experienced similar issues with xenarc's touchscreen controller?
    Does this appear to be a software issue or a hardware issue? (keep in mind built a complete custom case for the lcd screen and there is a chance damage could have been done)

    I am linking to a video to try and demonstrate the issue I am having. (sorry for the size, 23MB) At the beginning of the video you can see the 'xTouchMon.exe' stop responding pop up. After that you can see how the cursor does not accurately follow my finger, or click. Then towards the end you can see how it randomly right clicks.


    I have this same issue. I had it working great. just finished my fabrication and movied the internals to another shell and this shatty issue. After reading some other posts, people are correct. The screen is pinched in the corner the mouse arrow goes to. I found a quick fix but doesn't hold up for good. I slipped a credit card in the corner and pulled gently up on it. It def. unpinched the screen, but went back to this crap state when I hit a bump. I'm going to try this again in hopes to settle the bracket back a bit to allow the screen to breath in the corner, but hopefully I don't have to take it apart again. I'll update if I have to take it apart, if not for anyone else assume this works if i don't repost.

  4. #4
    Newbie
    Join Date
    Jul 2008
    Posts
    1

    Same issue

    I am having the identical issue, did you ever resolve the problem?

  5. #5
    Variable Bitrate
    Join Date
    Oct 2007
    Posts
    302
    Quote Originally Posted by LuckyLuke View Post
    I am having the identical issue, did you ever resolve the problem?
    I gently stuffed a card into the corner and pulled up to free the tention. It worked on and off. Everytime I restarted the pc it would happen. About three weeks ago I reformated my HD and problem never came back. Kinda wierd but i'm not complaining. The card trick worked though.

Similar Threads

  1. Problem w/ Touchscreen or USB Controller?
    By SpinOut123 in forum Input Devices
    Replies: 5
    Last Post: 05-23-2008, 11:28 AM
  2. Replies: 0
    Last Post: 10-23-2007, 12:45 PM
  3. Anyone know where i can find a lilliput touchscreen controller?
    By Sonicxtacy02 in forum General Hardware Discussion
    Replies: 1
    Last Post: 10-13-2007, 04:45 AM
  4. WTB: USB Touchscreen Controller Board
    By freudie1 in forum Classified Archive
    Replies: 2
    Last Post: 11-18-2006, 02:30 PM
  5. isa touchscreen controller
    By RatFink in forum LCD/Display
    Replies: 2
    Last Post: 03-04-2002, 10:24 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •