Results 1 to 3 of 3

Thread: 700IDT spring problem

  1. #1
    Newbie
    Join Date
    May 2008
    Posts
    18

    700IDT spring problem

    I just received my new 700IDT display and the screen wont stay latched. I push it all the way in and it hits the back and comes right back out again. I have used varying degrees of pressure to try to get it to latch and I have only been able to successfully get it to latch a couple of times after spending about 5 minutes on it. Anyone know how to fix it? I would rather not RMA it just for the latch, but I need it to stay latched when not it use.

    Thanks!

  2. #2
    Newbie
    Join Date
    May 2008
    Posts
    18
    Never mind I fixed it. The spring on the bottom kept getting jammed so it wouldnt properly catch.

  3. #3
    Low Bitrate raggaman's Avatar
    Join Date
    Feb 2006
    Location
    Phoenix, AZ
    Posts
    57
    Hey I am having the exact same problem. Do you mind explaining how you fixed it? RMA crossed my mind but if I can fix it then why bother. THX in advance.
    Oh why do I spend so much time and money on a technology that works only half the time? Is always a work in progress? Is never complete? I wonder.

Similar Threads

  1. Lilliput TouchKit problem solved!
    By AAVfReaK in forum LCD/Display
    Replies: 4
    Last Post: 11-07-2010, 09:29 AM
  2. FAQ: How to install a DVD R/RW in your Xenarc 700IDT
    By cdcamaro9534 in forum The FAQ Emporium
    Replies: 28
    Last Post: 12-10-2007, 01:34 PM
  3. gps navilock and com problem
    By lele67 in forum GPS
    Replies: 0
    Last Post: 04-01-2006, 08:41 PM
  4. Problem with directshow filter and WMP
    By EricE in forum Software & Software Development
    Replies: 0
    Last Post: 03-01-2006, 11:38 AM
  5. Car Idle - power/amp problem?
    By TheFaze in forum Car Audio
    Replies: 1
    Last Post: 12-16-2005, 12:10 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •