Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Help! Touchscreen not working

  1. #1
    Constant Bitrate Stealth915's Avatar
    Join Date
    Apr 2004
    Location
    Bay Area, CA
    Posts
    137

    Help! Touchscreen not working

    I'm having trouble getting the touchscreen on my 2008 model Lilliput 629. I purchased it from bybyte, prebuilt into a Mazda3 dash kit. The monitor works fine, and the touchkit software and drivers install perfectly. The only thing is when I touch the screen, nothing happens. I've tried running the calibration and the screen doesn't detect the stylus or my finger. Anybody have any idea as to what is the problem? I've tried uninstalling/reinstalling the drivers, and also have tried multiple USB ports. Still no luck. Please help!





    I don't know anything about taking apart the touchscreen, but looking at the back of the unit, I noticed that the CN20 connector doesn't have anything plugged in to it. Could this be the reason my touchscreen isn't responding?


    2004 Mazda3 Carputer Worklog - Update 5/17/11: Carputer 2.0 Hardware Selection

  2. #2
    Fusion Brain Creator 2k1Toaster's Avatar
    Join Date
    Mar 2006
    Location
    Colorado, but Canadian!
    Posts
    10,049
    Check from the LCD to the controller board. There should be a clear 4 conductor ribbon from it to the board.

    It could be backwards, loose, or missing. I would check that.
    Fusion Brain Version 6 Released!
    1.9in x 2.9in -- 47mm x 73mm
    30 Digital Outputs -- Directly drive a relay
    15 Analogue Inputs -- Read sensors like temperature, light, distance, acceleration, and more
    Buy now in the MP3Car.com Store

  3. #3
    Newbie GhostRiderDad's Avatar
    Join Date
    Apr 2008
    Posts
    42
    I have a 889GL and the touch screen suddenly stopped working. It had only been in the car 3 days. It is possible that the connection for the USB stopped working because of a faulty or worked loose ribbon cable...and where do I look? Thanks

  4. #4
    Newbie
    Join Date
    Aug 2007
    Posts
    18
    Is the controller detected in Windows?

  5. #5
    Low Bitrate dLockers's Avatar
    Join Date
    Jul 2007
    Posts
    75
    I have EXACTLY the same problem as you, same drivers, same firmware issue but using the innovatek 8inch TM868 iirc.

    Detected in windows, no errors, installed via device manager then application/utility installed - still no go, tried it upside down & back to front to eliminate all possible angles and im still getting no feedback from the touchscreen.

    PLEASE HELP!

  6. #6
    Newbie GhostRiderDad's Avatar
    Join Date
    Apr 2008
    Posts
    42
    In my case, the USB is no longer being deteced. I've tried it in other USB ports and still nothing. did something fry on me?

  7. #7
    FLAC Machinehead's Avatar
    Join Date
    Jun 2007
    Location
    hijacks small portable city
    Posts
    1,381
    Quote Originally Posted by Stealth915 View Post
    That connector is for the speaker, it doesn't have anything to do with the touch screen.

  8. #8
    Constant Bitrate Stealth915's Avatar
    Join Date
    Apr 2004
    Location
    Bay Area, CA
    Posts
    137
    Thanks for the info. I tried to find a ribbon cable on the unit, but I couldn't really see much without taking the unit apart. I decided to just send it back to ByByte to get it fixed.
    2004 Mazda3 Carputer Worklog - Update 5/17/11: Carputer 2.0 Hardware Selection

  9. #9
    Newbie GhostRiderDad's Avatar
    Join Date
    Apr 2008
    Posts
    42
    Does anyone kno why the USB would stop being recognized, and hence the touch screen not work? I had it in my car 3 days and it stopped cold. Thank goodness I have a mouse to use as a back up! HELP!!!!!

  10. #10
    Low Bitrate angel120's Avatar
    Join Date
    Apr 2008
    Location
    Queens, NY
    Posts
    63
    Quote Originally Posted by GhostRiderDad View Post
    Does anyone kno why the USB would stop being recognized, and hence the touch screen not work? I had it in my car 3 days and it stopped cold. Thank goodness I have a mouse to use as a back up! HELP!!!!!

    I'm having the same issue. My EBY701's touch isn't in Device Manager, but the video works perfectly fine. It used to work when I first got it, but no dice. I think the touch controller is screwed up.
    2003 Mazda 6i Sedan - White
    CarPC in the making!

Page 1 of 2 12 LastLast

Similar Threads

  1. Touchscreen install not working
    By Skipjacks in forum Input Devices
    Replies: 1
    Last Post: 10-02-2007, 07:43 AM
  2. Touchscreen not working
    By Ascension in forum LCD/Display
    Replies: 5
    Last Post: 06-01-2005, 11:14 AM
  3. Touchscreen problems with nlite and minlogon
    By Ascension in forum WinNT Based
    Replies: 1
    Last Post: 06-01-2005, 05:18 AM
  4. Replies: 1
    Last Post: 04-27-2005, 03:53 AM
  5. Lilliput touchscreen problem
    By samc in forum Input Devices
    Replies: 1
    Last Post: 05-09-2004, 11:12 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •