Results 1 to 5 of 5

Thread: Lilliput 629 -- broken, or am I dumb...?

  1. #1
    Constant Bitrate
    Join Date
    Jun 2008
    Location
    Atlanta, GA
    Posts
    146

    Lilliput 629 -- broken, or am I dumb...?

    Just got my new Lilliput 629. Based on my poking and prodding, it looks like I got a defective unit, but maybe someone can point me to an obvious error I'm making:

    If I plug in just the power cord, I get the red LED lighting up the POWER button. Pressing any of the buttons does nothing, however. I would expect to be able to access the OSD even without a VGA input, but I guess maybe that's not how it works.

    Plugging in the VGA cable to my laptop, the laptop sees a second display. However, even when enabling the second display, I get no video on the 629. Again, I have a red LED lighting up the POWER button, but pressing the buttons does nothing.

    Plugging in the USB cable, the laptop doesn't see a new device. While installing the Touchkit drivers, I don't get any controllers detected.

    As I see it one of two things is broken, the cable or the monitor itself. Questions:

    1) Should I be able to do anything with the 629 with just a power connection, no VGA, video, etc?

    2) On the VGA/USB cable, how far should the male end go into the female? Should the big ridge on the male end (which stops the screw-on bit from falling off) lie flush against the female end of the cable? As hard as I try and push the two together, there is still some space...

  2. #2
    Variable Bitrate
    Join Date
    Jul 2006
    Location
    seattle
    Posts
    421
    no, you won't be able to access osd without input signal.
    try to change the resolution on the secondary monitor on your laptop, or try different computer altogether.

    Is the liliput new? I doubt it's broken.

  3. #3
    Constant Bitrate
    Join Date
    Jun 2008
    Location
    Atlanta, GA
    Posts
    146
    Quote Originally Posted by skuller View Post
    no, you won't be able to access osd without input signal.
    try to change the resolution on the secondary monitor on your laptop, or try different computer altogether.

    Is the liliput new? I doubt it's broken.
    So I won't be able to access the OSD, but should I at least be able to take the unit out of standby (get the blue buttons)? I plugged up the video input, and got the same response -- red POWER button and nothing else.

    The thing is brand new (the warranty sticker thing on the case seam says 6/08) so I really hope it's not defective.

  4. #4
    Registered User
    Join Date
    Apr 2004
    Posts
    803
    Sounds like its broken. Send it back ASAP.

  5. #5
    Variable Bitrate
    Join Date
    Jul 2006
    Location
    seattle
    Posts
    421
    Quote Originally Posted by spamminator View Post
    So I won't be able to access the OSD, but should I at least be able to take the unit out of standby (get the blue buttons)? I plugged up the video input, and got the same response -- red POWER button and nothing else.

    The thing is brand new (the warranty sticker thing on the case seam says 6/08) so I really hope it's not defective.
    you were right, the screen should turn blue for a few seconds.

Similar Threads

  1. New Lilliput 629 Native Resolution?
    By Darkman613 in forum LCD/Display
    Replies: 46
    Last Post: 05-30-2011, 09:11 PM
  2. Replies: 1
    Last Post: 04-19-2009, 12:47 PM
  3. Lilliput 629 stopped working
    By numbr_9 in forum LCD/Display
    Replies: 1
    Last Post: 10-03-2007, 10:33 AM
  4. Lilliput 629 screen not clear - help
    By gdawg in forum LCD/Display
    Replies: 0
    Last Post: 09-28-2005, 08:34 AM
  5. WTB: Broken Lilliput 7" TS
    By avidan in forum Classified Archive
    Replies: 0
    Last Post: 01-20-2005, 12:13 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •