Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Lillitput 629GL-70NP/C/T 800x480 WTF is going on??

  1. #1
    Maximum Bitrate
    Join Date
    Apr 2006
    Location
    Sydney, Australia
    Posts
    574

    Arrow Lillitput 629GL-70NP/C/T 800x480 WTF is going on??

    OK I know this may have been done and dusted, but I'm trying to understand the 800x480 story, so on with the flame suite..

    now according to the specs from Lilliput

    Model: 629GL-70NP/C OR
    Color System: PAL-4.43 / NTSC-3.58
    DISPLAY SCREEN: Diagonal 7 inches/ 178mm (16: 9)
    High Resolution: 1152000 pixels(800*480) <------ is this the magic number?

    Ok, so the specs show the 800x480 as high resolution, so what does this really mean?

    Using the XP OS to change display, I can get 1024x768, 800x600, 640x480 and some higer ones. blah blah blah right?

    So I've asked the manufacture of my motherboard to write an option in BIOS to allow me to boot in 800x480, which they have done, after making this version of firmware for my BIOS, i can choose 800x480 (18bit).

    (AMI BIOS) on Kino 9453 motherboard

    I boot and get "out of range", so it's too high, too low, what? why is this 18bits? so changing things in the BIOS I finally get it to display the POST.

    **Pictures to come**

    Using the lilliput remote to get into the info it shows the display as 720x400 while in the BIOS screens?

    After windows boots up, it goes blank, no display.

    I go into safe mode change it to 800x600 in XP and then reboot, after a reboot the XP splash shows up as 800x600, but then it goes blank.

    I'm going nuts trying to figure out what is going on. Is it because the BIOS has the display set at 800x480 and the XP OS has a different display and they are conflicking?

    I've taken some pictures with the different resolutions and I will post them below when I get home later, so I'll reserve the next sopt for them.

    Do I need to reg hack my display entry, or is my BIOS display wrong?

    Now for the million $$$$$ question - Do I really need 800x480?

    Cheers
    Kosti
    New Car PC Build list in progress

  2. #2
    Maximum Bitrate
    Join Date
    Apr 2006
    Location
    Sydney, Australia
    Posts
    574
    Now for the pictures

    1st off the BIOS POSt screen of the Kino mainboard




    next the display option available after the manufacturer created a new bios for me for 800x480






    now what the screen detects the resolution as being 640x480




    starting up the XP OS the monitor detects this still at 640x480 and not 800x480 (is this now driven by the OS at this point)?




    then a blank screen after the OS loads and the monitor shows this as the resolution



    NOTICE the Vertical freq??? So what's happened? then there is no VGA signal and the screen seems to go into standby mode

  3. #3
    Maximum Bitrate
    Join Date
    Apr 2006
    Location
    Sydney, Australia
    Posts
    574
    so what's got me thinking is either the BIOS res was written for a LVDS but I am not sure, if I change the settings there is not a huge change.

    The most interesting resolution display I got was when I started in SAFE MODE for the OS

    720x400




    but this soon vanished as I loaded into safe mode to 640x480




    now I can change the display res in safemode to any of the popular resolutions 800x600 & 1024x768.



    &



    but when the OS loads after a restart, i end up with the same problem




    I even attempted to reload the OS incase the display got corrupted showed it at 720x400, but then after a reload, it failed again


  4. #4
    Maximum Bitrate
    Join Date
    Apr 2006
    Location
    Sydney, Australia
    Posts
    574
    Now another thing I've noticed with the lilliput is the characters after the V/H frequencies.

    If you look at the following, some have a half moon, while some display resolutions have a "-" dash, whether this has any significance I am not sure, but for now I am stuck on getting the right resolution, so I've put this out to those who have managed to get this working with a BIOS and OS hack(if required)









    please share your experience with the 800x480 and how you achieved this, REG hack or BIOS hack.

    Thanks
    Kosti

  5. #5
    Maximum Bitrate
    Join Date
    Apr 2006
    Location
    Sydney, Australia
    Posts
    574
    I also found this link, which explains the process to hack the EDID.

    http://softwarecommunity.intel.com/W...aphics/239.htm

    Will this help get what I need for optimuim performace/display?

  6. #6
    Maximum Bitrate
    Join Date
    Apr 2006
    Location
    Sydney, Australia
    Posts
    574
    OK, so I've sent this link to the motherboard maker in the hope they can work out why the display isn't showing up the native resolution of the llilliput.

    I did a new install and after sometime, I got the display stable on 800x600.

    Reading more threads on this, and the some what outdated links, it seems I will need to use the above method or try powerstrip as a last resort. I'm note sure how to use it et, but I'll guess I'll figure it out, the other thing I need to tried was some re-written DTD codes but this will be one of the last things to try.

    A useful link

    http://www.mp3car.com/vbulletin/lcd-...-graphics.html

    Quote Originally Posted by JuniorGeezer View Post
    Here's how it worked for me, for the 945 Intel mobile graphics and for a Lilliput 629 monitor.

    - Install a display driver that does not already contain a 800x480 resolution. I just took the latest regular driver from the Intel site.

    - Run DTD Calculator, and see if the two buttons in Registry Hack are active.

    - In the Calculation tab, select the standard timing 720x480.

    - In the Registry Hack tab, press More if needed, press Get Calculated, press Create Modeline, press write DTDs to registry. Reboot.

    - Display properties, click to show all modes, select the 720x480 driver and see if it displays ok. You have now established the ability to add new resolutions with DTD Calculator.

    - Run DTD Calculator again.

    - Start with the 720x480 template in the Calculation tab, change the five most top left values to: 29.5 (MhZ), 800, 816, 880. 936. (It's everything 80 pixels more than before and a bit higher clock to get 60 Hz).

    - Repeat the rest of the procedure with the new 800x480 resolution.
    Quote Originally Posted by freeman25002003 View Post
    Got the 800x480 working for Lilliput EBY701-NP/C/T on Intel 945GM

    Here is the DTD I used:

    82 0C 20 01 31 E0 19 10 64 38 15 00 00 00 00 00 00 00


    Just want to thank those people who wrote DTD Calculator

    I may add info is available on the forums, but all over the place (spent all night) and the conclusion is that getting the native res out of the lilliput is extremely difficult anyway

    I did find some packages put together but these didn't work / failed to install, so my steps will be

    1. Confirm BIOS display res is working from manufacture
    2. Use Powerstrip (no longer free)
    3. DTD hack

    Anyone else got some idea's on the approach to gain 800x480 or is 800x600 good enough?

  7. #7
    Maximum Bitrate galvitron's Avatar
    Join Date
    Mar 2007
    Location
    Socal
    Posts
    719
    Is your monitor connected via LVDS or VGA? That 18bit/36bit stuff looks to be for an onboard LVDS ribbon cable connector as opposed to a VGA setting. Usually VGA is handled with a Windows display driver.
    2006 Lancer Evolution IX MR In-Dash PC Project - WIP

    Planning:
    [----------] 100%
    Purchasing:
    [----------] 90%
    Installation/Fab/Assembly (Revised v2):
    [----------] 90%


  8. #8
    Maximum Bitrate
    Join Date
    Apr 2006
    Location
    Sydney, Australia
    Posts
    574
    Yes, ur right! and yes my screen is connected via VGA not LVDS

    The manufacturer has just confirmed that they wrote that res for the LVDS display not the CRT/VGA.

    They are working on it now for me, so hopefully it will not require too many hacks

    Do you think that once they have the resolution right, windows will see this as an available display res and allow me to choose it or will I still need to use powerstrip, DTD values?

    Cheers
    Kosti

  9. #9
    Maximum Bitrate galvitron's Avatar
    Join Date
    Mar 2007
    Location
    Socal
    Posts
    719
    I am not familiar with that motherboard but if it has Intel onboard graphics you can create the correct driver yourself if you can figure out the DTD string. If so, look at a thread that was all about getting 800X480 on the 945G chipset and it will lay it out for you. I forget the name but search is your friend.
    2006 Lancer Evolution IX MR In-Dash PC Project - WIP

    Planning:
    [----------] 100%
    Purchasing:
    [----------] 90%
    Installation/Fab/Assembly (Revised v2):
    [----------] 90%


  10. #10
    Maximum Bitrate
    Join Date
    Apr 2006
    Location
    Sydney, Australia
    Posts
    574
    Yep, I've got those threads, and quoted some of the steps in a few posts above on here.

    I'm hoping that once the BIOS is correct, the OS will see that this is available and hopefully I will not need to hack the regi or use powerstrip.

    But, there is still something weird going on with the motherboard because the display is not right even after a fresh install.

    I have to connect another LCD monitor and I see this going through phase changes and then I get a display, once I have this, I swap screens to the lilliput and the OS find it and displays XP.


    Does anyone know what the options on the lilliput actually do under the monitor section when selecting the menu option on the remote?

    Phase, Frequency, as these values change all by themselves and I'm wondering that the screen is struggling to display certain ranges and that's why it hits over range?

    Damn if only Lilliput has better support!

Page 1 of 2 12 LastLast

Similar Threads

  1. 800x480 on a transflective lilliput?
    By kuo in forum LCD/Display
    Replies: 23
    Last Post: 12-24-2007, 12:06 PM
  2. Has anyone EVER gotten a Lilliput to detect 800x480?
    By larry_llama in forum LCD/Display
    Replies: 49
    Last Post: 12-03-2006, 02:05 AM
  3. 800x480 on the SP13000 with Powerstrip
    By theminor in forum LCD/Display
    Replies: 15
    Last Post: 10-16-2006, 10:32 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •