Results 1 to 6 of 6

Thread: Xenarc TS acting very strangely

  1. #1
    Constant Bitrate deus ex machina's Avatar
    Join Date
    Mar 2006
    Posts
    136

    Xenarc TS acting very strangely

    My Xenarc touchscreen has started sporadically doing something that is hard to describe. It sort of anchors the cursor to a point on the screen so that when I touch anywhere else, the cursor drags (as if the right mouse button were down) to the point I am touching. When I take the pressure off this point, the cursor immediately pulls back to the position at which it was anchored. I guess that sometimes the fact that I have stopped touching the screen does not register. Also, sometimes it simply clicks itself, but this is more rare.

    I attempted to make a video of this phenomenon with my low-quality camera phone, but it didn't come out very clear. I'll put it up anyway, and maybe you'll be able to see what I'm talking about. You can see the mouse cursor running to and from my finger when it does "anchor" itself (which it does several times in the video).

    Anyway, any ideas? I tried the method in the "how to fix your disfunctional touch panel" sticky and it didn't seem to work.

  2. #2
    FLAC
    Join Date
    Oct 2006
    Posts
    1,025
    most likely the casing is pressing too hard against the overlay, try taking out the casing and see if problem persist.

  3. #3
    Constant Bitrate deus ex machina's Avatar
    Join Date
    Mar 2006
    Posts
    136
    I tried the method in the "how to fix your disfunctional touch panel" sticky

  4. #4
    FLAC
    Join Date
    Oct 2006
    Posts
    1,025
    then its probally time for a new TS overlay.

  5. #5
    Constant Bitrate deus ex machina's Avatar
    Join Date
    Mar 2006
    Posts
    136
    Already ordered. Will update this post for posterity if/when I confirm that it's the panel.

  6. #6
    Constant Bitrate deus ex machina's Avatar
    Join Date
    Mar 2006
    Posts
    136
    New touch panel seems to have solved the problem.

Similar Threads

  1. Poor audio quality Xenarc MDT-X7000?
    By jconfidence in forum General Hardware Discussion
    Replies: 3
    Last Post: 08-11-2008, 12:53 AM
  2. Xenarc 8" TSV backlight acting up.
    By Dexter in forum LCD/Display
    Replies: 7
    Last Post: 06-23-2005, 05:04 PM
  3. xenarc first impressions, tried lilliput before
    By emdzey01 in forum LCD/Display
    Replies: 7
    Last Post: 06-09-2005, 07:26 PM
  4. Replies: 88
    Last Post: 09-15-2004, 06:38 PM
  5. Xenarc acting strange once installed
    By Sivion in forum LCD/Display
    Replies: 8
    Last Post: 08-02-2004, 10:30 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •