Results 1 to 5 of 5

Thread: Lilliput 629 - 2008 touchpanel not working

  1. #1
    Newbie
    Join Date
    Oct 2008
    Posts
    2

    Lilliput 629 - 2008 touchpanel not working

    So i removed my screen from my dash on Thursday to do a bit of tinkering with other things, when replacing the screen and powering up the touch panel was not working, first instinct was to restart, no luck with that. So i removed the usb connector and plugged it back in again and i got a pop up window in the task bar tray stating "One of your USB devices has malfunctioned, disconnect and reconnect and try again" or something to that effect. well i'd disconnect and reconnect it, same problem.

    in hardware manager, it says the same thing, the device is an "unknown device" and its status is "malfunctioning" touchkit doesn't recognize the screen nor does windows. I reinstalled touch kit, latest version, no success, checked all connections, try'd a different usb port, a port i know to be working, so it's not my ports. pulled the screen apart, ribbon cables, both screen and touch panel are all in place, but i re-seated them just in case, touch panel in tact and not damaged.....

    i don't know what else to try.... perhaps its the usb controller board???? who knows...... any suggestions anyone???


    Dave

  2. #2
    Newbie sunnyboy's Avatar
    Join Date
    Sep 2008
    Posts
    3
    Quote Originally Posted by dave89 View Post
    i don't know what else to try.... perhaps its the usb controller board???? who knows...... any suggestions anyone???


    Dave
    I've the same issue, still didn't connect directly (only through HUB) hope HUB is dead, but if HUB is still alive, I have the same questions, is it usual babyborn problem for 629?

  3. #3
    Newbie
    Join Date
    Oct 2008
    Posts
    2
    Originally it was connected through a 4 port hub, which ports still work with other devices, but tested it on other available ports on the pc and no luck.

    Dave

  4. #4
    Newbie sunnyboy's Avatar
    Join Date
    Sep 2008
    Posts
    3
    Quote Originally Posted by dave89 View Post
    Originally it was connected through a 4 port hub, which ports still work with other devices, but tested it on other available ports on the pc and no luck.

    Dave
    the same, but at the same time HDD failed to start up and I couldn't test hub and other hardware..., now waiting for SSD, after it will fix touch or hub.

  5. #5
    Newbie sunnyboy's Avatar
    Join Date
    Sep 2008
    Posts
    3
    UPDATE: it was hub, I've tested touch and it's working !!!!!!!!!!!! Thanks god. Good luck Dave with you touch.
    Russia, Moscow

Similar Threads

  1. Auto switch not working right on Lilliput 629 LED
    By djBEER in forum LCD/Display
    Replies: 4
    Last Post: 07-31-2008, 08:43 PM
  2. lilliput 7" touchscreen part is not working.
    By petb in forum LCD/Display
    Replies: 1
    Last Post: 01-04-2008, 03:26 AM
  3. lilliput 629 won't show windows
    By Snortonnorton in forum LCD/Display
    Replies: 5
    Last Post: 08-25-2007, 12:05 PM
  4. Lilliput EBY-701 / 629
    By thumper_svx in forum LCD/Display
    Replies: 5
    Last Post: 05-16-2007, 05:55 PM
  5. Lilliput Touchscreen not working
    By jjc319 in forum LCD/Display
    Replies: 5
    Last Post: 02-01-2004, 04:37 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •