Page 4 of 4 FirstFirst 1234
Results 31 to 37 of 37

Thread: Xenarc TSV Touch Screen not working (FIXED!!!!)

  1. #31
    Constant Bitrate
    Join Date
    May 2004
    Location
    Northridge CA
    Posts
    141
    oh ok good i just ordered a xenarc and i hope its the newer version

  2. #32
    Newbie
    Join Date
    Jan 2004
    Posts
    21
    I have exactly the same problem - no more controller. From reading these posts this whole situation is ridiculous. Has anyone contacted Xenarc? How can they send stuff out like this? I am confident that I can fix the connector problem but what if I take it apart and its not that? Dont want to ruin the warranty. And by the way, if you purchased a flat panel display, would you be happy with coloured pixels permanantly on the screen? Xenarc seem to think so, aparently this is normal.

    Quote:

    Please note that the LCD screen is made with high precision technology. However, black points or bright points of light (red, blue or green) may appear constantly on the LCD screen, and irregular coloured stripes or brightness may appear on the LCD screen. This is not a malfunction. (Effective dots: more then 99.999%)

    Can someone please explain this, how can this be right?

  3. #33
    FLAC IntellaWorks's Avatar
    Join Date
    Jun 2004
    Location
    NH
    Posts
    1,173

    .

    WOW, can't believe there is tape in there like that... They were probably thinking no one will ever know.. Little did they realize us geeks would tear apart thier casings and mod the screens...


    I got a newer xenarc no tape.. thank god .. I would have flipped my ***** if I saw duct tape in my 475.00 LCD.
    Progress [I will seriously never be done!]
    Via EPIA MII
    512MB RAM
    OEM GPS (embedded)
    nLite WinXP pro on
    1GB Extreme III CF card
    Carnetix 1260 startup/ DC-DC regulator
    Software: Still, re-Writing my existing front end in .Net

  4. #34
    Newbie
    Join Date
    Jan 2004
    Posts
    21
    As I understand it, the TFT manufactuer will batch their screens. So there will be bins of no dead pixels, bins with 1,2,3.. etc dead pixels and they are priced according to quality.

    So I paid 350E which is NOT cheap and they have a no dead pixel garauntee.
    But I have a bright red dot in the middle of the screen!

  5. #35
    Low Bitrate rmjjensen's Avatar
    Join Date
    Oct 2003
    Location
    New Jersey
    Posts
    104

    Thread Revival!!

    Ugh ...I had issues with my laptop install BSOD-ing constantly and I finally got around to fixing it (about 8-9 months later - yes that long) and it works!! So, I go to put it back in my car and the touch screen is not working! I get the message "no more controller" when I try to add it. DAMMITTT!!!

    Let me say that I've had this XENARC screen for a VERY long time - 6 years I'd say - It's been in my Infiniti, Subaru and now the Acura. I've never had any problems and had taken some precautionary measures to make sure things work. I've had many problems with the connector and I had to resolder it about 3 years ago (in my Subaru).

    So, nothing has changed except for the fact that I've been driving and things have had the opportunity to knock themselves loose. I'd like to know where on the screen's board I'd need to resolder? As you can see by this pic, I've used zip-ties and hot glue to make sure the connector doesn't move around.

    Can someone "circle" the area in question?

    Thanks!




  6. #36
    Newbie xenarctech's Avatar
    Join Date
    Aug 2009
    Posts
    38
    Since 2005, we have undergone many revisions and improvements. These problems are non-existant for years. But should anyone have any problem with their Xenarc Screen, please contact us directly as we stand behind our products 100%. And here at Xenarc, we build our monitors with LCD panels that has no bad pixels. But sometimes bad pixel appears after some use. This has been on our FAQ for many many years. Customer do have the option of sending the unit back for replacement within 30 days:

    Q: Why is there black points or bright dots (red, blue, or green) on the LCD monitor?

    A: The LCD screen is made with high-precision technology. However, in rare instances, you may experience black points or bright points of light (red, blue, or green) which may appear constantly on the LCD screen. This is not malfunction and is part of the LCD manufacturing process. However, we guarantee that the effective dots is more than 99.999%. This is a guarantee better than most of the major LCD monitor manufacturers. And if you are still not satisfied with your screen due to any number of dead pixel, you can always send it back within 30days of purchase and we'll replace it for you free of charge!


    Quote Originally Posted by Nick1_S View Post
    I have exactly the same problem - no more controller. From reading these posts this whole situation is ridiculous. Has anyone contacted Xenarc? How can they send stuff out like this? I am confident that I can fix the connector problem but what if I take it apart and its not that? Dont want to ruin the warranty. And by the way, if you purchased a flat panel display, would you be happy with coloured pixels permanantly on the screen? Xenarc seem to think so, aparently this is normal.

    Quote:

    Please note that the LCD screen is made with high precision technology. However, black points or bright points of light (red, blue or green) may appear constantly on the LCD screen, and irregular coloured stripes or brightness may appear on the LCD screen. This is not a malfunction. (Effective dots: more then 99.999%)

    Can someone please explain this, how can this be right?

  7. #37
    Newbie xenarctech's Avatar
    Join Date
    Aug 2009
    Posts
    38
    rmjjensen, your screen is modified and very old so it could be anything. The pictures don't really help. But you can e-mail me directly at [email protected] and I will be more than happy to e-mail you a connector pin-out so you can start from there. Another thing you can try is to replace the touchscreen controller. I would recommend you to send the unit back to us. We can test the control board and touchscreen controller for you for free. You only need to pay shipping.

    Quote Originally Posted by rmjjensen View Post
    Ugh ...I had issues with my laptop install BSOD-ing constantly and I finally got around to fixing it (about 8-9 months later - yes that long) and it works!! So, I go to put it back in my car and the touch screen is not working! I get the message "no more controller" when I try to add it. DAMMITTT!!!

    Let me say that I've had this XENARC screen for a VERY long time - 6 years I'd say - It's been in my Infiniti, Subaru and now the Acura. I've never had any problems and had taken some precautionary measures to make sure things work. I've had many problems with the connector and I had to resolder it about 3 years ago (in my Subaru).

    So, nothing has changed except for the fact that I've been driving and things have had the opportunity to knock themselves loose. I'd like to know where on the screen's board I'd need to resolder? As you can see by this pic, I've used zip-ties and hot glue to make sure the connector doesn't move around.

    Can someone "circle" the area in question?

    Thanks!




Page 4 of 4 FirstFirst 1234

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •