Page 1 of 4 1234 LastLast
Results 1 to 10 of 37

Thread: Xenarc TSV Touch Screen not working (FIXED!!!!)

  1. #1
    Constant Bitrate
    Join Date
    Sep 2002
    Location
    Redmond, WA
    Posts
    171

    Xenarc TSV Touch Screen not working

    I am trying to get my Xenarc touch screen to work under Windows XP.

    After installing the driver and utility program it doesn't work.

    In the eely2000 config utility there are no active panels listed in the panel list. If I select "Add" I get a popup message box that says "No More controller" [OK]

    I've tried this on no less than 4 windows XP machines and get the same result.

    Interestingly if I open a terminal program like HyperTerminal, open the com port, and touch the panel, I get random characters. So at the very least there is some kind of connectivity with the touch controller.

  2. #2
    Constant Bitrate
    Join Date
    Sep 2002
    Location
    Redmond, WA
    Posts
    171
    Btw, I've tried various combinations of powering the display or the computer first. Same result.

  3. #3
    I'm sorry, and you are....? frodobaggins's Avatar
    Join Date
    Jan 2003
    Location
    Ruston, LA
    Posts
    8,846
    send it back

  4. #4
    Constant Bitrate
    Join Date
    Sep 2002
    Location
    Redmond, WA
    Posts
    171
    I've already sent it back once. Still the same problem.

    Since then, I've opened it up for final mounting in my dash, so no more warranty.

  5. #5
    I'm sorry, and you are....? frodobaggins's Avatar
    Join Date
    Jan 2003
    Location
    Ruston, LA
    Posts
    8,846
    Originally posted by digitallexus
    I've already sent it back once. Still the same problem.

    Since then, I've opened it up for final mounting in my dash, so no more warranty.
    Well shame on you for modding something before you even knew it worked properly

    Of course if it happened twice, then maybe it's not defective, maybe your procedure is just borked somewhere.

  6. #6
    Maximum Bitrate osirisdon's Avatar
    Join Date
    Feb 2003
    Location
    South Florida
    Posts
    686
    HMMM?!?!? Maybe the OS? WinXP maybe not working properly with the drivers and or software? Have you tried with a diferent operating system?

  7. #7
    Newbie
    Join Date
    Feb 2003
    Location
    Los Angeles, CA
    Posts
    35
    why don't you try the driver available for download on their webiste:

    http://www.xenarc.com/download.html

  8. #8
    Variable Bitrate
    Join Date
    Mar 2002
    Posts
    325
    Hey,

    Mine works fine in WinXP. Try dling new drivers from their site.

    birrman54

  9. #9
    Constant Bitrate
    Join Date
    Sep 2002
    Location
    Redmond, WA
    Posts
    171

    Xenarc TSV Touch Screen problem (Solved)

    I tried various driver downloads again, and still could not get it to work in windows.

    I noticed there were DOS utilities for the display in the driver zip file. To eliminate the complexities of Windows, I tried booting up the good ole DOS prompt.

    After running the TPANEL.exe, the utility reported that no panel was found on any of the COM ports.

    Hmmm, it doesn't get any simpler than DOS, so probably not a driver issue.

    What next? Well since I have the xenarc case cracked open, the next thing was to check for basic continuity between the serial connector and the 4 connections to the touch screen controller board. The integration of the touch screen to the lcd is pretty hacky. A small touch screen controller board is covered in black tape to prevent shorting against the nearby backlight inverter! The small board is held in place by a big chunk of scotch tape. Nice. The board is connected via 4 hand soldered wires to 2 places on the main LCD controller board. 2 near the VGA/Serial connector, and 2 near the inverter. The controller also connects via ribbon cable to the resistive touch panel itself.

    Alright, 4 wires. I assume we have Power, Ground, SerialTx and Serial Rx. This means we are only dealing with 3 wires to the DB9 (as expected).

    DB9 Pin 2 (receive data) traces through to the touch controller
    DB9 ground traces through to the touch controller
    DB9 Pin 3 does not trace trough. Ah-ha! that's not normal.

    Next I found the very tiny trace coming from the vga/serial connector port. It traced back to the db9 pin3 just fine so the cable is good. Now, the wire to the touch controller does not directly connect to this connector. It travels a 16th of an inch to a post, normally occupied by a surface mount resistor and then via soldered wire to the touch controller. So I check continuity between the connector and the post. Nothing.

    Breaking out a bright light revealed the problem. The connector has a cold solder joint where it is attached to the PCB. Without this connection, no data can be trasmitted to the display.
    This explains why I could see data coming from the display when I used a simple terminal program and touched the display, but the driver couldn't fully recognize the panel.

    The really lame thing is I have actually sent this display back to Xenarc twice now. I am pretty disappointed they did not fix the touch screen problem during either of these RMA's. The first time I sent it back, they didn't do a thing to it, nothing. just shipped it back to me. The second time they finally at least swapped out the LCD to get rid of 3 bad pixels, but no touch controller fix.

    Well, time to break out the soldering iron and magnifying glass to see if I can fix the connector.

  10. #10
    Constant Bitrate
    Join Date
    Sep 2002
    Location
    Redmond, WA
    Posts
    171
    Success!!! A quick touch of the soldering iron to the cold solder joint and we have a good connection.

    I loaded up the EELY utility and clicked Add. At last!!!! Touch controller found. Yay!!

Page 1 of 4 1234 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •