Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: PSA: Xenarc 700IDT is not worth the money

  1. #1
    Low Bitrate
    Join Date
    Jun 2005
    Location
    Austin, Texas
    Posts
    105

    PSA: Xenarc 700IDT is not worth the money

    Why is it that every brand of LCD seems to have so many issues?

    I bought this May 15th, 2009, but I had issues with the rest of my setup, and didn't get around to installing it until about two weeks ago. Everything seemed fine until I was leaving work today--when I just got no VGA signal. The monitor would power off as if it had nothing hooked up. I figured it was the VGA cable, but when I got home, I played with it more, and discovered the ribbon cable is bad. As I fold the screen horizontal, it lights up and displays my signal... as I let the screen fold out, the signal AND power dies from the screen. Pushing on the ribbon cable as it folds tends to affect how far the screen can move while retaining image...

    I went with a manual, non-motorized screen, because I heard they were like tanks compared to the motorized ones. How is it that even the manual one died after 2 weeks of use? If I had to estimate, it's been opened/closed about 40 times. I would expect a product of this cost/caliber to make it to a few thousand iterations before hitting issues.

    I bought this from Mp3car.com--does that make me SOL, since it's beyond the 30-days? This is very frustrating, and I read reviews that nearly every kind of screen tends to fail, whether it's in-dash, or not... Why are these things so crappy? I've got an industrial LCD that I bought many years ago, that's been through hell and back, and it's still running strong... it's fallen off my desk, run in 150F+ car temperatures, and the list goes on.

    Is there such thing as a reliable in-car (in-dash, preferrably,) LCD? At this point, I might as well have just bought the LCD off ebay, since (from what I've read,) mp3car.com won't warranty the product anyhow... Would I be better off replacing the ribbon cable myself?

  2. #2
    Newbie
    Join Date
    Jul 2009
    Posts
    21
    Funny, i was just about to post a very similar problem.
    Mine is doing the exact same thing after around 1-2 months use. Tilting on the slightest angle makes the signal drop out altogether, or cause it to flicker and distort when it comes back on. Hell, even going over a bump makes it flick off.
    This is my first indash screen and it hasn't been subjected to any rough treatment so i have no idea how it's broken already.
    I have e-mailed Xenarc tech support with this issue (and one or two others) and am awaiting a response. I will keep you posted.

  3. #3
    North of the land of Hey Huns
    Auto Apps:loading...

    Join Date
    Jun 2004
    Location
    Westminster, MD
    Posts
    2,127
    The same thing happened to my idt after almost a year. Xenarc repaired it for free as they should for you as long as it has the holographic xenarc sticker on it. If it does not, then you bought it from an unauthorized reseller and you may be screwed
    "stop with the REINSTALLS, what do you think we got some lame-o installer!!!" - mitchjs
    RevFE
    My Shop

  4. #4
    Newbie
    Join Date
    Jul 2009
    Posts
    21
    Funnily enough, mine came from the MP3car store and it does not have that sticker. It has the XENARC words embossed, but this crummy looking sticker is around it. (perhaps the actual sticker peeled off at some point?)
    I have e-mailed the MP3 car store and given them a photo of it and will wait to hear what they say.

  5. #5
    Low Bitrate
    Join Date
    Jun 2005
    Location
    Austin, Texas
    Posts
    105
    I got an RMA # from Xenarc to send it back... I'm debating whether or not to request a non-moving screen that will last longer...

  6. #6
    Variable Bitrate Zogg's Avatar
    Join Date
    Apr 2005
    Location
    Plano, TX
    Posts
    311
    Mine starting failing right at the one year mark a few months ago. One of the screen colors started flaking off and on, and sometimes the screen wouldn't even power on. Of course I had modified the back panel, without taking the main unit apart though, so I figured they wouldn't repair it under warranty.

    So I ordered a new ribbon cable from Xenarc, around $15 if I remember correctly, and that fixed it. The new cable has a metal shield around it which really beefed it up, although it was harder to install than the non-shielded cable would have been.

    Just wanted you to know that they have improved the ribbon cable. Yours is newer though so it may have already had the newer cable. But I no longer close/open the unit all the time, I leave it open unless it needs to be in stealth mode, so as to minimize the cycling of the screen.
    Zotac N630I-D-E M/B w/ Nvidia 7100, E5300 cpu, Xenarc 700IDT, M2-ATX, XP, RR & DFX 5.1.

  7. #7
    Low Bitrate
    Join Date
    Jun 2005
    Location
    Austin, Texas
    Posts
    105
    So, I got the unit back with the new ribbon cable, and it worked for about 2 weeks. I started getting the following problems:

    - screen aligning improperly on every turn-on
    - vibrating intensely while driving, clacking etc
    - certain color spectrums failing in the screen. I checked my output from PC and it was fine. I tried wiggling cables, and all sorts of stuff
    - the screen stopped displaying VGA signal at all
    - the screen stopped powering on at all

    it took about a week, and maybe 15-20 open/closes from the time I started seeing color issues for the screen to completely die -- again.

    I'm definitely not impressed, and I have ANOTHER RMA pending now. This is getting ridiculous. I wish I could swap it out for a fixed-screen, but then I'd have to do custom glass work and it might get stolen, or otherwise get my car too much attention from the wrong people.

    I'd avoid this screen, personally.

  8. #8
    Low Bitrate
    Join Date
    Jun 2005
    Location
    Austin, Texas
    Posts
    105
    another reason to avoid this screen is that it is literally 4 inches longer than a standard DIN radio. it sticks out of my dash extremely far, and the mounting holes/etc to not provide a very standard installation. Things that are VERY easy to plan in advance when you are making a screen designed for a SPECIFIC opening.

  9. #9
    Low Bitrate
    Join Date
    Jun 2005
    Location
    Austin, Texas
    Posts
    105
    yawn, still waiting for the screen to come back

  10. #10
    Low Bitrate
    Join Date
    Jun 2005
    Location
    Austin, Texas
    Posts
    105
    Screen is back... for some reason it STILL flickers randomly, even on a bench power supply, or in the car with the engine turned off.

    Why would that be?

    Also, the switch that turns off the screen when you close the screen is not working... so when I close the screen it randomly triggers touch-screen signals...

    friggin AWESOME! wow... Is there such thing as a good 700IDT?

Page 1 of 2 12 LastLast

Similar Threads

  1. Xenarc 700IDT (700-IDT) Power Pinouts
    By cMags in forum LCD/Display
    Replies: 1
    Last Post: 01-21-2008, 06:22 PM
  2. Xenarc 700IDT - questions: Power? Documentation?
    By riptex in forum LCD/Display
    Replies: 1
    Last Post: 12-06-2007, 05:35 PM
  3. Trade: Have Xenarc TSV for Xenarc 700IDT
    By msreyes in forum Classified Archive
    Replies: 5
    Last Post: 11-27-2006, 10:11 AM
  4. Replies: 0
    Last Post: 10-07-2006, 09:37 PM
  5. Replies: 8
    Last Post: 03-05-2006, 06:33 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •