Has anyone ever got this working? I cannot for the life of me find the right Modeline. Either they drop down to 640x480 or scale up to 800x600. I did find one that nearly worked, but it was only a 56hz refresh rate (Modeline "800x480" 40.00 800 848 976 1056 480 637 641 672 -hsync -vsync). Can someone give me pointers to get the correct resolution and refresh rate?

Board: http://www.newegg.com/Product/Produc...82E16813121342
Ubuntu 10.04

Code:
Section "ServerLayout"
	Identifier     "X.org Configured"
	Screen         "Screen0"
EndSection

Section "Files"
	ModulePath   "/usr/lib/xorg/modules"
	FontPath     "/usr/share/fonts/X11/misc"
	FontPath     "/usr/share/fonts/X11/cyrillic"
	FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
	FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
	FontPath     "/usr/share/fonts/X11/Type1"
	FontPath     "/usr/share/fonts/X11/100dpi"
	FontPath     "/usr/share/fonts/X11/75dpi"
	FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
	FontPath     "built-ins"
EndSection

Section "Module"
	Load  "dri"
	Load  "dri2"
	Load  "extmod"
	Load  "dbe"
	Load  "glx"
	Load  "record"
EndSection

Section "Monitor"
Identifier   "Monitor0"
VendorName   "Xenarc"
ModelName    "700IDT"
HorizSync       28-38
VertRefresh     43-72
Option          "DPMS"
Modeline "800x480" 40.00 800 848 976 1056 480 637 641 672 -hsync -vsync
EndSection

Section "InputDevice"
Identifier "touchscreen0"
Driver "evtouch"
Option "Device" "/dev/input/event0"
Option "DeviceName" "touchscreen"
Option "SwapY" "1"
Option "SwapX" "0"
Option "ReportingMode" "Raw"
Option "SendCoreEvents"
EndSection 


EndSection
Section "Device"
	Identifier  "Card0"
	Driver      "intel"
	VendorName  "Intel Corporation"
	BoardName   "82945G/GZ Integrated Graphics Controller"
	BusID       "PCI:0:2:0"
	Option		"AccelMethod"	"UXA"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"

	DefaultDepth	24

	SubSection "Display"
		Modes "800x480"
	EndSubSection
EndSection