Results 1 to 5 of 5

Thread: Ebay touchscreen install giving me headaches! Whats wrong?

  1. #1
    Newbie
    Join Date
    Nov 2009
    Posts
    19

    Ebay touchscreen install giving me headaches! Whats wrong?

    I have a generic 7" ebay touchscreen, didnt come with drivers but I didnt need them on my previous carPC (used drivesoft box). The monitor works perfectly on the drivesoft system, installed right away through USB and never gave a single problem.

    Built another system from parts and of course now the touchscreen wont cooperate. I have installed drivers from eGalaxTouch, which from what Ive found they are supposed to be generic drivers.
    With eGalaxTouch installed I can finally get the computer to recognize & install the touchscreen, and it shows up under the "mouse & other pointing devices" and claims to be working properly.

    However it does nothing. I have tried all kinds of settings in the eGalaxTouch utility and have yet to get any response from touching the screen. I cannot calibrate or anything, and have no idea why its not working. Swap the old pc back in & it works just fine, so its not the monitor.

    Im no pc wizard, just know enough to get myself in trouble every now & then. lol
    Im sure it is probably something little or an overlooked setting, but I could really use some ideas.
    Last edited by audiophyle_247; 08-20-2011 at 12:49 AM.

  2. #2
    MySQL Error soundman98's Avatar
    Join Date
    Jan 2008
    Location
    on the border of northern IL/IN
    Posts
    5,848
    do you have a link to the screen you bought? or possibly a model number?

  3. #3
    Newbie
    Join Date
    Nov 2009
    Posts
    19
    I bought it a LONG time ago, this one looks just like it though. Price seems about the same if i remember right.
    http://www.ebay.com/itm/VM70-7-TFT-L...item27bcd303dd

    Have not seen any model numbers or anything on the monitor, and the box was generic with nothing but " 7" touchscreen monitor" printed on it.
    Googleing VM70 now & see a few related threads now, hopefully they contain answers.

  4. #4
    MySQL Error soundman98's Avatar
    Join Date
    Jan 2008
    Location
    on the border of northern IL/IN
    Posts
    5,848
    yes, sold by shortcircuit.com-- try emailing them for the driver(i thought the egalax driver worked with that one though).

    link to product page:
    http://www.short-circuit.com/product/VM70.html

    edit:

    found it under their support page:
    http://www.short-circuit.com/support/files.html

  5. #5
    Newbie
    Join Date
    Nov 2009
    Posts
    19
    Yeah, I found your first link after finding that ebay listing with a model number. Who'd have thought I should have searched for a similar model instead of generic drivers, lol. Knew it would be something dumb on my part.

    They have a driver download option at the bottom of the sale page, so I did and it worked like a charm!
    Interestingly enough the installation of the driver is identical to the eGalaxTouch except different colored screens and different logo. The options, settings, etc are all identical.

    New CarPC is finally up & running like a champ, now just have some little stuff to work out on the peripherals.
    Thanks for the help soundman.

Similar Threads

  1. Whats wrong here? No Power to PC
    By b12buddy in forum Newbie
    Replies: 6
    Last Post: 09-30-2009, 04:08 PM
  2. Touchscreen whats wrong
    By Charles1 in forum Input Devices
    Replies: 0
    Last Post: 05-07-2007, 08:00 PM
  3. Whats wrong
    By sourcewire in forum Car Audio
    Replies: 11
    Last Post: 11-27-2006, 03:24 PM
  4. whats wrong with my set up
    By refuse in forum Car Audio
    Replies: 9
    Last Post: 05-13-2006, 03:19 PM
  5. GPS giving wrong coordinates!
    By bmw318ISCoupe in forum GPS
    Replies: 9
    Last Post: 01-05-2006, 03:06 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •