Results 1 to 6 of 6

Thread: Touchscreen problems

  1. #1
    Low Bitrate
    Join Date
    Aug 2008
    Location
    SouthernOK
    Posts
    72

    Touchscreen problems

    Got a new motherboard/cpu combo, memory and SSD drive, but since installing my first unit I have lost the driver cd for my touchscreen. I have found 2 threads on this forum with drivers for my touchscreen but after installing either of them, the screen still does not respond to touching.

    This is the screen I have:
    http://www.gooddeals18.com/product/S...reen--VGA.html

    I'm sure it is something I'm doing wrong at this point, but after 3 days of hardware issues at work, I'm tired of dealing with problems.

    This thread has both of the drivers I have tried:
    http://www.mp3car.com/lcd-display/10...s-monitor.html

    Everything appears to install, so I restart and try to do a calibration. On the calibration is where it doesn't respond to touching.

    Any ideas?
    2004 F150 STX Heritage:
    Parts:
    ASUS E35M1-I Fusion AMD 1.6GHz DC ~$114
    Patriot 32GB SSD ~$80
    Kingston 4GB ~$25
    1/2" MDF - ~$15
    10" Samsung touch panel - ~270
    M2 Power Supply $85
    GPS Receiver ~ $36
    iGuidance ~100

  2. #2
    Maximum Bitrate kegobeer's Avatar
    Join Date
    Nov 2010
    Location
    Panama City Beach
    Posts
    627
    When you plug in the usb, do you hear the Windows usb notification sound? Do you have a touchscreen/hid-compliant entry in keyboards (or mice and other pointing devices)?

    Have you tried the older versions of the cartft drivers, or did you just try the newest ones?
    1999 Mercury Grand Marquis GS with: ASRock E350M1 w/4GB RAM, 80GB Intel SSD, Opus DCX3.120, Visteon HD Radio + HDR-USB, PL-18N wifi, OBDLink Scan Tool, BTA6210 BT, BU-353, Win 7 Ultimate, CF 4.0, Alpine MRP-F240 + MRP-T220, RF Punch 1572s, Kicker 8" Comp.

  3. #3
    Newbie
    Join Date
    Aug 2011
    Posts
    8
    Here is another post with a link to drivers,
    http://www.mp3car.com/maccar/128750-...ml#post1284633

  4. #4
    Low Bitrate
    Join Date
    Aug 2008
    Location
    SouthernOK
    Posts
    72
    Yes to all of the above. The oldest drivers I tried were 4.3.8.

    I know it isn't the screen as I can hook up the old harddrive and everything works.

    FIXED: I had to rollback all the way to the 4.0 drivers.
    Last edited by 04f150stx; 09-08-2011 at 08:00 PM.
    2004 F150 STX Heritage:
    Parts:
    ASUS E35M1-I Fusion AMD 1.6GHz DC ~$114
    Patriot 32GB SSD ~$80
    Kingston 4GB ~$25
    1/2" MDF - ~$15
    10" Samsung touch panel - ~270
    M2 Power Supply $85
    GPS Receiver ~ $36
    iGuidance ~100

  5. #5
    Maximum Bitrate kegobeer's Avatar
    Join Date
    Nov 2010
    Location
    Panama City Beach
    Posts
    627
    Hook up the other drive and connect the screen. Look in the device manager and find the device(s), then look at the driver section and find out where the drivers are. Copy them and paste them onto the new drive, then point the screen at the copied drivers and see if things start working. Plus, you can also google for the driver names you find and see if you can locate the drivers online.

    You might want to contact the company you bought the screen from, and ask for the drivers.

    Have you checked out this site?

    http://www.touch-base.com/

    There's a thread on this forum about drivers for your screen, and he found them at touch-base.
    Last edited by kegobeer; 09-08-2011 at 08:04 PM.
    1999 Mercury Grand Marquis GS with: ASRock E350M1 w/4GB RAM, 80GB Intel SSD, Opus DCX3.120, Visteon HD Radio + HDR-USB, PL-18N wifi, OBDLink Scan Tool, BTA6210 BT, BU-353, Win 7 Ultimate, CF 4.0, Alpine MRP-F240 + MRP-T220, RF Punch 1572s, Kicker 8" Comp.

  6. #6
    Low Bitrate
    Join Date
    Aug 2008
    Location
    SouthernOK
    Posts
    72
    kegobeer, I tried copying the drivers from the old drive, but they didn't work.

    After finally getting the 4.0 drivers to work, the screen has to be calibrated each time before it will work. Any ideas? edit: missed the 4.3.0 drivers the first time. After getting those everything works as it is supposed to.
    Last edited by 04f150stx; 09-18-2011 at 10:42 PM.
    2004 F150 STX Heritage:
    Parts:
    ASUS E35M1-I Fusion AMD 1.6GHz DC ~$114
    Patriot 32GB SSD ~$80
    Kingston 4GB ~$25
    1/2" MDF - ~$15
    10" Samsung touch panel - ~270
    M2 Power Supply $85
    GPS Receiver ~ $36
    iGuidance ~100

Similar Threads

  1. Problems with Touchscreen (Please help)
    By xdjneo in forum Power Supplies
    Replies: 5
    Last Post: 02-07-2007, 06:27 PM
  2. Touchscreen problems :(
    By Ryanmt in forum LCD/Display
    Replies: 4
    Last Post: 07-26-2005, 12:36 PM
  3. Replies: 1
    Last Post: 01-31-2005, 12:35 PM
  4. touchscreen problems
    By SilverJester in forum Input Devices
    Replies: 0
    Last Post: 06-25-2004, 09:52 PM
  5. Sharp Touchscreen problems
    By Cameron in forum General Hardware Discussion
    Replies: 4
    Last Post: 09-05-2000, 06:12 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •