Results 1 to 5 of 5

Thread: Lilliput 669GL-70NP/C/T-HB-RV Very Slow Startup

  1. #1
    Constant Bitrate besjr69's Avatar
    Join Date
    Feb 2011
    Posts
    123

    Lilliput 669GL-70NP/C/T-HB-RV Very Slow Startup

    I purchased this monitor about a yr and a half ago. I've been powering it using 12VDC from an M2-ATX. This morning when I started up there was a blank screen, but the PC booted up (I could hear music playing through the speakers). After powering down the PC, I inspected behind the monitor and didn't see anything unusual. After firing it back up, I just continue on to work. Halfway through my trip the monitor cut on and I was able to see the display and the touch screen worked. Everything was good. On my trip to lunch it did the same thing.

    It takes about 2min for the monitor to display anything. Then it will show a blue screen for the next 2mins or so. And finally, windows will display on the screen. Also, the remote nor the OSD is functional although it does show the input mode in the upper right corner ("DVI"). What could be causing this issue? Is it the control board?

    Bobby

  2. #2
    Constant Bitrate besjr69's Avatar
    Join Date
    Feb 2011
    Posts
    123
    FIXED: After chatting with Chris of Mo-Co-So.com, the issue has been identified. Somehow the IR sensor or the button board was shorted. I unplugged it and it works great. Already ordered and received a new board and IR sensor (<$20).

  3. #3
    Newbie
    Join Date
    Jan 2011
    Location
    Astoria NY
    Posts
    29
    Glad I found this - having the same problem. I'll try unplugging the IR sensor. Can't remember if it's just the ribbon cable or not
    Sent from my HD7 using Board Express

  4. #4
    Newbie
    Join Date
    Jan 2011
    Location
    Astoria NY
    Posts
    29
    Didn't work for me - I'll drop Chris a line from mo-co-so

  5. #5
    Newbie
    Join Date
    Jan 2011
    Location
    Astoria NY
    Posts
    29
    If you are still reading this - did you unplug your board before booting the computer? Mine doesn't come on at all with the IR/Board disconnected

Similar Threads

  1. Replies: 1
    Last Post: 07-26-2012, 05:17 PM
  2. Lilliput 669GL-70NP/C/T HDMI dramas- please help!
    By spewk1 in forum LCD/Display
    Replies: 7
    Last Post: 11-29-2011, 09:03 PM
  3. Computer won't read my Lilliput 669GL-70NP/C/T-HB-RV
    By Jesus Freak in forum LCD/Display
    Replies: 7
    Last Post: 06-01-2011, 06:17 PM
  4. Lilliput 669GL-70NP Extending HDMI Cable
    By cla1067 in forum LCD/Display
    Replies: 22
    Last Post: 01-04-2011, 06:23 PM
  5. Lilliput 7" Touchscreen 669GL-70NP/C/T
    By PrayingWithFire in forum LCD/Display
    Replies: 0
    Last Post: 06-30-2010, 03:25 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •