Page 3 of 3 FirstFirst 123
Results 21 to 29 of 29

Thread: Liliput 7" LED Capacitive "tablet style" screen? 779gl-70np-c-t

  1. #21
    Newbie
    Join Date
    Jul 2014
    Posts
    6
    I'd like to buy one of these, but I am not sure they will work with linux. Did anyone try this screen with the touch-base.com drivers? Their supported device list is a bit inconclusive. If someone could hook up this screen to a Windows computer and post the Vendor ID and Product ID as explained here that would be great:

    http://touch-base.com/documentation/...s.htm#_Windows

    Thanks!

  2. #22
    FLAC coucouillu's Avatar
    Join Date
    Nov 2004
    Location
    FRANCE
    Posts
    1,116
    Quote Originally Posted by heda View Post
    I'd like to buy one of these, but I am not sure they will work with linux. Did anyone try this screen with the touch-base.com drivers? Their supported device list is a bit inconclusive. If someone could hook up this screen to a Windows computer and post the Vendor ID and Product ID as explained here that would be great:

    http://touch-base.com/documentation/...s.htm#_Windows

    Thanks!

    Hi

    I have seen your PM for Vendor ID and Product ID
    I will do it this week end for you and would update previous post with this information

  3. #23
    FLAC coucouillu's Avatar
    Join Date
    Nov 2004
    Location
    FRANCE
    Posts
    1,116
    Post #19 updated with HID information
    HID\VID_1391&PID_2112&Col02\6&1c319c32&0&0001

    @raggedrebel92,
    Do you auto dimming working?
    For me not and when I analyze hardware conception, I am not estonished : there isn't any photo resistance!
    look at this picture
    http://www.mp3car.com/vbulletin/atta...530_153947.jpg
    from the right to left :
    - dual led for state indication
    - Infra Led receptor
    - missing composant but is desing on the PCB a LED (emission of light)

    please confirm on your side if your auto dimming is working well.
    thank you.

  4. #24
    Newbie
    Join Date
    Jul 2014
    Posts
    6
    I bought the Lilliput 779GL-70NP/C/T from mp3car through amazon. I was intending to use the screen with linux (openSUSE 13.1), and the screen appears to be fully supported! Getting the lcd panel to work in the native resolution appeared to be a bit cumbersome, but here are relevant pieces of the xorg.conf that works for me. Notice that the screen is detected as a "Idek Iiyama AS4637". In my setup it's connected to DFP-2, DFP-0 is the main notebook screen.

    Code:
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
        Option         "Xinerama" "0"
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "Idek Iiyama AS4637"
        HorizSync       24.0 - 80.0
        VertRefresh     56.0 - 85.0
        ModeLine       "800x480_60" 29.756 800 824 896 992 480 483 493 500 +hsync +vsync
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "Quadro FX 770M"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "Stereo" "0"
        Option         "UseEDIDFreqs" "FALSE"
        Option         "ModeValidation" "AllowNonEdidModes"
        Option         "metamodes" "DFP-0: nvidia-auto-select +0+0, DFP-2: 800x480_60 +1680+0 {Rotation=left}"
        SubSection     "Display"
            Depth       24
            Modes      "800x480_60"
        EndSubSection
    EndSection
    The touch screen is recognized by the kernel as an event device (evdev) and inititally shows up as a mouse pointer /dev/input/mouse2 and event /dev/input/event10 (or whatever number it get's assigned). Using the linux evtest en xinput commands you can disable the mouse pointer, and grab all the touch screen events directly from /dev/input/event10. The horizontal and vertical resolution are both 4096. evtest reports touches for 10 simultaneous fingers (slots)

    I added a udev rule in 99-touchscreen.rules to create a symlink to /dev/touchscreen:

    Code:
    SUBSYSTEM=="input", ATTRS{name}=="HID 1391:2112",  SYMLINK+="touchscreen", MODE="0666"
    A description of the available multitouch events can be found here:
    https://www.kernel.org/doc/Documenta...h-protocol.txt
    https://www.kernel.org/doc/Documenta...vent-codes.txt

    After playing with the screen for a while I noticed something weird: when using 2 or more fingers simultaneously, (i.e. zooming) sometimes one of the fingers did not generate a release (ABS_MT_TRACKING_ID = -1) event, and as a result it appears that one finger is still touching the screen, even though all fingers are off the screen. At first I thought this might be linux/driver specific, so I rebooted to Win7, and I saw the exact same behavior. This is best seen in the following screenshot from paint:

    Name:  lilliput_mt_no_release.jpg
Views: 137
Size:  74.8 KB

    I used two fingers to draw two lines. Every 2 seconds or so I lifted both fingers from the screen, and put them back about 1 cm further. After the third time, the second (bottom) finger did not release, and when I put the first (top) finger back on the screen paint connected the line as if the finger never left the screen.

    I'm wondering if this is just my device, or is this a general fault in the 779's firmware? To make sure I have returned my device and hope to receive a new one soon. If more people have encountered this behavior please let me know.

  5. #25
    FLAC coucouillu's Avatar
    Join Date
    Nov 2004
    Location
    FRANCE
    Posts
    1,116
    @heda,

    try with one finger under Windows+paint and fill all the screen.
    do you have a result like the video below?

  6. #26
    Newbie
    Join Date
    Jul 2014
    Posts
    6
    Just tried it, but I don't have the problem you are describing. I don't notice any dead zone. One finger dragging appears to work just fine.

    In the mean time I ordered a second Lilliput 779, which arrived on Thursday, and it appears to have exactly the same problem as the first one. I tried in WIn7, Win8 and Linux. So it is safe to say that it is an issue with all Lilliput 779 units. It's probably a firmware issue.

    I have contacted mp3car about this, and they have asked Lilliput to look into this. (As always, mp3car's customer support is great!). Lilliput has confirmed the issue, and they will provide a solution in two weeks. I'm not sure what they can do about this, maybe a new firmware. To Be Continued...

  7. #27
    FLAC coucouillu's Avatar
    Join Date
    Nov 2004
    Location
    FRANCE
    Posts
    1,116
    Quote Originally Posted by heda View Post
    Just tried it, but I don't have the problem you are describing. I don't notice any dead zone. One finger dragging appears to work just fine.

    In the mean time I ordered a second Lilliput 779, which arrived on Thursday, and it appears to have exactly the same problem as the first one. I tried in WIn7, Win8 and Linux. So it is safe to say that it is an issue with all Lilliput 779 units. It's probably a firmware issue.

    I have contacted mp3car about this, and they have asked Lilliput to look into this. (As always, mp3car's customer support is great!). Lilliput has confirmed the issue, and they will provide a solution in two weeks. I'm not sure what they can do about this, maybe a new firmware. To Be Continued...
    Hi Heda,
    Do you have any video of your issue, I would try to test the same case on my Lilliput 779.

    About the eventually firmware upgrade, please keep us informed.

  8. #28
    Newbie
    Join Date
    Jul 2014
    Posts
    6
    Hey, here are the requested videos of the multi-touch issue with the Lilliput 779.

    Windows7 + Paint:



    Let me know if you can reproduce this issue.

  9. #29
    Newbie
    Join Date
    Jul 2014
    Posts
    6
    And here is a second movie showing the multi-touch release issue with OpenSuSe 13.1 and a modified version of evdev:


Page 3 of 3 FirstFirst 123

Similar Threads

  1. Replies: 0
    Last Post: 09-13-2007, 01:28 PM
  2. Lilliput 7" 619GL-70NP "versa" Touchscreen 629GL-70NP
    By flavor4real in forum LCD/Display
    Replies: 0
    Last Post: 10-05-2006, 08:00 PM
  3. Replies: 2
    Last Post: 07-12-2006, 04:06 AM
  4. Liliput 7" or 8" Touch Screen
    By bertie in forum Newbie
    Replies: 5
    Last Post: 03-24-2005, 09:13 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •