Results 1 to 6 of 6

Thread: Xenarc lose connection???

  1. #1
    Newbie
    Join Date
    Dec 2003
    Location
    Birmingham, AL
    Posts
    39

    Xenarc lose connection???

    I just got my Xenarc in today. It works well, except for a lose connection where the connector (the one that houses the video inputs) connects to the back of the Xenarc unit.

    Is this a common problem?


    thanks,
    .brit

  2. #2
    Maximum Bitrate
    Join Date
    Jun 2003
    Location
    Atlanta/Augusta, GA
    Posts
    505
    Its always worked fine for me, but it is noted to be pretty fragile.

    Some have opted to solder the cable and ditch the connector all together.

  3. #3
    Newbie bradaland's Avatar
    Join Date
    Oct 2003
    Location
    Northeast, USA
    Posts
    32
    Hi!,
    Mine broke off! But As long as you ordered it from an authorized dealer or factory direct, they will take it back and replace the board inside under warranty.

    I'd take an extra precaution and buy some adhesive clamps for the cord in the back for tension relief. The design Xenarc has makes the cord bend and that causes too much pressure on the soldered input connector.

    Mine works great otherwise though!
    I did it all with a Dell and a Dock!
    DVD,MP3,TV,FM,GPS, XM,WiFi,CDRW,
    5.1 Dolby, 420 GB, 512 MB,1 Ghz,7" Touch

  4. #4
    Low Bitrate
    Join Date
    Jul 2003
    Location
    houston tx
    Posts
    99
    mine broke too but i sent it to them and they replaced it for free

  5. #5
    SMKFree liquid_smoke's Avatar
    Join Date
    Aug 2003
    Location
    Chicago
    Posts
    4,842
    yeah that connector is a piece of crap! mine broke in less than a week.

  6. #6
    Variable Bitrate kiztope's Avatar
    Join Date
    Nov 2002
    Location
    In the car
    Posts
    426
    have they fixed this with the updated screens?

Similar Threads

  1. FS: Xenarc 700TSV touch UXGA capable
    By cproaudio in forum Classified Archive
    Replies: 16
    Last Post: 01-20-2003, 07:38 AM
  2. Xenarc VGA or Composite
    By GTPmp3PC in forum LCD/Display
    Replies: 4
    Last Post: 01-14-2003, 11:15 AM
  3. Copilot lose GPS connection
    By cproaudio in forum GPS
    Replies: 10
    Last Post: 12-05-2002, 10:10 AM
  4. Xenarc Meta FAQ
    By Skippman in forum LCD/Display
    Replies: 0
    Last Post: 08-23-2002, 04:11 PM
  5. Xenarc 7" Touchscreen VGA Group Buy.
    By Skippman in forum LCD/Display
    Replies: 144
    Last Post: 07-27-2002, 11:52 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •