Results 1 to 7 of 7

Thread: I need help with Xenarc monitor.

  1. #1
    Variable Bitrate ryuandwings's Avatar
    Join Date
    Nov 2003
    Location
    TN
    Posts
    273

    Question I need help with Xenarc monitor.

    I have searched and did not see what I was looking for,
    so I need your help.

    I have Xenarc 700TS connected to m10000 and that was working perfectly
    for a few days. I was in the process of installing softwares then all sudden
    monitor turned black. The power LED is still solid when computer is on and
    flashes when computer is off like normal. I looked for any image to see if
    it was back light or something, but monitor is total darkness.

    Can anybody tell me what I can do to figure out the problem?
    Like I said earlier, I tried the search but I might have missed somethng
    so link to some posts would be good too. I need something... Please!

    If you need to know more detail I can find out more.

    Any help will be great. Thanks.

  2. #2
    Raw Wave Confused's Avatar
    Join Date
    Aug 2003
    Location
    Essex, England
    Posts
    2,224
    Did you change the screen resolution/refresh rate to anything weird?

    What happens if you connect the computer up to another display? Do you see anything? If so, try setting the screen resolution back to something like 800x600@60Hz, and see if the display shows a picture again. Can you also try hooking up the display to another computer?

    If neither of those work, then I guess it's time to contact Xenarc, their tech support is good, you will probably get Jimmy Hu dealing with it, he definately knows his stuff


    Good luck!


    Garry
    Co-Developer of A.I.M.E.E
    www.aimee.cc

  3. #3
    Low Bitrate
    Join Date
    Mar 2003
    Posts
    70
    I also had the same problem,but my knowledge is not that level I could resolve it by myself,

    I hope someone has a solution

  4. #4
    Variable Bitrate ryuandwings's Avatar
    Join Date
    Nov 2003
    Location
    TN
    Posts
    273
    Thanks for your advise, Garry.

    I tried your recommendations, but monitor is still nothing.
    When I connected to different monitor, everything worked
    fine.

    Well, I guess its time to contact Xenarc.
    I already voided the warrenty, do you think I can still get help?
    I guess I need to ask them that.

    Thanks for your help.

  5. #5
    Variable Bitrate
    Join Date
    Apr 2001
    Location
    NJ, USA
    Posts
    242
    Check the resolution, refresh rate, # of colors, etc. Since you already voided the warranty open the Xenarc and see if you broke the VGA port off the board. It could be something as simple as a broken pin or solder joint on the board. If you know someone with a Xenarc then try their cable. It could be a broken cable or monitor.

  6. #6
    Variable Bitrate ryuandwings's Avatar
    Join Date
    Nov 2003
    Location
    TN
    Posts
    273
    Quote Originally Posted by Tony S
    Check the resolution, refresh rate, # of colors, etc. Since you already voided the warranty open the Xenarc and see if you broke the VGA port off the board. It could be something as simple as a broken pin or solder joint on the board. If you know someone with a Xenarc then try their cable. It could be a broken cable or monitor.
    I really don't think it's the cable or connection.
    The reason I said that is because I don't see any light coming thru the
    back of LCD. When the panel was working, I could see white light at the back
    of LCD panel. Since I'm having problem with the LCD, I don't see any light
    at same location. Could this be blown backlight?

    Do anyone know how to replace Xenarc backlight?
    Or even how to get one?

    I have contacted Xenarc but no response yet. I guess I will give them more
    time after the new year.

  7. #7
    Variable Bitrate kiztope's Avatar
    Join Date
    Nov 2002
    Location
    In the car
    Posts
    426
    any news yet?

Similar Threads

  1. Xenarc owners READ THIS B4 U FRY YOUR MONITOR!!!!!!!!!
    By cproaudio in forum LCD/Display
    Replies: 6
    Last Post: 11-15-2004, 05:47 PM
  2. FS: Xenarc 700TSV touch UXGA capable
    By cproaudio in forum Classified Archive
    Replies: 16
    Last Post: 01-20-2003, 06:38 AM
  3. Xenarc Meta FAQ
    By Skippman in forum LCD/Display
    Replies: 0
    Last Post: 08-23-2002, 03:11 PM
  4. Disabling monitor in Win98
    By CaffeineAddict in forum LCD/Display
    Replies: 2
    Last Post: 11-12-2001, 07:33 PM
  5. Running windows with no monitor?
    By BLACKOUT in forum General Hardware Discussion
    Replies: 14
    Last Post: 03-14-2001, 10:56 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •