Page 1 of 4 1234 LastLast
Results 1 to 10 of 36

Thread: help lilliput wont power up anymore

  1. #1
    Low Bitrate
    Join Date
    May 2004
    Posts
    86

    help lilliput wont power up anymore

    i was trying to fit my touchscreen. and i opened the screen i only unpluged all the ribbon cable and put it back together and now i have no power to the lcd?

  2. #2
    Raw Wave wizardPC's Avatar
    Join Date
    Jun 2000
    Location
    Nashville
    Posts
    2,635
    those ribbon cables can be tricky. take it apart again, adjust the cables until the power comes back on, and THEN put it back together
    Debt as of 1/1/05: $34,354.48
    Debt as of July 4, 2007: $0.00 explanation
    I'M DEBT FREE!!
    I'm now a reasonably successful gunblogger.

  3. #3
    Low Bitrate
    Join Date
    May 2004
    Posts
    86
    i been trying for hours and the ribbon is all folded up...and i still have no power.. nothing light up cant turn it on or anything..

  4. #4
    Bowel movement jjh221's Avatar
    Join Date
    Dec 2003
    Location
    not sure yet.
    Posts
    1,645
    What do you mean no power? do you get power to the buttons? like the light on the side? does the screen light up?

  5. #5
    Low Bitrate
    Join Date
    May 2004
    Posts
    86
    i get no power at all..nothing light up..i open it to see if could fix the touchscreen problem..i just got this screen to 2days ago and now it messed up...hope i could fix it. all started with the damn touchscreen

  6. #6
    Constant Bitrate ashbosh's Avatar
    Join Date
    Mar 2004
    Posts
    115
    I had same problem(I removed the cables, shorted the cap in process, won't power up). I was able to power on, but still working on the ribbon cables. The problem was the little connector called DIP2. One of the pins were bent. The ckt was open. somehow that prevented the unit from powering up. Fixed that after couple of hours of troubleshooting. I suggest you check all your connections and check whether you are getting voltages across the components etc. Good luck.
    Current project ■■■■■■■■■■■■■■■■■■■■■■■■■■___ 85%
    Xenarc 700TS, Mobile Athlon 1GHz, Soyo K7VME, 30Gb HD, Slimline DVD drive, TB Santa Cruz, Opus 120W
    Holux G210

    03 Acura TL, Zapco & Precision Power amps, Adire Koda comps & EDesign 12" sub.

  7. #7
    Bowel movement jjh221's Avatar
    Join Date
    Dec 2003
    Location
    not sure yet.
    Posts
    1,645
    Ok first you opend it up and tried to fix it the first time and removed all the ribbons?
    Now you opened up again because it does not work and nothing comes on and not lights right?

  8. #8
    Bowel movement jjh221's Avatar
    Join Date
    Dec 2003
    Location
    not sure yet.
    Posts
    1,645
    yeah listen to ashbosh . all though i have know idea what the DIP2 is or the ckt.. but i do know is that you dont need the ribbons to at least power up the back light on the screen. Im have some problems with my lilliput with no video im just about to buy a new one....

  9. #9
    Low Bitrate
    Join Date
    May 2004
    Posts
    86
    i just got it to power up...took a while to line up the ribbon..but now i get a while screen. is that mean my ribbon is messup and i need a new one?

  10. #10
    Bowel movement jjh221's Avatar
    Join Date
    Dec 2003
    Location
    not sure yet.
    Posts
    1,645
    I have no clue what you mean.

    Try wigglin and jigglin it

Page 1 of 4 1234 LastLast

Similar Threads

  1. My low cost, easy to build power supply...
    By SkinnyBoy in forum Power Supplies
    Replies: 52
    Last Post: 09-27-2006, 07:10 PM
  2. mobo does not support resume on power loss
    By ashbosh in forum General Hardware Discussion
    Replies: 3
    Last Post: 05-18-2004, 10:49 AM
  3. Simple Idea for keeping power to inverter while cranking....
    By syclone477 in forum Power Supplies
    Replies: 1
    Last Post: 03-23-2004, 10:03 AM
  4. Brief power loss between ACC and start
    By Destin in forum General Hardware Discussion
    Replies: 20
    Last Post: 01-26-2001, 11:12 PM
  5. HELP!! Power Supply wont supply power
    By Saab in forum General Hardware Discussion
    Replies: 3
    Last Post: 08-28-2000, 10:33 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •