Results 1 to 6 of 6

Thread: Hot glue + xenarc inverter == unhappy.

  1. #1
    Maximum Bitrate fluffy2097's Avatar
    Join Date
    Jul 2003
    Location
    Fremont, CA
    Posts
    594

    Hot glue + xenarc inverter == unhappy.

    So I was just opening up my xenarc to reseat some connections, and the hot glue holding the speaker in place had attached itself to a component on my inverter, causing it to be torn off the board as I removed the back.

    So now I need a new inverter. A GS-INV940 to be exact.

    Anyone know where I can get one, anow how much they would cost? More importantly, Does anyone have one I can get within the week. I really need my screen functional. as I use it for work.
    A digital mind lost in an analog world.

    Learn to ask smart questions!
    http://www.catb.org/~esr/faqs/smart-questions.html

    My car PC: The Lost Cause!

  2. #2
    Raw Wave rando's Avatar
    Join Date
    Mar 2004
    Location
    Redondo Beach, CA
    Posts
    1,973
    Can you just reattach the component?

  3. #3
    MySQL Error jcdillin's Avatar
    Join Date
    May 2003
    Location
    Miami, FL
    Posts
    4,043
    Any way to get a pic, can't you just solder the part back on?

  4. #4
    Constant Bitrate JayKaye's Avatar
    Join Date
    Jan 2004
    Location
    Sydney, Australia
    Posts
    192
    ouch!

    www.ti.com (texas instruments)
    I did a search in TI, found nothing. I did a google search, again found nothing. Might be an idea to take the part to your local electronics warehouse an as someone there for a suitable replacement. Sounds to be like it isnt your average part (or part number).

    Car PC v1 - 1999 - 2000
    DOS 6.22 - MPXF - 2x16 LCD - 6.4GB
    Car PC v2 - 2002 - 2006
    XP - 7" wide/touch - GPS - Tank batt relay - 100GB
    Car PC v3 - 2008
    XP - 7" wide/touch - GPS - 802.11g - FM/XM - OBDII - WWW

    [||||||||||||||----] 80% complete

  5. #5
    Maximum Bitrate fluffy2097's Avatar
    Join Date
    Jul 2003
    Location
    Fremont, CA
    Posts
    594
    it's pretty ugly. I believe it was an inductor that got pulled off and it didn't even come off clean. I'll show it to my housemate whoes an electrical engineer. If anyone can fix it, he can. If he can't, I've already contacte DScustoms to see if I can't buy a new inverter card.
    A digital mind lost in an analog world.

    Learn to ask smart questions!
    http://www.catb.org/~esr/faqs/smart-questions.html

    My car PC: The Lost Cause!

  6. #6
    Maximum Bitrate fluffy2097's Avatar
    Join Date
    Jul 2003
    Location
    Fremont, CA
    Posts
    594
    Update! The inductor I tore off was custom wound. There's no way to reattach it. I need a new inverter. Does anyone out there have a xenarc with a broken screen or something I can canabilize?
    A digital mind lost in an analog world.

    Learn to ask smart questions!
    http://www.catb.org/~esr/faqs/smart-questions.html

    My car PC: The Lost Cause!

Similar Threads

  1. relay, inverter, fuse problems
    By cheesyhoward in forum Power Supplies
    Replies: 5
    Last Post: 06-02-2005, 09:04 AM
  2. Hot glue is evil.
    By fluffy2097 in forum Input Devices
    Replies: 0
    Last Post: 07-28-2004, 08:44 AM
  3. relay, inverter, fuse problems
    By cheesyhoward in forum General Hardware Discussion
    Replies: 6
    Last Post: 06-22-2004, 03:05 PM
  4. Hot glue in PCI slots
    By ppgt94 in forum General Hardware Discussion
    Replies: 10
    Last Post: 08-16-2001, 09:59 AM
  5. odd inverter behavior
    By jshrieve in forum General Hardware Discussion
    Replies: 30
    Last Post: 04-10-2001, 04:53 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •