Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: xenarc won't power on...help

  1. #11
    Variable Bitrate
    Join Date
    Apr 2001
    Location
    NJ, USA
    Posts
    242
    Well, did you replace the blown fuse yet?

    NEVER work on your carputer (or anything important actually) when you're dead tired and 1/2 asleep. I just popped my Xenarc's cherry too and now the damn internal fuse is blown. I've luckily got an electronics components store a few miles away. I'm hoping that's the fix. Let me know how you make out with the new fuse.
    P4 2.4GHz, Intel mobo w/onboard sound & video, 128MB memory, 100GB Seagate Momentus laptop drive, Xenarc 700TSV 7" touchscreen, IRman using Girder, 150W Opus dc/dc psu, Alpine CDA-9835 h/u, MBQuart speakers, Infinity 15" sub, MTX amps.

  2. #12
    FLAC Chairboy's Avatar
    Join Date
    Jan 2004
    Posts
    1,380
    You're obviously lying, Xenarcs don't break.
    Chrysler 300 - Fabricating
    http://hallert.net/

  3. #13
    Variable Bitrate
    Join Date
    Apr 2001
    Location
    NJ, USA
    Posts
    242
    Not if you're doing things right. (and not half asleep while doing an install)
    P4 2.4GHz, Intel mobo w/onboard sound & video, 128MB memory, 100GB Seagate Momentus laptop drive, Xenarc 700TSV 7" touchscreen, IRman using Girder, 150W Opus dc/dc psu, Alpine CDA-9835 h/u, MBQuart speakers, Infinity 15" sub, MTX amps.

  4. #14
    Variable Bitrate
    Join Date
    Feb 2004
    Location
    Green Bay, WI
    Posts
    342
    yes that was it!!!! It was really easy and xenarc sent me 2 fuses for free....since in my area i found 1 place that had them and they were $3 each and you had to buy 5. Online they were under $1 but the sites had a min. order of $10....Xenarc's customer service is the BEST!!!

  5. #15
    Variable Bitrate
    Join Date
    Apr 2001
    Location
    NJ, USA
    Posts
    242
    These screens' components are really, really sensitive. Just for the helluvit I added a fuse onto the ground wire to the screen. Glad to hear you got yours working again.
    P4 2.4GHz, Intel mobo w/onboard sound & video, 128MB memory, 100GB Seagate Momentus laptop drive, Xenarc 700TSV 7" touchscreen, IRman using Girder, 150W Opus dc/dc psu, Alpine CDA-9835 h/u, MBQuart speakers, Infinity 15" sub, MTX amps.

Page 2 of 2 FirstFirst 12

Similar Threads

  1. My low cost, easy to build power supply...
    By SkinnyBoy in forum Power Supplies
    Replies: 52
    Last Post: 09-27-2006, 06:10 PM
  2. New product - PC Power switch with wired remote
    By hd54321 in forum General Hardware Discussion
    Replies: 5
    Last Post: 03-08-2006, 10:48 PM
  3. Xenarc 700TS / hardwire power
    By dnorrell in forum LCD/Display
    Replies: 18
    Last Post: 11-29-2004, 10:04 AM
  4. Brief power loss between ACC and start
    By Destin in forum General Hardware Discussion
    Replies: 20
    Last Post: 01-26-2001, 10:12 PM
  5. HELP!! Power Supply wont supply power
    By Saab in forum General Hardware Discussion
    Replies: 3
    Last Post: 08-28-2000, 09:33 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •