Results 1 to 7 of 7

Thread: Killed my lcd already?

  1. #1
    Newbie
    Join Date
    Dec 2004
    Posts
    18

    Killed my lcd already?

    I bought a used psone lcd made by Interact, and taking it out of its case seems to have killed it. I had the seller demo it so I know it worked a couple days ago. Since then I've pulled it out of it's hideous plastic case and now I can't get any response out of it. When I put 7.5V to it (as it says on the case) nothing happens at all. There is a 7805 near the power leads so I checked that with the dmm and there is only 0.2V across the input leads. All the ribbon cables etc are snug so I'm starting to think I've blown something somehow.

  2. #2
    Newbie
    Join Date
    Dec 2004
    Posts
    18
    The multi-av connector only has five pins, which correspond to the composite and l/r audio inputs so I don't think the screen needs any other signal to wake up. I also measured the wall wart I was using and found it was putting out 7.8-8v, what kind of input tolerances do these kinds of lcds usually have?

  3. #3
    Newbie
    Join Date
    Dec 2004
    Posts
    18
    I guess no one has a similar screen.

    Anyways, I've tried it with a better 7.5V/1.5A supply and still no dice. No backlight, no onscreen controls (volume etc), no picture.

    I wish I had dropped it or somehow obviously broken it, then I wouldn't feel so bad.

  4. #4
    MySQL Error jcdillin's Avatar
    Join Date
    May 2003
    Location
    Miami, FL
    Posts
    4,043
    your only getting 0.2v at the input of the 7805? is anything getting hot? any small surface mount fuses that might have blown? I would look to make sure you dont see anything marked F1 or F2 on the board that could be a fuse.
    肚子笑痛了
    S60 Install

  5. #5
    Newbie
    Join Date
    Dec 2004
    Posts
    18
    Thanks a lot for your help.
    After scouring the board for fuses, the only thing I found marked F was something I thought was a capacitor but is apparently a resettable fuse.



    It checks out with a continuity tester but I don't know how to otherwise test one of these.

  6. #6
    MySQL Error jcdillin's Avatar
    Join Date
    May 2003
    Location
    Miami, FL
    Posts
    4,043
    what are the numbers on it? if it is indeed a fuse I would try bridging it, also using the center pin as ground of that 7805 what voltages are you getting on either side of it?
    肚子笑痛了
    S60 Install

  7. #7
    Newbie
    Join Date
    Dec 2004
    Posts
    18
    Well I'm a bit of an idiot. I didn't think to try and plug the speakers back in. It turns out that at least the audio part powers on and the volume controls work, but still nothing from the screen. I also must have been mismeasuring somehow because the voltages at the 7805 seem normal (~8v in 5v out).

Similar Threads

  1. 8.4" LCD in WRX dash.
    By Giuliano in forum LCD/Display
    Replies: 46
    Last Post: 08-07-2010, 04:27 AM
  2. Replies: 13
    Last Post: 12-24-2005, 06:14 PM
  3. Lilliput LCD monitors
    By 001 in forum LCD/Display
    Replies: 9
    Last Post: 10-27-2003, 03:46 PM
  4. lcd datasheet help
    By oddcomp in forum LCD/Display
    Replies: 1
    Last Post: 11-08-2002, 11:24 AM
  5. Replies: 4
    Last Post: 03-16-2002, 02:32 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •