Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: White Screen of death

  1. #1
    Newbie calvincbr's Avatar
    Join Date
    Nov 2004
    Location
    San Luis Obispo, CA
    Posts
    39

    White Screen of death

    I thought Bill Gate's blue screen of death was bad ... think again. The white screen of death hurts even more because that's 3 bills down the drain unless I can fix it by replacing the ribbon. Needless to say, it was a 7" lilliput w/ touch screen. I was so close to adding the final touch to my car, but like always, something bad happens. Not only do I get the white screen, but the colar that holds down the ribbon on the lcd side broke off. If anyone knows any cool fixes other than changing ribbon or lcd, let me know.

    http://www.calracin.com/carputer/sad.html

  2. #2
    Constant Bitrate
    Join Date
    Apr 2004
    Posts
    171
    its the egg... its not getting enough voltage.. not joking neither.. check the voltage after the egg and you'll see about 6v.. seems the regulator splits into 2 tracks so 1 goes down and you still get half the power through...

    Watch it though cause you run it too long and the extra current to turn the screen on needed from 6v will melt the cable.

    Best option.. hock it to your pc's power supply and see if it then works.. if it does then you'll want a new regulated power supply.

  3. #3
    Newbie calvincbr's Avatar
    Join Date
    Nov 2004
    Location
    San Luis Obispo, CA
    Posts
    39
    Quote Originally Posted by Skuzzle
    its the egg... its not getting enough voltage.. not joking neither.. check the voltage after the egg and you'll see about 6v.. seems the regulator splits into 2 tracks so 1 goes down and you still get half the power through...

    Watch it though cause you run it too long and the extra current to turn the screen on needed from 6v will melt the cable.

    Best option.. hock it to your pc's power supply and see if it then works.. if it does then you'll want a new regulated power supply.
    I was trying to revive the VGA and VIDEO screen using AC power with no luck. And the egg no longer connects to the cig lighter, it connects to the ACC.

  4. #4
    Newbie
    Join Date
    Jun 2004
    Location
    Netherlands
    Posts
    3
    Quote Originally Posted by calvincbr
    Not only do I get the white screen, but the colar that holds down the ribbon on the lcd side broke off.

    I've got that problem also. I'm curious if there's a solution to this other than soldering a new connector.

  5. #5
    Variable Bitrate
    Join Date
    Oct 2004
    Location
    Netherlands
    Posts
    382
    Quote Originally Posted by Ibiza96
    I've got that problem also. I'm curious if there's a solution to this other than soldering a new connector.
    i just sent mine back for warrentee :P
    my destinator map resource down permanently

  6. #6
    Low Bitrate
    Join Date
    Nov 2002
    Location
    Vermont, yay.
    Posts
    84
    I'd suggest just trying a new ribbon cable if you haven't already... I'm also in the final stages of my project and was fiddling around a little too much with the ribbon cable, and ended up bending it, resulting in the white screen. Ordered a $6 cable from digitalww.com, arrived in 3 days, and fixed the problem right away.

  7. #7
    Newbie
    Join Date
    Sep 2003
    Posts
    14
    I broke off that damn latch too so now I have the WSOD! Someone suggested using duct tape and a glue gun to fix the problem- haven't tried it though....

    -Mike

  8. #8
    Newbie calvincbr's Avatar
    Join Date
    Nov 2004
    Location
    San Luis Obispo, CA
    Posts
    39
    Lets hope that the new cable will fix the problem.

  9. #9
    Newbie
    Join Date
    Jun 2004
    Location
    Netherlands
    Posts
    3
    Just ordered a new cable. Maybe i'm gonna use hot glue to keep it in place instead of tape.

  10. #10
    Newbie
    Join Date
    Jul 2004
    Posts
    2
    I too, have the WSOD. I tested continuity of the ribbon, and it was perfect. Do I still need to get another ribbon cable to rectify this problem?

Page 1 of 2 12 LastLast

Similar Threads

  1. Anyone care to help me with a mystery screen?
    By Rover_Eli in forum LCD/Display
    Replies: 34
    Last Post: 03-27-2007, 08:34 PM
  2. Problem with Lilliput and white screen
    By 99C5Vert in forum LCD/Display
    Replies: 1
    Last Post: 12-16-2004, 12:08 PM
  3. prob (white screen) with datalux m1023 and sharp lcd
    By Question in forum LCD/Display
    Replies: 7
    Last Post: 07-11-2003, 07:32 PM
  4. Replies: 13
    Last Post: 07-02-2002, 11:54 AM
  5. NEC Versa M/75 Laptop TFT screen w/touch
    By Macgyver777 in forum LCD/Display
    Replies: 23
    Last Post: 03-24-2002, 03:14 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •