Page 1 of 6 123456 LastLast
Results 1 to 10 of 54

Thread: ARGH!!! Xenarc burning smell!!

  1. #1
    Low Bitrate Anees's Avatar
    Join Date
    Feb 2005
    Location
    UK, North West
    Posts
    101

    Angry ARGH!!! Xenarc burning smell!! (Now with PICS!)

    Hi Guys,

    I have got to the stage where I am puttiing my Xenarc 7" 700TSV into the Lexus Sat Nav housing. The screen will then pop-up when the ignition is ON and fold down when the ignition is OFF.

    Trouble is that after about 20minutes use I can smell BURNING!
    The touchscreen has also gone crazy and the housing feels warm to the touch.

    What could be causing the problem? The Lexus OEM housing provides more space and ventalation then the standard Xenarc casing.

    The only metal thing inside the OEM housing is the motor - but that is away from the screen and I have covered it with insulating tape - just to be on the safe side.

    Am I shorting something?

    Please help!

    Thanks,
    Anees

  2. #2
    MySQL Error jcdillin's Avatar
    Join Date
    May 2003
    Location
    Miami, FL
    Posts
    4,043
    pictures?
    肚子笑痛了
    S60 Install

  3. #3
    Low Bitrate Anees's Avatar
    Join Date
    Feb 2005
    Location
    UK, North West
    Posts
    101
    I'm at work so not really.

    Here is a pic of the housing with the screen in (not my car but exactly the same):



    Housing on its own:


  4. #4
    Newbie Kostas GOLF V's Avatar
    Join Date
    Feb 2005
    Posts
    20
    hhmmm i think that there should be some holes to let some air to move inside...

    the originac Xenarc "case" has a lot of them... don't you think?

  5. #5
    Low Bitrate Anees's Avatar
    Join Date
    Feb 2005
    Location
    UK, North West
    Posts
    101
    At the back of the housing their does seem to be plenty of ventalation space.

  6. #6
    MySQL Error jcdillin's Avatar
    Join Date
    May 2003
    Location
    Miami, FL
    Posts
    4,043
    you sure something isnt getting pinched? like some wires? maybe if you can take it out and get some pictures inside, might be of help.

    but if the casing is getting really warm to the touch that would tell me that it isnt getting enough air. Might need to add a small fan at the bottom to get the air moving
    肚子笑痛了
    S60 Install

  7. #7
    cheap custom title JC-S60's Avatar
    Join Date
    Mar 2004
    Location
    Ghent - Belgium
    Posts
    1,863
    I had an older xenarc burn up on me before (backlight inverter)...

    No reason and I got another one (which I burned by reverse polarizing, yeah!)

    Got a new xenarc now and it works great. Also got the dww 700m and it blew up on me the first time I connected it, athough everything seems to work as it should, despite the bang and smoke I had (haven't tested the TS an TV yet)...

    And then this weekend, my 13,8v powersupply blew too!!!



    Just let the m*ther*****er burn! ahem, sorry

  8. #8
    Low Bitrate Anees's Avatar
    Join Date
    Feb 2005
    Location
    UK, North West
    Posts
    101
    Quote Originally Posted by JC-S60
    I had an older xenarc burn up on me before (backlight inverter)...

    No reason and I got another one (which I burned by reverse polarizing, yeah!)

    Got a new xenarc now and it works great. Also got the dww 700m and it blew up on me the first time I connected it, athough everything seems to work as it should, despite the bang and smoke I had (haven't tested the TS an TV yet)...

    And then this weekend, my 13,8v powersupply blew too!!!



    Just let the m*ther*****er burn! ahem, sorry
    Seriously - WOW!!!
    Stay away from me!!! Don't want your bad electrical carma!

  9. #9
    Low Bitrate Anees's Avatar
    Join Date
    Feb 2005
    Location
    UK, North West
    Posts
    101
    Originally Posted by Darth Scouse
    Can you post some pics of inside the casing as i would like to know where the inverter is mounted. also make sure you have not damaged the silicone insulation on the wires from the inverter as it is very fragile and coul dbe causing a short.

    Try just running the backlight (disconnect the FFC ribbon cable) and see what happens then try the other way round by disconnecting the inverter from the controller (do not run the inverter with no load). Ventilation should not be a kajor issue but if it is you could try spacing the sceen back with some 1-2mm tabs around the edges to allow air to pass out around the screen or try and use a fan to vent the encolusure down through the dash if you can. (i suspect you dont want to put holes in the top of your nice flip up holder).

    i cant believe it is a purely ventilation thing but you never know.

    Andy

    PS I hate you as I want your car with twin Xenarcs int he dash like you are doing!
    .

  10. #10
    Low Bitrate Anees's Avatar
    Join Date
    Feb 2005
    Location
    UK, North West
    Posts
    101
    @Darth Scouse

    I'll get some pics up Wednesday - I won't get chance now to play with it until Wednesday after work!

    However I have a feeling what the problem may be....

    I have a wooden rod covered in insulating tape running across the back of the Xenarc display to hold it in place.

    The instructions I followed originally wanted me to use a brass rod, but a wooden scewer ( ) was all I could find.

    He is a pic from the instructions:


    The screen in a picture is not a Xenarc. The rod is quite tight across the back of the Xenarc in my housing...maybe I squashed something?
    Attached Images Attached Images  

Page 1 of 6 123456 LastLast

Similar Threads

  1. That new car smell...
    By PatO in forum Off Topic
    Replies: 33
    Last Post: 04-01-2005, 03:29 AM
  2. that burning smell
    By pimpJ in forum Car Audio
    Replies: 38
    Last Post: 11-09-2004, 01:14 AM
  3. Replies: 88
    Last Post: 09-15-2004, 06:38 PM
  4. Xenarc Meta FAQ
    By Skippman in forum LCD/Display
    Replies: 0
    Last Post: 08-23-2002, 04:11 PM
  5. Burning smell?
    By r0cket- in forum General Hardware Discussion
    Replies: 8
    Last Post: 03-26-2001, 06:58 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •