Results 1 to 9 of 9

Thread: Please help! I think I broke my new Liliput TV.. (kind of long)

  1. #1
    Newbie
    Join Date
    Jun 2005
    Posts
    4

    Please help! I think I broke my new Liliput TV.. (kind of long)

    1st and foremost, I did read the FAQ at the top of the page... there is a lot of good info in there. I wish I had found this site a month ago before I started this project.

    Hey guys, I am not a Noob when it comes to electronics, infact I am rather technical... BUT LCD TV's I know hardly nothing about. I have been working on a huge project for my car, it has taken over a month to complete. I was ready to install the TV a few days ago, but I wanted to test it before I installed it. Well, it does not turn on.

    (Problem 1)
    I am going insane. When it was new (2 weeks ago) it worked perfect. I had to take it completely apart to install it. In doing so, I didn't realize that the ribbon cables had clips and I pulled out the ribbon, and the clip came off and it broke. Now the cable does not stay in on its own. I tried plugging it in and holding the ribbon down with my finger very tightly, but it didn't turn on.

    (Problem 2)
    this is a possible problem... but I am not sure if it matters... maybe someone knows? I de-soldered the RF sensor so I can extend the wires. I broke the RF sensors prong by accident... would that cause the TV not to turn on? I know it shouldn't, but maybe it completes a circuit or something?

    (Problem 3) I tried my best not to touch any of the electronics on the TV, but I know I did a couple of times... should it still be ok?

    The TV will not turn on, and none of the blue lights will come on for the buttons. I am seriously at my wits end with this.... I really do not want to buy another one... can anyone think of anything I can do?

    THANK YOU ALL FOR YOUR HELP IN ADVANCE! If you can get it working for me, Iíll forever be in debt to you guys!

    BTW, if anyone wants to see my project and fiberglasing for the unit... just let me know.

  2. #2
    Maximum Bitrate neon_eddy's Avatar
    Join Date
    Nov 2004
    Location
    Ham Lake, MN
    Posts
    598
    you could try soldering the ribbon .. or making a plug for it.. via DB9 male/female connectors from RS .. to allow easy disconnect later..

    my bet is it has to do with the ribbon..

    that's why I use a magna-doodle..
    Shawn



    Check out my web company Minneapolis Web Designer | MODx Web Design - Himmelberger Design


  3. #3
    MySQL Error jcdillin's Avatar
    Join Date
    May 2003
    Location
    Miami, FL
    Posts
    4,043
    yeah, that pin missing from the IR sensor would not have any effect on the unit powering up, but if you broke the clip on the ribbon cable, holding it down will not be enough to make contact. It needs that little clip to compress the cable onto the contacts. Most of my ribbon cable clips are broken, but the nice part is that they still will lock down if you really try.

    And if touching the circuit board damaged them, all mine would have been toast a long time ago.
    肚子笑痛了
    S60 Install

  4. #4
    Newbie
    Join Date
    Jun 2005
    Posts
    4
    so there is still hope for me then? how do i "really try" to lock them down?

    I do not want to even attempt to solder wires to each pin... the space is way to small. do any of you live In rhode island? I am willing to pay for someone to help me...

    but if not, any ideas for me?

  5. #5
    Constant Bitrate studmonk3y's Avatar
    Join Date
    Feb 2004
    Location
    Honolulu, HI
    Posts
    157
    the smaller ribbon cable has to be plugged in all the way to one side, the larger one has to be plugged in completely and just right. They're very touchy so play around with positioning them. I'd recommend hot glue to secure it in place

  6. #6
    Newbie
    Join Date
    Jun 2005
    Posts
    4
    ok thats good to know! I am assuming that the smaller ribbon needs to be pluged in in order for the unit to turn on, right? I am going to see if i can find that clip anywhere. if not, can i jam someting in there to keep the ribbon down? what would you sugest?

    I am sorry for all the questions, but i just hope tha t i can fix this... I have wanted a carputer for a long time... and i am so close to getting it working... i just need to get the tv up and running!

  7. #7
    Constant Bitrate anik321's Avatar
    Join Date
    Nov 2004
    Posts
    143
    1. studmonk3y gives a good solution: plug the cable in and hold it down by hand(with everything else already plugged in).See if you can get the screen to turn on. Once you have it right, use hot glue or even just electrical tape to attach the cable onto the PCB board. Its a quick easy solution.

    If it fails, 'hot air soldering' - very precise and clean if you know what you are doing. but buying a hot air soldering station might be a little expensive. (walk into the EE lab of a nearby college! and tell them you are from MechE and you need help)

    2. the IR module does not have any effect on the screen turning on. But if you want to replace it, find out the modulation frequency it works on - else it wont respond to the remote control (if you still plan to use it)

    be patient and work slowly

  8. #8
    MySQL Error jcdillin's Avatar
    Join Date
    May 2003
    Location
    Miami, FL
    Posts
    4,043
    you might try a very thin peice of cardboard or something along those lines
    肚子笑痛了
    S60 Install

  9. #9
    Newbie
    Join Date
    Jun 2005
    Posts
    4
    Quote Originally Posted by anik321
    1. studmonk3y gives a good solution: plug the cable in and hold it down by hand(with everything else already plugged in).See if you can get the screen to turn on. Once you have it right, use hot glue or even just electrical tape to attach the cable onto the PCB board. Its a quick easy solution.

    If it fails, 'hot air soldering' - very precise and clean if you know what you are doing. but buying a hot air soldering station might be a little expensive. (walk into the EE lab of a nearby college! and tell them you are from MechE and you need help)

    2. the IR module does not have any effect on the screen turning on. But if you want to replace it, find out the modulation frequency it works on - else it wont respond to the remote control (if you still plan to use it)

    be patient and work slowly

    I've tried holding it down, but i didnt try to wiggle it because i dint want something to fry/short out.

    i checked out hot air soldering, and for the price i could just but another tv.. or two! lol. i dont go to school, so thats not an option.. lol

    how would i find out the frequency it works on? i didn't see any marks on the IR unit, could i call liliput themselfs? thanks again guys

Similar Threads

  1. Embedding BSPlayer
    By Needstorage in forum Software & Software Development
    Replies: 17
    Last Post: 01-29-2007, 03:15 AM
  2. How do i accomplish this?
    By Danceheaven in forum Software & Software Development
    Replies: 11
    Last Post: 07-19-2004, 04:48 PM
  3. Should I put a battery between ITPS and PS? kind of long
    By NoNonsense in forum Power Supplies
    Replies: 0
    Last Post: 07-14-2004, 09:50 AM
  4. never lose focus
    By marsjell in forum Software & Software Development
    Replies: 21
    Last Post: 08-12-2002, 01:18 PM
  5. serial port shutdown signal
    By moahdib in forum Power Supplies
    Replies: 12
    Last Post: 08-03-2001, 08:52 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •