Results 1 to 3 of 3

Thread: lilliput won't power up at all

  1. #1
    Variable Bitrate nadir_s's Avatar
    Join Date
    Oct 2002
    Location
    San Jose, CA
    Posts
    289

    lilliput won't power up at all

    i've reseated the ribbon many times ... no luck.

    I don't even get teh red standby light.

    It working perfectly fine until my friend took the front frame off to fab. it into his car stereo bezel.

    Do i keep tryin to reseat these cables?
    [ 5-spd 1996 M A X i M A SE ]

  2. #2
    Variable Bitrate nadir_s's Avatar
    Join Date
    Oct 2002
    Location
    San Jose, CA
    Posts
    289
    err figured it out.

    Just saw it in the FAQs too haha.


    FYI anyone who have issues like this again .. make sure the smaller ribbon is seated all the way to the right of the connector on the LCD panel.

    i love this forum
    [ 5-spd 1996 M A X i M A SE ]

  3. #3
    Newbie
    Join Date
    Jun 2004
    Posts
    12
    If you have a volt meter switch it the 12 volt mode and see if you still have power after the fuse. Its the little square block with a 1A near the power connecter on the back of the PCB.

Similar Threads

  1. xenarc first impressions, tried lilliput before
    By emdzey01 in forum LCD/Display
    Replies: 7
    Last Post: 06-09-2005, 06:26 PM
  2. Replies: 4
    Last Post: 04-11-2005, 03:33 PM
  3. xenerac and lilliput power cables
    By fallnangel in forum LCD/Display
    Replies: 8
    Last Post: 01-15-2005, 10:49 AM
  4. Lilliput Power Polarity?
    By aleromaster in forum LCD/Display
    Replies: 8
    Last Post: 09-10-2004, 02:22 PM
  5. Possible to power lilliput this way?
    By ScorpionV in forum LCD/Display
    Replies: 9
    Last Post: 07-19-2004, 07:39 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •